﻿<!DOCTYPE html>
<html lang="en-US" prefix="og: https://ogp.me/ns#">
<head>
	<meta charset="UTF-8">
	<link rel="profile" href="https://gmpg.org/xfn/11">
	<title>ESP8266 NodeMCU Stepper Motor (28BYJ-48 and ULN2003 Driver) | Random Nerd Tutorials </title><link rel="preload" href="https://i1.wp.com/randomnerdtutorials.com/wp-content/uploads/2021/07/28BYJ-48-connected-to-ULN2003-Motor-Driver-01-module.jpg?resize=750%2C422&amp;quality=100&amp;strip=all&amp;ssl=1" as="image" srcset="https://i1.wp.com/randomnerdtutorials.com/wp-content/uploads/2021/07/28BYJ-48-connected-to-ULN2003-Motor-Driver-01-module.jpg?w=750&amp;quality=100&amp;strip=all&amp;ssl=1 750w, https://i1.wp.com/randomnerdtutorials.com/wp-content/uploads/2021/07/28BYJ-48-connected-to-ULN2003-Motor-Driver-01-module.jpg?resize=300%2C169&amp;quality=100&amp;strip=all&amp;ssl=1 300w" sizes="(max-width: 750px) 100vw, 750px"><link rel="preload" href="https://i0.wp.com/randomnerdtutorials.com/wp-content/uploads/2021/07/28BYJ-48-Stepper-Motors.jpg?resize=750%2C422&amp;quality=100&amp;strip=all&amp;ssl=1" as="image" srcset="https://i0.wp.com/randomnerdtutorials.com/wp-content/uploads/2021/07/28BYJ-48-Stepper-Motors.jpg?w=750&amp;quality=100&amp;strip=all&amp;ssl=1 750w, https://i0.wp.com/randomnerdtutorials.com/wp-content/uploads/2021/07/28BYJ-48-Stepper-Motors.jpg?resize=300%2C169&amp;quality=100&amp;strip=all&amp;ssl=1 300w" sizes="(max-width: 750px) 100vw, 750px"><link rel="preload" href="https://i1.wp.com/randomnerdtutorials.com/wp-content/uploads/2017/10/header-200.png?w=828&amp;quality=100&amp;strip=all&amp;ssl=1" as="image" srcset="" sizes=""><link rel="preload" href="https://i2.wp.com/randomnerdtutorials.com/wp-content/uploads/2021/08/ESP8266-Stepper-Motor-Tutorial-Arduino-IDE.jpg?resize=828%2C466&amp;quality=100&amp;strip=all&amp;ssl=1" as="image" srcset="https://i2.wp.com/randomnerdtutorials.com/wp-content/uploads/2021/08/ESP8266-Stepper-Motor-Tutorial-Arduino-IDE.jpg?w=1280&amp;quality=100&amp;strip=all&amp;ssl=1 1280w, https://i2.wp.com/randomnerdtutorials.com/wp-content/uploads/2021/08/ESP8266-Stepper-Motor-Tutorial-Arduino-IDE.jpg?resize=300%2C169&amp;quality=100&amp;strip=all&amp;ssl=1 300w, https://i2.wp.com/randomnerdtutorials.com/wp-content/uploads/2021/08/ESP8266-Stepper-Motor-Tutorial-Arduino-IDE.jpg?resize=1024%2C576&amp;quality=100&amp;strip=all&amp;ssl=1 1024w, https://i2.wp.com/randomnerdtutorials.com/wp-content/uploads/2021/08/ESP8266-Stepper-Motor-Tutorial-Arduino-IDE.jpg?resize=768%2C432&amp;quality=100&amp;strip=all&amp;ssl=1 768w" sizes="(max-width: 828px) 100vw, 828px"><link rel="preload" href="https://randomnerdtutorials.com/wp-content/uploads/2016/04/logornt.png" as="image" srcset="" sizes=""><style id="flying-press-css">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</style><link rel="stylesheet" media="print" onload="this.media='all'" href="https://randomnerdtutorials.com/wp-content/cache/flying-press/randomnerdtutorials.com/3d1bea95f8f0.post.used.css"><link rel="preload" href="https://randomnerdtutorials.com/wp-content/themes/generatepress/assets/fonts/generatepress.woff2" as="font" type="font/woff2" crossorigin="">

		<!-- All in One SEO 4.1.3.1 -->
		<meta name="description" content="Learn how to control a stepper motor with the ESP8266 NodeMCU. We'll use the 28BYJ-48 unipolar stepper motor with the ULN2003 motor driver. It will be programmed using Arduino IDE.">
		<meta name="keywords" content="esp8266 nodemcu stepper motor 28byj-48 uln2003 driver,esp8266 nodemcu stepper motor 28byj-48 uln2003 driver arduino ide core,esp8266 stepper motor 28byj-48 uln2003 driver arduino">
		<link rel="canonical" href="https://randomnerdtutorials.com/esp8266-nodemcu-stepper-motor-28byj-48-uln2003/">
		<meta property="og:site_name" content="Random Nerd Tutorials">
		<meta property="og:type" content="article">
		<meta property="og:title" content="ESP8266 NodeMCU Stepper Motor (28BYJ-48 and ULN2003 Driver) | Random Nerd Tutorials ">
		<meta property="og:description" content="Learn how to control a stepper motor with the ESP8266 NodeMCU. We'll use the 28BYJ-48 unipolar stepper motor with the ULN2003 motor driver. It will be programmed using Arduino IDE.">
		<meta property="og:url" content="https://randomnerdtutorials.com/esp8266-nodemcu-stepper-motor-28byj-48-uln2003/">
		<meta property="og:image" content="https://randomnerdtutorials.com/wp-content/uploads/2021/08/ESP8266-Stepper-Motor-Tutorial-Arduino-IDE.jpg">
		<meta property="og:image:secure_url" content="https://randomnerdtutorials.com/wp-content/uploads/2021/08/ESP8266-Stepper-Motor-Tutorial-Arduino-IDE.jpg">
		<meta property="og:image:width" content="1280">
		<meta property="og:image:height" content="720">
		<meta property="article:published_time" content="2021-08-31T10:54:37Z">
		<meta property="article:modified_time" content="2021-08-31T11:19:38Z">
		<meta name="twitter:card" content="summary">
		<meta name="twitter:domain" content="randomnerdtutorials.com">
		<meta name="twitter:title" content="ESP8266 NodeMCU Stepper Motor (28BYJ-48 and ULN2003 Driver) | Random Nerd Tutorials ">
		<meta name="twitter:description" content="Learn how to control a stepper motor with the ESP8266 NodeMCU. We'll use the 28BYJ-48 unipolar stepper motor with the ULN2003 motor driver. It will be programmed using Arduino IDE.">
		<meta name="twitter:image" content="https://randomnerdtutorials.com/wp-content/uploads/2021/08/ESP8266-Stepper-Motor-Tutorial-Arduino-IDE.jpg">
		<meta name="google" content="nositelinkssearchbox">
		<script type="application/ld+json" class="aioseo-schema">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</script>
		<!-- All in One SEO -->

<link rel="dns-prefetch" href="//scripts.mediavine.com">
<link rel="dns-prefetch" href="//s.w.org">
<link rel="dns-prefetch" href="//v0.wordpress.com">
<link rel="dns-prefetch" href="//i0.wp.com">
<link rel="dns-prefetch" href="//i1.wp.com">
<link rel="dns-prefetch" href="//i2.wp.com">
<link rel="alternate" type="application/rss+xml" title="Random Nerd Tutorials » Feed" href="https://randomnerdtutorials.com/feed/">
<link rel="alternate" type="application/rss+xml" title="Random Nerd Tutorials » Comments Feed" href="https://randomnerdtutorials.com/comments/feed/">
<link rel="alternate" type="application/rss+xml" title="Random Nerd Tutorials » ESP8266 NodeMCU with Stepper Motor (28BYJ-48 and ULN2003 Motor Driver) Comments Feed" href="https://randomnerdtutorials.com/esp8266-nodemcu-stepper-motor-28byj-48-uln2003/feed/">
		<script>
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/randomnerdtutorials.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.8"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([10084,65039,8205,55357,56613],[10084,65039,8203,55357,56613])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style>
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel="stylesheet" id="wp-block-library-css" media="all" data-lazy-method="interaction" data-lazy-attributes="href" data-lazy-href="https://randomnerdtutorials.com/wp-content/cache/flying-press/randomnerdtutorials.com/43c4bc05b5e3.style.min.css">
<style id="wp-block-library-inline-css">
.has-text-align-justify{text-align:justify;}
</style>
<link rel="stylesheet" id="mediaelement-css" media="all" data-lazy-method="interaction" data-lazy-attributes="href" data-lazy-href="https://randomnerdtutorials.com/wp-content/cache/flying-press/randomnerdtutorials.com/2b0dd7eecea0.mediaelementplayer-legacy.min.css">
<link rel="stylesheet" id="wp-mediaelement-css" media="all" data-lazy-method="interaction" data-lazy-attributes="href" data-lazy-href="https://randomnerdtutorials.com/wp-content/cache/flying-press/randomnerdtutorials.com/ea958276b7de.wp-mediaelement.min.css">
<link rel="stylesheet" id="generate-style-css" media="all" data-lazy-method="interaction" data-lazy-attributes="href" data-lazy-href="https://randomnerdtutorials.com/wp-content/cache/flying-press/randomnerdtutorials.com/76081276afd9.all.min.css">
<style id="generate-style-inline-css">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</style>
<link rel="stylesheet" id="generate-font-icons-css" media="all" data-lazy-method="interaction" data-lazy-attributes="href" data-lazy-href="https://randomnerdtutorials.com/wp-content/cache/flying-press/randomnerdtutorials.com/78ce964ac72d.font-icons.min.css">
<link rel="stylesheet" id="generate-child-css" media="all" data-lazy-method="interaction" data-lazy-attributes="href" data-lazy-href="https://randomnerdtutorials.com/wp-content/cache/flying-press/randomnerdtutorials.com/273667da91ad.style.css">
<link rel="stylesheet" id="elementor-icons-css" media="all" data-lazy-method="interaction" data-lazy-attributes="href" data-lazy-href="https://randomnerdtutorials.com/wp-content/cache/flying-press/randomnerdtutorials.com/def44311f099.elementor-icons.min.css">
<link rel="stylesheet" id="elementor-frontend-legacy-css" media="all" data-lazy-method="interaction" data-lazy-attributes="href" data-lazy-href="https://randomnerdtutorials.com/wp-content/cache/flying-press/randomnerdtutorials.com/558c7031d340.frontend-legacy.min.css">
<link rel="stylesheet" id="elementor-frontend-css" media="all" data-lazy-method="interaction" data-lazy-attributes="href" data-lazy-href="https://randomnerdtutorials.com/wp-content/cache/flying-press/randomnerdtutorials.com/be44ed3d2346.frontend.min.css">
<style id="elementor-frontend-inline-css">
@font-face{font-family:eicons;src:url(https://randomnerdtutorials.com/wp-content/plugins/elementor/assets/lib/eicons/fonts/eicons.eot?5.10.0);src:url(https://randomnerdtutorials.com/wp-content/plugins/elementor/assets/lib/eicons/fonts/eicons.eot?5.10.0#iefix) format("embedded-opentype"),url(https://randomnerdtutorials.com/wp-content/plugins/elementor/assets/lib/eicons/fonts/eicons.woff2?5.10.0) format("woff2"),url(https://randomnerdtutorials.com/wp-content/plugins/elementor/assets/lib/eicons/fonts/eicons.woff?5.10.0) format("woff"),url(https://randomnerdtutorials.com/wp-content/plugins/elementor/assets/lib/eicons/fonts/eicons.ttf?5.10.0) format("truetype"),url(https://randomnerdtutorials.com/wp-content/plugins/elementor/assets/lib/eicons/fonts/eicons.svg?5.10.0#eicon) format("svg");font-weight:400;font-style:normal}
</style>
<link rel="stylesheet" id="elementor-post-94299-css" media="all" data-lazy-method="interaction" data-lazy-attributes="href" data-lazy-href="https://randomnerdtutorials.com/wp-content/cache/flying-press/randomnerdtutorials.com/281b612b521e.post-94299.css">
<link rel="stylesheet" id="elementor-pro-css" media="all" data-lazy-method="interaction" data-lazy-attributes="href" data-lazy-href="https://randomnerdtutorials.com/wp-content/cache/flying-press/randomnerdtutorials.com/ad50b9d85c8f.frontend.min.css">
<link rel="stylesheet" id="font-awesome-5-all-css" media="all" data-lazy-method="interaction" data-lazy-attributes="href" data-lazy-href="https://randomnerdtutorials.com/wp-content/cache/flying-press/randomnerdtutorials.com/74bab4578692.all.min.css">
<link rel="stylesheet" id="font-awesome-4-shim-css" media="all" data-lazy-method="interaction" data-lazy-attributes="href" data-lazy-href="https://randomnerdtutorials.com/wp-content/cache/flying-press/randomnerdtutorials.com/c55205bce667.v4-shims.min.css">
<link rel="stylesheet" id="elementor-post-83058-css" media="all" data-lazy-method="interaction" data-lazy-attributes="href" data-lazy-href="https://randomnerdtutorials.com/wp-content/cache/flying-press/randomnerdtutorials.com/bcfb211601fd.post-83058.css">
<link rel="stylesheet" id="generate-sticky-css" media="all" data-lazy-method="interaction" data-lazy-attributes="href" data-lazy-href="https://randomnerdtutorials.com/wp-content/cache/flying-press/randomnerdtutorials.com/858f6e0503fe.sticky.min.css">
<link rel="stylesheet" id="generate-menu-logo-css" media="all" data-lazy-method="interaction" data-lazy-attributes="href" data-lazy-href="https://randomnerdtutorials.com/wp-content/cache/flying-press/randomnerdtutorials.com/c1185c7ce5bc.menu-logo.min.css">
<style id="generate-menu-logo-inline-css">
@media (max-width: 768px){.sticky-menu-logo .navigation-stick:not(.mobile-header-navigation) .menu-toggle,.menu-logo .main-navigation:not(.mobile-header-navigation) .menu-toggle{display:inline-block;clear:none;width:auto;float:right;}.sticky-menu-logo .navigation-stick:not(.mobile-header-navigation) .mobile-bar-items,.menu-logo .main-navigation:not(.mobile-header-navigation) .mobile-bar-items{position:relative;float:right;}.regular-menu-logo .main-navigation:not(.navigation-stick):not(.mobile-header-navigation) .menu-toggle{display:inline-block;clear:none;width:auto;float:right;}.regular-menu-logo .main-navigation:not(.navigation-stick):not(.mobile-header-navigation) .mobile-bar-items{position:relative;float:right;}body[class*="nav-float-"].menu-logo-enabled:not(.sticky-menu-logo) .main-navigation .main-nav{display:block;}.sticky-menu-logo.nav-float-left .navigation-stick:not(.mobile-header-navigation) .menu-toggle,.menu-logo.nav-float-left .main-navigation:not(.mobile-header-navigation) .menu-toggle,.regular-menu-logo.nav-float-left .main-navigation:not(.navigation-stick):not(.mobile-header-navigation) .menu-toggle{float:left;}}
</style>
<link rel="stylesheet" id="google-fonts-1-css" media="all" data-lazy-method="interaction" data-lazy-attributes="href" data-lazy-href="https://randomnerdtutorials.com/wp-content/cache/flying-press/randomnerdtutorials.com/3160f4c8d110.f572dad0265d.google-font.css">
<link rel="stylesheet" id="jetpack_css-css" media="all" data-lazy-method="interaction" data-lazy-attributes="href" data-lazy-href="https://randomnerdtutorials.com/wp-content/cache/flying-press/randomnerdtutorials.com/ed477db52a19.jetpack.css">
<script src="https://randomnerdtutorials.com/wp-includes/js/jquery/jquery.min.js?ver=02dd5d04add4" id="jquery-core-js"></script>
<script src="https://randomnerdtutorials.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=79b4956b7ec4" id="jquery-migrate-js"></script>
<script async="async" data-noptimize="1" data-cfasync="false" src="https://scripts.mediavine.com/tags/random-nerd-tutorials.js?ver=5.8" id="mv-script-wrapper-js" defer></script>
<script src="https://randomnerdtutorials.com/wp-content/plugins/elementor/assets/lib/font-awesome/js/v4-shims.min.js?ver=7a5dea0a705c" id="font-awesome-4-shim-js" defer></script>
<link rel="https://api.w.org/" href="https://randomnerdtutorials.com/wp-json/"><link rel="alternate" type="application/json" href="https://randomnerdtutorials.com/wp-json/wp/v2/posts/106084"><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://randomnerdtutorials.com/xmlrpc.php?rsd">
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://randomnerdtutorials.com/wp-includes/wlwmanifest.xml"> 
<meta name="generator" content="WordPress 5.8">
<link rel="shortlink" href="https://randomnerdtutorials.com/?p=106084">
<link rel="alternate" type="application/json+oembed" href="https://randomnerdtutorials.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Frandomnerdtutorials.com%2Fesp8266-nodemcu-stepper-motor-28byj-48-uln2003%2F">
<link rel="alternate" type="text/xml+oembed" href="https://randomnerdtutorials.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Frandomnerdtutorials.com%2Fesp8266-nodemcu-stepper-motor-28byj-48-uln2003%2F&amp;format=xml">
<style>img{height:auto}</style><meta name="viewport" content="width=device-width, initial-scale=1"><!-- Global site tag (gtag.js) - Google Analytics -->
<script async data-lazy-src="https://www.googletagmanager.com/gtag/js?id=UA-41273278-2" data-lazy-method="interaction" data-lazy-attributes="src"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-41273278-2');
</script>
<style>
@media ( min-width: 782px ) {
  .skip-link {
    display:none;
  }
}
.is-logo-image {
width: 145px;
height: 60px;
}
.rntn-top-menu {
background: #edeff3;
border-radius: 4px;
padding: 4px 8px;
margin: 4px;
}
.rnt-menu-top-links a {
text-decoration: none;
color: #3a3a3a ;
}
.rnt-menu-top-links a:hover { text-decoration: underline; color: #3a3a3a; }
</style><link rel="icon" href="https://i2.wp.com/randomnerdtutorials.com/wp-content/uploads/2018/03/n-favicon-2018.png?fit=16%2C16&amp;quality=100&amp;strip=all&amp;ssl=1" sizes="32x32">
<link rel="icon" href="https://i2.wp.com/randomnerdtutorials.com/wp-content/uploads/2018/03/n-favicon-2018.png?fit=16%2C16&amp;quality=100&amp;strip=all&amp;ssl=1" sizes="192x192">
<link rel="apple-touch-icon" href="https://i2.wp.com/randomnerdtutorials.com/wp-content/uploads/2018/03/n-favicon-2018.png?fit=16%2C16&amp;quality=100&amp;strip=all&amp;ssl=1">
<meta name="msapplication-TileImage" content="https://i2.wp.com/randomnerdtutorials.com/wp-content/uploads/2018/03/n-favicon-2018.png?fit=16%2C16&amp;quality=100&amp;strip=all&amp;ssl=1">
<meta http-equiv="Content-Type" content="text/html; charset=utf-8"></head>

<body data-rsssl="1" class="post-template-default single single-post postid-106084 single-format-standard wp-embed-responsive post-image-above-header post-image-aligned-center sticky-menu-no-transition sticky-enabled menu-logo menu-logo-enabled both-sticky-menu both-sidebars nav-above-header separate-containers fluid-header active-footer-widgets-0 nav-search-enabled nav-aligned-center header-aligned-center dropdown-hover featured-image-active elementor-default elementor-kit-94299 elementor-page-82536" itemtype="https://schema.org/Blog" itemscope>
	<a class="screen-reader-text skip-link" href="#content" title="Skip to content">Skip to content</a>		<nav id="site-navigation" class="auto-hide-sticky main-navigation sub-menu-right" itemtype="https://schema.org/SiteNavigationElement" itemscope>
			<div class="inside-navigation grid-container grid-parent">
				<div class="site-logo sticky-logo navigation-logo">
					<a href="https://randomnerdtutorials.com/" title="Random Nerd Tutorials" rel="home">
						<img src="https://randomnerdtutorials.com/wp-content/uploads/2016/04/logornt.png" alt="Random Nerd Tutorials" class="is-logo-image" loading="eager" width="250" height="80">
					</a>
				</div><form method="get" class="search-form navigation-search" action="https://randomnerdtutorials.com/">
					<input type="search" class="search-field" value="" name="s" title="Search">
				</form>		<div class="mobile-bar-items">
						<span class="search-item">
				<a aria-label="Open Search Bar" href="#">
									</a>
			</span>
		</div>
						<button class="menu-toggle" aria-controls="primary-menu" aria-expanded="false">
					<span class="mobile-menu">Menu</span>				</button>
				<div id="primary-menu" class="main-nav"><ul id="menu-newtop" class=" menu sf-menu"><li id="menu-item-20487" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-20487"><a href="https://randomnerdtutorials.com/download">Free eBooks</a></li>
<li id="menu-item-20484" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-20484"><a href="https://randomnerdtutorials.com/about">About</a></li>
<li id="menu-item-20485" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-20485"><a href="https://randomnerdtutorials.com/contact">Contact</a></li>
<li id="menu-item-68854" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-68854"><a target="_blank" rel="noopener" href="https://rntlab.com/login">Courses Login</a></li>
<li id="menu-item-20483" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-20483"><a href="https://randomnerdtutorials.com/courses/"><strong>Get Courses</strong><span role="presentation" class="dropdown-menu-toggle"></span></a>
<ul class="sub-menu">
	<li id="menu-item-40154" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-40154"><a href="https://randomnerdtutorials.com/courses/"><strong>All eBooks &amp; Courses</strong></a></li>
	<li id="menu-item-100940" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-100940"><a href="https://randomnerdtutorials.com/build-web-servers-esp32-esp8266-ebook/"><strong>Build Web Servers with ESP32 and ESP8266</strong></a></li>
	<li id="menu-item-69105" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-69105"><a href="https://randomnerdtutorials.com/learn-esp32-with-arduino-ide/">Learn ESP32 with Arduino IDE</a></li>
	<li id="menu-item-96038" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-96038"><a href="https://randomnerdtutorials.com/esp32-cam-projects-ebook/">Build ESP32-CAM Projects</a></li>
	<li id="menu-item-83302" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-83302"><a href="https://randomnerdtutorials.com/micropython-programming-with-esp32-and-esp8266/">MicroPython Programming with ESP32 and ESP8266</a></li>
	<li id="menu-item-40149" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-40149"><a href="https://randomnerdtutorials.com/home-automation-using-esp8266/">Home Automation Using ESP8266</a></li>
	<li id="menu-item-40150" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-40150"><a href="https://randomnerdtutorials.com/build-a-home-automation-system-for-100/">Build a Home Automation System for $100</a></li>
	<li id="menu-item-40151" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-40151"><a href="https://randomnerdtutorials.com/arduino-step-by-step-projects/">Arduino Step-by-step Projects</a></li>
	<li id="menu-item-40153" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-40153"><a href="https://randomnerdtutorials.com/android-apps-for-arduino-with-mit-app-inventor-2/">Android Apps For Arduino</a></li>
	<li id="menu-item-40152" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-40152"><a href="https://randomnerdtutorials.com/electronics-for-beginners/">Electronics For Beginners</a></li>
</ul>
</li>
<li class="search-item menu-item-align-right"><a aria-label="Open Search Bar" href="#"></a></li></ul></div>			</div>
		</nav>
				<header id="masthead" class="site-header" itemtype="https://schema.org/WPHeader" itemscope>
			<div class="inside-header">
							</div>
		</header>
		
	<div id="page" class="site grid-container container hfeed grid-parent">
		<div style="margin-top:10px; padding:10px;" class="rnt-menu-top-links">
	<a class="rntn-top-menu" href="https://randomnerdtutorials.com/">HOME</a>
  <a class="rntn-top-menu" href="https://randomnerdtutorials.com/projects-esp32/">ESP32</a>
  <a class="rntn-top-menu" href="https://randomnerdtutorials.com/projects-esp8266/">ESP8266</a>
  <a class="rntn-top-menu" href="https://randomnerdtutorials.com/projects-esp32-cam/">ESP32-CAM</a>
  <a class="rntn-top-menu" href="https://randomnerdtutorials.com/projects-esp32-esp8266-micropython/">MICROPYTHON</a>
  <a class="rntn-top-menu" href="https://randomnerdtutorials.com/projects-arduino/">ARDUINO</a>
  <a class="rntn-top-menu" href="https://makeradvisor.com/" target="_blank" rel="noopener">REVIEWS</a>
  <a class="rntn-top-menu" href="https://randomnerdtutorials.com/projects/">PROJECTS</a>
</div>		<div id="content" class="site-content">
			
	<div id="primary" class="content-area grid-parent mobile-grid-100 push-15 grid-60 tablet-push-15 tablet-grid-60">
		<main id="main" class="site-main">
			
<article id="post-106084" class="post-106084 post type-post status-publish format-standard has-post-thumbnail hentry category-esp8266 category-esp8266-project category-esp8266-arduino-ide category-esp8266-projects category-0-esp8266 category-project mv-content-wrapper" itemtype="https://schema.org/CreativeWork" itemscope>
	<div class="inside-article">
					<header class="entry-header">
				<h1 class="entry-title" itemprop="headline">ESP8266 NodeMCU with Stepper Motor (28BYJ-48 and ULN2003 Motor Driver)</h1>			</header>
			
		<div class="entry-content" itemprop="text">
			
<p>In this guide, you’ll learn how to control a stepper motor with the ESP8266 NodeMCU board. We’ll use the 28BYJ-48 unipolar stepper motor with the ULN2003 motor driver. We’ll program the ESP8266 board using Arduino IDE.</p>



<div class="wp-block-image"><figure class="aligncenter size-full"><img width="828" height="466" src="https://i2.wp.com/randomnerdtutorials.com/wp-content/uploads/2021/08/ESP8266-Stepper-Motor-Tutorial-Arduino-IDE.jpg?resize=828%2C466&amp;quality=100&amp;strip=all&amp;ssl=1" alt="ESP8266 NodeMCU with Stepper Motor 28BYJ-48 and ULN2003 Motor Driver Arduino IDE" class="wp-image-106093" srcset="https://i2.wp.com/randomnerdtutorials.com/wp-content/uploads/2021/08/ESP8266-Stepper-Motor-Tutorial-Arduino-IDE.jpg?w=1280&amp;quality=100&amp;strip=all&amp;ssl=1 1280w, https://i2.wp.com/randomnerdtutorials.com/wp-content/uploads/2021/08/ESP8266-Stepper-Motor-Tutorial-Arduino-IDE.jpg?resize=300%2C169&amp;quality=100&amp;strip=all&amp;ssl=1 300w, https://i2.wp.com/randomnerdtutorials.com/wp-content/uploads/2021/08/ESP8266-Stepper-Motor-Tutorial-Arduino-IDE.jpg?resize=1024%2C576&amp;quality=100&amp;strip=all&amp;ssl=1 1024w, https://i2.wp.com/randomnerdtutorials.com/wp-content/uploads/2021/08/ESP8266-Stepper-Motor-Tutorial-Arduino-IDE.jpg?resize=768%2C432&amp;quality=100&amp;strip=all&amp;ssl=1 768w" sizes="(max-width: 828px) 100vw, 828px" data-recalc-dims="1" loading="eager"></figure></div>



<p>We have a similar tutorial for the ESP32 board: <a href="https://randomnerdtutorials.com/esp32-stepper-motor-28byj-48-uln2003/">ESP32 with Stepper Motor (28BYJ-48 and ULN2003 Motor Driver)</a></p>



<h2>Parts Required</h2>



<p>To follow this tutorial, you need the following parts:</p>



<ul><li><a href="https://makeradvisor.com/tools/28byj-48-stepper-motor-uln2003/" target="_blank" rel="noreferrer noopener">28BYJ-48 Stepper Motor</a></li><li><a href="https://makeradvisor.com/tools/28byj-48-stepper-motor-uln2003/" target="_blank" rel="noreferrer noopener">ULN2003 Motor Driver</a></li><li><a href="https://makeradvisor.com/tools/esp8266-esp-12e-nodemcu-wi-fi-development-board/" target="_blank" rel="noreferrer noopener">ESP8266 </a>(read <a href="https://makeradvisor.com/best-esp8266-wi-fi-development-board/" target="_blank" rel="noreferrer noopener">Best ESP8266 Development Boards</a>)</li><li><a href="https://makeradvisor.com/tools/jumper-wires-kit-120-pieces/" target="_blank" rel="noreferrer noopener">Jumper Wires</a></li><li>5V Power Supply</li></ul>


<p>You can use the preceding links or go directly to <a href="https://makeradvisor.com/tools/?utm_source=rnt&amp;utm_medium=post&amp;utm_campaign=post" target="_blank">MakerAdvisor.com/tools</a> to find all the parts for your projects at the best price!</p><p style="text-align:center;"><a href="https://makeradvisor.com/tools/?utm_source=rnt&amp;utm_medium=post&amp;utm_campaign=post" target="_blank"><img src="https://i1.wp.com/randomnerdtutorials.com/wp-content/uploads/2017/10/header-200.png?w=828&amp;quality=100&amp;strip=all&amp;ssl=1" data-recalc-dims="1" loading="eager"></a></p>



<h2>Introducing Stepper Motors</h2>



<p>A stepper motor is a brushless DC electric motor that divides a full rotation into a number of steps. It moves one step at a time, and each step is the same size. This allows us to rotate the motor by a precise angle to a precise position. The stepper motor can rotate clockwise or counterclockwise. </p>



<p>The following picture shows two 28BYJ-48 stepper motors.</p>



<div class="wp-block-image"><figure class="aligncenter size-full"><img width="750" height="422" src="https://i0.wp.com/randomnerdtutorials.com/wp-content/uploads/2021/07/28BYJ-48-Stepper-Motors.jpg?resize=750%2C422&amp;quality=100&amp;strip=all&amp;ssl=1" alt="28BYJ-48 Stepper Motors" class="wp-image-105431" srcset="https://i0.wp.com/randomnerdtutorials.com/wp-content/uploads/2021/07/28BYJ-48-Stepper-Motors.jpg?w=750&amp;quality=100&amp;strip=all&amp;ssl=1 750w, https://i0.wp.com/randomnerdtutorials.com/wp-content/uploads/2021/07/28BYJ-48-Stepper-Motors.jpg?resize=300%2C169&amp;quality=100&amp;strip=all&amp;ssl=1 300w" sizes="(max-width: 750px) 100vw, 750px" data-recalc-dims="1" loading="eager"></figure></div>



<p>Stepper motors are made of internal coils that make the motor shaft move in steps in one direction or the other when current is applied to the coils in a specific way.</p>



<p>There are two types of stepper motors: unipolar and bipolar stepper motors.</p>



<p>In this article, we won’t detail how the stepper motors are made and how they work internally. To learn in more detail how they work and the differences between each type of stepper motor, we recommend reading this article by the <a href="https://dronebotworkshop.com/stepper-motors-with-arduino/" target="_blank" rel="noreferrer noopener nofollow">DroneBotWorkshop blog</a>.</p>



<h3>28BYJ-48 Stepper Motor</h3>



<p>There are several stepper motors with different specifications. This tutorial will cover the widely used <strong>28BYJ-48 unipolar stepper motor</strong> with the <strong>ULN2003 motor driver</strong>.</p>



<div class="wp-block-image"><figure class="aligncenter size-large"><img width="750" height="422" src="https://i1.wp.com/randomnerdtutorials.com/wp-content/uploads/2021/07/28BYJ-48-connected-to-ULN2003-Motor-Driver-01-module.jpg?resize=750%2C422&amp;quality=100&amp;strip=all&amp;ssl=1" alt="28BYJ-48 connected to ULN2003 Motor Driver 01 module" class="wp-image-105430" srcset="https://i1.wp.com/randomnerdtutorials.com/wp-content/uploads/2021/07/28BYJ-48-connected-to-ULN2003-Motor-Driver-01-module.jpg?w=750&amp;quality=100&amp;strip=all&amp;ssl=1 750w, https://i1.wp.com/randomnerdtutorials.com/wp-content/uploads/2021/07/28BYJ-48-connected-to-ULN2003-Motor-Driver-01-module.jpg?resize=300%2C169&amp;quality=100&amp;strip=all&amp;ssl=1 300w" sizes="(max-width: 750px) 100vw, 750px" data-recalc-dims="1" loading="eager"></figure></div>



<h4>28BYJ-48 Stepper Motor Features</h4>



<p>Features of the stepper motor (for more details, consult the datasheet):</p>



<ul><li>Rated voltage: 5V DC</li><li>Number of phases: 4</li><li>Speed variation ratio: 1/64</li><li>Stride angle: 5.625º/64</li><li>Frequency: 100Hz</li></ul>



<p>The 28BYJ-48 stepper motor has a total of four coils. One end of the coils is connected to 5V, which corresponds to the motor’s red wire. The other end of the coils corresponds to the wires with blue, pink, yellow, and orange color. Energizing the coils in a logical sequence makes the motor move one step in one direction or the other.</p>



<div class="wp-block-image"><figure class="aligncenter size-full"><img width="704" height="434" src="https://i2.wp.com/randomnerdtutorials.com/wp-content/uploads/2021/07/28BYJ-48-stepper-motor-coils.png?resize=704%2C434&amp;quality=100&amp;strip=all&amp;ssl=1" alt="28BYJ-48 stepper motor coils" class="wp-image-105372" srcset="https://i2.wp.com/randomnerdtutorials.com/wp-content/uploads/2021/07/28BYJ-48-stepper-motor-coils.png?w=704&amp;quality=100&amp;strip=all&amp;ssl=1 704w, https://i2.wp.com/randomnerdtutorials.com/wp-content/uploads/2021/07/28BYJ-48-stepper-motor-coils.png?resize=300%2C185&amp;quality=100&amp;strip=all&amp;ssl=1 300w" sizes="(max-width: 704px) 100vw, 704px" data-recalc-dims="1" loading="lazy"></figure></div>



<p>The 28BYJ-48 Stepper Motor has a stride angle of 5.625°/64 in half-step mode. This means that the motor has a step angle of 5.625º—so it needs 360º/5.625º = 64 steps in half-step mode. In full-step mode: 64/2 = 32 steps to complete one rotation.</p>



<p>However, the output shaft is driven via a 64:1 gear ratio. This means that the shaft (visible outside the motor) will complete rotation if the motor inside rotates 64 times. This means that the motor will have to move 32×64 = 2048 steps for the shaft to complete one full rotation. This means that you’ll have a precision of 360º/2048 steps = 0.18º/step.</p>



<p>So, in summary:</p>



<ul><li>Total steps per revolution = 2048 steps</li><li>Step angle = 0.18º/step</li></ul>



<p>If you’re using a different stepper motor, please consult the datasheet.</p>



<h2>ULN2003 Motor Driver</h2>



<p>To interface the stepper motor with the ESP8266 NodeMCU board, we’ll use the ULN2003 motor driver, as shown in the figure below. The 28BYJ-48 stepper motor is many times sold together with the ULN2003 motor driver.</p>



<div class="wp-block-image"><figure class="aligncenter size-full"><img width="750" height="422" src="https://i1.wp.com/randomnerdtutorials.com/wp-content/uploads/2021/07/ULN2003-Motor-Driver-01-module-board.jpg?resize=750%2C422&amp;quality=100&amp;strip=all&amp;ssl=1" alt="ULN2003 Motor Driver 01 module board" class="wp-image-105429" srcset="https://i1.wp.com/randomnerdtutorials.com/wp-content/uploads/2021/07/ULN2003-Motor-Driver-01-module-board.jpg?w=750&amp;quality=100&amp;strip=all&amp;ssl=1 750w, https://i1.wp.com/randomnerdtutorials.com/wp-content/uploads/2021/07/ULN2003-Motor-Driver-01-module-board.jpg?resize=300%2C169&amp;quality=100&amp;strip=all&amp;ssl=1 300w" sizes="(max-width: 750px) 100vw, 750px" data-recalc-dims="1" loading="lazy"></figure></div>



<p>The module comes with a connector that makes it easy and simple to connect the motor to the module. It has four input pins to control the coils that make the stepper motor move. The four LEDs provide a visual interface of the coils’ state. </p>



<div class="wp-block-image"><figure class="aligncenter size-full"><img width="750" height="429" src="https://i2.wp.com/randomnerdtutorials.com/wp-content/uploads/2021/07/ULN2003-Motor-Driver-01.png?resize=750%2C429&amp;quality=100&amp;strip=all&amp;ssl=1" alt="ULN2003 Motor Driver Labels" class="wp-image-105359" srcset="https://i2.wp.com/randomnerdtutorials.com/wp-content/uploads/2021/07/ULN2003-Motor-Driver-01.png?w=750&amp;quality=100&amp;strip=all&amp;ssl=1 750w, https://i2.wp.com/randomnerdtutorials.com/wp-content/uploads/2021/07/ULN2003-Motor-Driver-01.png?resize=300%2C172&amp;quality=100&amp;strip=all&amp;ssl=1 300w" sizes="(max-width: 750px) 100vw, 750px" data-recalc-dims="1" loading="lazy"></figure></div>



<p>There are pins to connect <span class="rnthl rntcred">VCC</span> and <span class="rnthl rntcblack">GND,</span> and a jumper cap that acts as an ON/OFF switch to power the stepper motor—if you remove the jumper, there is no power reaching the motor. You can use those pins to wire a physical switch.</p>



<h3>ULN2003 Motor Driver Pinout</h3>



<p>The following table shows the module pinout:</p>



<figure class="wp-block-table"><table><tbody><tr><td><span class="rnthl rntclgray">IN1</span></td><td>Control the motor: connect to a microcontroller digital pin</td></tr><tr><td><span class="rnthl rntclgray">IN2</span></td><td>Control the motor: connect to a microcontroller digital pin</td></tr><tr><td><span class="rnthl rntclgray">IN3</span></td><td>Control the motor: connect to a microcontroller digital pin</td></tr><tr><td><span class="rnthl rntclgray">IN4</span></td><td>Control the motor: connect to a microcontroller digital pin</td></tr><tr><td><span class="rnthl rntcred">VCC</span></td><td>Powers the motor</td></tr><tr><td><span class="rnthl rntcblack">GND</span></td><td>Common GND</td></tr><tr><td>Motor connector</td><td>Connect the motor connector</td></tr></tbody></table></figure>



<h2 class="wiring">Wire Stepper Motor to the ESP8266 Board</h2>



<p>In this section, we’ll connect the stepper motor to the ESP8266 via the ULN2003 motor driver.</p>



<p>We’ll connect IN1, IN2, IN3, and IN4 to GPIOs <span class="rnthl rntclblue">5</span>, <span class="rnthl rntcyellow">4</span>, <span class="rnthl rntclgreen">14</span>, and <span class="rnthl rntclgray">12</span>. You can use any other suitable digital pins (check our <a href="https://randomnerdtutorials.com/esp8266-pinout-reference-gpios/">ESP8266 pinout reference guide</a>).</p>



<p>You can follow the next schematic diagram.</p>



<div class="wp-block-image"><figure class="aligncenter size-full"><img width="828" height="446" src="https://i1.wp.com/randomnerdtutorials.com/wp-content/uploads/2021/08/ESP8266-Stepper-Motor-Schematic-Diagram-Wiring.png?resize=828%2C446&amp;quality=100&amp;strip=all&amp;ssl=1" alt="ESP8266 with Stepper Motor 28BYJ-48 and ULN2003A Schematic Diagram Wiring" class="wp-image-106096" srcset="https://i1.wp.com/randomnerdtutorials.com/wp-content/uploads/2021/08/ESP8266-Stepper-Motor-Schematic-Diagram-Wiring.png?w=1269&amp;quality=100&amp;strip=all&amp;ssl=1 1269w, https://i1.wp.com/randomnerdtutorials.com/wp-content/uploads/2021/08/ESP8266-Stepper-Motor-Schematic-Diagram-Wiring.png?resize=300%2C161&amp;quality=100&amp;strip=all&amp;ssl=1 300w, https://i1.wp.com/randomnerdtutorials.com/wp-content/uploads/2021/08/ESP8266-Stepper-Motor-Schematic-Diagram-Wiring.png?resize=1024%2C551&amp;quality=100&amp;strip=all&amp;ssl=1 1024w, https://i1.wp.com/randomnerdtutorials.com/wp-content/uploads/2021/08/ESP8266-Stepper-Motor-Schematic-Diagram-Wiring.png?resize=768%2C413&amp;quality=100&amp;strip=all&amp;ssl=1 768w" sizes="(max-width: 828px) 100vw, 828px" data-recalc-dims="1" loading="lazy"></figure></div>



<p class="rntbox rntcred"><strong>Note: </strong> You should power the motor driver using an external 5V power supply.</p>



<figure class="wp-block-table"><table><tbody><tr><td><strong>Motor Driver</strong></td><td><strong>ESP8266</strong></td></tr><tr><td>IN1</td><td><span class="rnthl rntcblue">GPIO 5</span></td></tr><tr><td>IN2</td><td><span class="rnthl rntcyellow">GPIO 4</span></td></tr><tr><td>IN3</td><td><span class="rnthl rntcgreen">GPIO 14</span></td></tr><tr><td>IN4</td><td><span class="rnthl rntcgray">GPIO 12</span></td></tr></tbody></table></figure>



<h2>Installing the AccelStepper Library</h2>



<p>There are different ways to control stepper motors with a microcontroller. To control the stepper motor with the ESP8266, we’ll use the <a href="https://www.airspayce.com/mikem/arduino/AccelStepper/" target="_blank" rel="noreferrer noopener">AccelStepper </a>library. This library allows you to easily move the motor a defined number of steps, set its speed, acceleration, and much more. </p>



<p>The library has great documentation explaining how to use its methods. You can check it <a href="https://www.airspayce.com/mikem/arduino/AccelStepper/classAccelStepper.html" target="_blank" rel="noreferrer noopener">here</a>.</p>



<p>Follow the next steps to install the library in your Arduino IDE.</p>



<ol><li>Go to <strong>Sketch</strong> &gt; <strong>Include Library</strong> &gt; <strong>Manage Libraries…</strong></li><li>Search for “accelstepper”.</li><li>Install the AccelStepper library by Mike McCauley. We’re using version 1.61.0.</li></ol>



<div class="wp-block-image"><figure class="aligncenter size-full"><img width="786" height="443" src="https://i1.wp.com/randomnerdtutorials.com/wp-content/uploads/2021/08/install-accelstepper-library-Arduino-ide.png?resize=786%2C443&amp;quality=100&amp;strip=all&amp;ssl=1" alt="Install AccelStepper Library Arduino IDE" class="wp-image-106090" srcset="https://i1.wp.com/randomnerdtutorials.com/wp-content/uploads/2021/08/install-accelstepper-library-Arduino-ide.png?w=786&amp;quality=100&amp;strip=all&amp;ssl=1 786w, https://i1.wp.com/randomnerdtutorials.com/wp-content/uploads/2021/08/install-accelstepper-library-Arduino-ide.png?resize=300%2C169&amp;quality=100&amp;strip=all&amp;ssl=1 300w, https://i1.wp.com/randomnerdtutorials.com/wp-content/uploads/2021/08/install-accelstepper-library-Arduino-ide.png?resize=768%2C433&amp;quality=100&amp;strip=all&amp;ssl=1 768w" sizes="(max-width: 786px) 100vw, 786px" data-recalc-dims="1" loading="lazy"></figure></div>



<h2>Control Stepper Motor with the ESP8266 – Code</h2>



<p>Copy the following code to your Arduino IDE. In this example, the motor will make one clockwise rotation and a counterclockwise rotation over and over again.</p>


<pre style="max-height: 40em; margin-bottom: 20px;"><code class="language-c">/*
  Rui Santos
  Complete project details at https://RandomNerdTutorials.com/esp8266-nodemcu-stepper-motor-28byj-48-uln2003/
  
  Permission is hereby granted, free of charge, to any person obtaining a copy
  of this software and associated documentation files.
  
  The above copyright notice and this permission notice shall be included in all
  copies or substantial portions of the Software.
  
  Based on Stepper Motor Control - one revolution by Tom Igoe
*/

#include &lt;AccelStepper.h&gt;

const int stepsPerRevolution = 2048;  // change this to fit the number of steps per revolution

// ULN2003 Motor Driver Pins
#define IN1 5
#define IN2 4
#define IN3 14
#define IN4 12

// initialize the stepper library
AccelStepper stepper(AccelStepper::HALF4WIRE, IN1, IN3, IN2, IN4);

void setup() {
  // initialize the serial port
  Serial.begin(115200);
  
  // set the speed and acceleration
  stepper.setMaxSpeed(500);
  stepper.setAcceleration(100);
  // set target position
  stepper.moveTo(stepsPerRevolution);
}

void loop() {
  // check current stepper motor position to invert direction
  if (stepper.distanceToGo() == 0){
    stepper.moveTo(-stepper.currentPosition());
    Serial.println("Changing direction");
  }
  // move the stepper motor (one step at a time)
  stepper.run();
}
</code></pre>
	<p style="text-align:center"><a class="rntwhite" href="https://github.com/RuiSantosdotme/Random-Nerd-Tutorials/raw/master/Projects/ESP8266/ESP8266_Stepper_Motor_Basic.ino" target="_blank">View raw code</a></p>



<p>We adapted this sketch from the examples provided by the library (<strong>File </strong>&gt; <strong>Examples </strong>&gt; <strong>AccelStepper </strong>&gt;<strong> Bounce</strong>).</p>



<h3>How the Code Works</h3>



<p>First, include the <span class="rnthl rntliteral">AccelStepper.h</span> library.</p>



<pre class="wp-block-code language-c"><code>#include &lt;AccelStepper.h&gt;</code></pre>



<p>Define the steps per revolution of your stepper motor—in our case, it’s 2048:</p>



<pre class="wp-block-code language-c"><code>const int stepsPerRevolution = 2048;  // change this to fit the number of steps per revolution</code></pre>



<p>Define the motor input pins. In this example, we’re connecting to GPIOs 5, 4, 14, and 12, but you can use any other suitable GPIOs.</p>



<pre class="wp-block-code language-c"><code>#define IN1 5
#define IN2 4
#define IN3 14
#define IN4 12</code></pre>



<p>Initialize an instance of the AccelStepper library called <span class="rnthl rntliteral">stepper</span>. Pass as arguments: <span class="rnthl rntliteral">AccelStepper::HALF4WIRE</span> to indicate we’re controlling the stepper motor with four wires, and the input pins. In the case of the 28BYJ-48 stepper motor, the order of the pins is <span class="rnthl rntliteral">IN1</span>, <span class="rnthl rntliteral">IN3</span>, <span class="rnthl rntliteral">IN2</span>, <span class="rnthl rntliteral">IN4</span>—it might be different for your motor.</p>



<pre class="wp-block-code language-c"><code>AccelStepper stepper(AccelStepper::HALF4WIRE, IN1, IN3, IN2, IN4);</code></pre>



<p>In the <span class="rnthl rntliteral">setup()</span>, initialize the Serial Monitor at a baud rate of 115200.</p>



<pre class="wp-block-code language-c"><code>Serial.begin(115200);</code></pre>



<p>Set the stepper motor maximum speed using the <span class="rnthl rntliteral">setMaxSpeed()</span> method. Pass as argument the speed in steps per second.</p>



<pre class="wp-block-code language-c"><code>stepper.setMaxSpeed(500);</code></pre>



<p>As mentioned in the documentation, the <span class="rnthl rntliteral">setMaxSpeed()</span> method sets the maximum permitted speed. The <span class="rnthl rntliteral">run()</span> function will accelerate up to the speed set by this function.</p>



<p>Set the acceleration using the <span class="rnthl rntliteral">setAcceleration()</span> method. Pass as argument the acceleration in steps per second per second.</p>



<pre class="wp-block-code language-c"><code>stepper.setAcceleration(100);</code></pre>



<p>Then, use the <span class="rnthl rntliteral">moveTo()</span> method to set a target position. Then, the <span class="rnthl rntliteral">run()</span> function will try to move the motor (at most one step per call) from the current position to the target position set by the most recent call to this function. We’re setting the target position to 2048 (which is a complete turn in case of this motor).</p>



<pre class="wp-block-code language-c"><code>stepper.moveTo(stepsPerRevolution);</code></pre>



<p>In the <span class="rnthl rntliteral">loop()</span>, we’ll rotate the stepper motor clockwise and counterclockwise. </p>



<p>First, we check if the motor has already achieved its target position. To do that, we can use the <span class="rnthl rntliteral">distanceToGo()</span> function that returns the steps from the current position to the target position. </p>



<p>When the motor reaches its target position, it means that the <span class="rnthl rntliteral">distanceToGo()</span> function will return <span class="rnthl rntliteral">0</span> and the following if statement will be true.</p>



<pre class="wp-block-code language-c"><code>if (stepper.distanceToGo() == 0){</code></pre>



<p>When the motor reaches its target position, we set a new target position—which is the same as the current position but in the opposite direction.</p>



<pre class="wp-block-code language-c"><code>stepper.moveTo(-stepper.currentPosition());</code></pre>



<p>Finally, call <span class="rnthl rntliteral">stepper.run()</span> to move the motor one step at a time in the <span class="rnthl rntliteral">loop()</span>.</p>



<pre class="wp-block-code language-c"><code>stepper.run();</code></pre>



<p>Here’s an explanation about the <span class="rnthl rntliteral">run()</span> method provided by the library documentation: “The <span class="rnthl rntliteral">run()</span> function polls the motor and step it if a step is due, implementing accelerations and decelerations to achieve the target position. You must call this as frequently as possible, but at least once per minimum step time interval, preferably in your main loop. Note that each call to <span class="rnthl rntliteral">run()</span> will make at most one step, and then only when a step is due, based on the current speed and the time since the last step”.</p>



<h2>Demonstration</h2>



<p>Upload the code to your board. After uploading, the motor will make one clockwise rotation and a counterclockwise rotation over and over again. It starts the rotation at a lower speed until reaching the desired speed before reaching the target position.</p>



<p>You can watch a quick video demonstration:</p>


<div style="text-align:center"><iframe width="720" height="405" frameborder="0" webkitallowfullscreen mozallowfullscreen allowfullscreen data-lazy-src="https://player.vimeo.com/video/592192911?color=ff9933&amp;title=1&amp;byline=0&amp;portrait=0" data-lazy-method="viewport" data-lazy-attributes="src"></iframe></div>



<h2>Wrapping Up</h2>



<p>This tutorial was a getting started guide for stepper motors with the ESP8266. Stepper motors move one step at a time and allow you to position the motor shaft at a specific angle.</p>



<p>In a future tutorial, we’ll show you how to create a web server to control the stepper motor remotely with the ESP8266. So, stay tuned.</p>



<p>We hope you find this tutorial useful. </p>



<p>Learn more about the ESP8266 with our resources:</p>



<ul><li><a href="https://randomnerdtutorials.com/home-automation-using-esp8266/">Home Automation Using ESP8266</a></li><li><a href="https://randomnerdtutorials.com/build-web-servers-esp32-esp8266-ebook/">Build Web Servers with ESP32 and ESP8266 eBook (2nd Edition)</a></li><li><a href="https://randomnerdtutorials.com/projects-esp8266/">More ESP8266 Projects and Tutorials…</a></li></ul>



<p>Thanks for reading.</p>
		</div>

		<br>
<center><a href="https://randomnerdtutorials.com/pcbway" target="_blank"><img src="https://randomnerdtutorials.com/wp-content/uploads/2020/10/750x170-updated-f.png" loading="lazy" width="750" height="148"></a></center>
<br>
		<div data-elementor-type="section" data-elementor-id="83032" class="elementor elementor-83032" data-elementor-settings="[]">
		<div class="elementor-section-wrap">
					<section class="elementor-section elementor-top-section elementor-element elementor-element-2d8a9105 elementor-section-boxed elementor-section-height-default elementor-section-height-default" data-id="2d8a9105" data-element_type="section">
						<div class="elementor-container elementor-column-gap-default">
							<div class="elementor-row">
					<div class="elementor-column elementor-col-100 elementor-top-column elementor-element elementor-element-2280806f" data-id="2280806f" data-element_type="column">
			<div class="elementor-column-wrap elementor-element-populated">
							<div class="elementor-widget-wrap">
						<section class="elementor-section elementor-inner-section elementor-element elementor-element-4a840dd4 elementor-section-boxed elementor-section-height-default elementor-section-height-default" data-id="4a840dd4" data-element_type="section">
						<div class="elementor-container elementor-column-gap-default">
							<div class="elementor-row">
					<div class="elementor-column elementor-col-50 elementor-inner-column elementor-element elementor-element-3497580" data-id="3497580" data-element_type="column">
			<div class="elementor-column-wrap elementor-element-populated">
							<div class="elementor-widget-wrap">
						<div class="elementor-element elementor-element-7b0162e9 elementor-widget elementor-widget-image" data-id="7b0162e9" data-element_type="widget" data-widget_type="image.default">
				<div class="elementor-widget-container">
								<div class="elementor-image">
													<a href="https://randomnerdtutorials.com/build-web-servers-esp32-esp8266-ebook/">
							<img src="https://randomnerdtutorials.com/wp-content/uploads/elementor/thumbs/Build-Web-Servers-with-ESP32-and-ESP8266-eBook-2nd-Edition-500px-h-p2lw6wwnkk9ystvwe9iof8zx6yt4x7uma3cqfup534.jpg" title="Build-Web-Servers-with-ESP32-and-ESP8266-eBook-2nd-Edition-500px-h" alt="Build-Web-Servers-with-ESP32-and-ESP8266-eBook-2nd-Edition-500px-h" loading="lazy" width="129" height="180">								</a>
														</div>
						</div>
				</div>
						</div>
					</div>
		</div>
				<div class="elementor-column elementor-col-50 elementor-inner-column elementor-element elementor-element-45a69540" data-id="45a69540" data-element_type="column">
			<div class="elementor-column-wrap elementor-element-populated">
							<div class="elementor-widget-wrap">
						<div class="elementor-element elementor-element-d7f411a elementor-widget elementor-widget-heading" data-id="d7f411a" data-element_type="widget" data-widget_type="heading.default">
				<div class="elementor-widget-container">
			<h4 class="elementor-heading-title elementor-size-default"><a href="https://randomnerdtutorials.com/build-web-servers-esp32-esp8266-ebook/">[eBook] Build Web Servers with ESP32 and ESP8266 (2nd Edition)</a></h4>		</div>
				</div>
				<div class="elementor-element elementor-element-5dc4402f elementor-hidden-phone elementor-widget elementor-widget-text-editor" data-id="5dc4402f" data-element_type="widget" data-widget_type="text-editor.default">
				<div class="elementor-widget-container">
								<div class="elementor-text-editor elementor-clearfix">
					Build Web Server projects with the ESP32 and ESP8266 boards to control outputs and monitor sensors remotely. Learn HTML, CSS, JavaScript and client-server communication protocols <strong><a href="https://randomnerdtutorials.com/build-web-servers-esp32-esp8266-ebook/" rel="noopener">DOWNLOAD »</a></strong>					</div>
						</div>
				</div>
						</div>
					</div>
		</div>
								</div>
					</div>
		</section>
				<div class="elementor-element elementor-element-4de314b8 elementor-hidden-desktop elementor-hidden-tablet elementor-widget elementor-widget-text-editor" data-id="4de314b8" data-element_type="widget" data-widget_type="text-editor.default">
				<div class="elementor-widget-container">
								<div class="elementor-text-editor elementor-clearfix">
					<p>Build Web Server projects with the ESP32 and ESP8266 boards to control outputs and monitor sensors remotely. Learn HTML, CSS, JavaScript and client-server communication protocols <strong><a href="https://randomnerdtutorials.com/build-web-servers-esp32-esp8266-ebook/" rel="noopener">DOWNLOAD »</a></strong></p>					</div>
						</div>
				</div>
						</div>
					</div>
		</div>
								</div>
					</div>
		</section>
				</div>
		</div>
		
		<div data-elementor-type="section" data-elementor-id="82533" class="elementor elementor-82533" data-elementor-settings="[]">
		<div class="elementor-section-wrap">
					<section class="elementor-section elementor-top-section elementor-element elementor-element-31c9920 elementor-section-boxed elementor-section-height-default elementor-section-height-default" data-id="31c9920" data-element_type="section">
						<div class="elementor-container elementor-column-gap-default">
							<div class="elementor-row">
					<div class="elementor-column elementor-col-100 elementor-top-column elementor-element elementor-element-e6bec81" data-id="e6bec81" data-element_type="column">
			<div class="elementor-column-wrap elementor-element-populated">
							<div class="elementor-widget-wrap">
						<div class="elementor-element elementor-element-ae5f36f elementor-widget elementor-widget-text-editor" data-id="ae5f36f" data-element_type="widget" data-widget_type="text-editor.default">
				<div class="elementor-widget-container">
								<div class="elementor-text-editor elementor-clearfix">
					<h3>Recommended Resources</h3>					</div>
						</div>
				</div>
						</div>
					</div>
		</div>
								</div>
					</div>
		</section>
				<section class="elementor-section elementor-top-section elementor-element elementor-element-df31b19 elementor-section-boxed elementor-section-height-default elementor-section-height-default" data-id="df31b19" data-element_type="section">
						<div class="elementor-container elementor-column-gap-default">
							<div class="elementor-row">
					<div class="elementor-column elementor-col-33 elementor-top-column elementor-element elementor-element-f988f78" data-id="f988f78" data-element_type="column">
			<div class="elementor-column-wrap elementor-element-populated">
							<div class="elementor-widget-wrap">
						<div class="elementor-element elementor-element-ea4ffd5 elementor-widget elementor-widget-image" data-id="ea4ffd5" data-element_type="widget" data-widget_type="image.default">
				<div class="elementor-widget-container">
								<div class="elementor-image">
													<a href="https://randomnerdtutorials.com/build-a-home-automation-system-for-100/">
							<img width="400" height="225" src="https://i1.wp.com/randomnerdtutorials.com/wp-content/uploads/2017/10/home-automation-sb-img.jpg?fit=400%2C225&amp;quality=100&amp;strip=all&amp;ssl=1" class="attachment-full size-full" alt="" srcset="https://i1.wp.com/randomnerdtutorials.com/wp-content/uploads/2017/10/home-automation-sb-img.jpg?w=400&amp;quality=100&amp;strip=all&amp;ssl=1 400w, https://i1.wp.com/randomnerdtutorials.com/wp-content/uploads/2017/10/home-automation-sb-img.jpg?resize=300%2C169&amp;quality=100&amp;strip=all&amp;ssl=1 300w" sizes="(max-width: 400px) 100vw, 400px" loading="lazy">								</a>
														</div>
						</div>
				</div>
				<div class="elementor-element elementor-element-1d03956 elementor-widget elementor-widget-text-editor" data-id="1d03956" data-element_type="widget" data-widget_type="text-editor.default">
				<div class="elementor-widget-container">
								<div class="elementor-text-editor elementor-clearfix">
					<p><strong><a href="https://randomnerdtutorials.com/build-a-home-automation-system-for-100/">Build a Home Automation System from Scratch »</a> </strong>With Raspberry Pi, ESP8266, Arduino, and Node-RED.</p>					</div>
						</div>
				</div>
						</div>
					</div>
		</div>
				<div class="elementor-column elementor-col-33 elementor-top-column elementor-element elementor-element-c804b9b" data-id="c804b9b" data-element_type="column">
			<div class="elementor-column-wrap elementor-element-populated">
							<div class="elementor-widget-wrap">
						<div class="elementor-element elementor-element-caff517 elementor-widget elementor-widget-image" data-id="caff517" data-element_type="widget" data-widget_type="image.default">
				<div class="elementor-widget-container">
								<div class="elementor-image">
													<a href="https://randomnerdtutorials.com/home-automation-using-esp8266/">
							<img width="400" height="225" src="https://i1.wp.com/randomnerdtutorials.com/wp-content/uploads/2017/10/esp8266-sb-img.jpg?fit=400%2C225&amp;quality=100&amp;strip=all&amp;ssl=1" class="attachment-full size-full" alt="" srcset="https://i1.wp.com/randomnerdtutorials.com/wp-content/uploads/2017/10/esp8266-sb-img.jpg?w=400&amp;quality=100&amp;strip=all&amp;ssl=1 400w, https://i1.wp.com/randomnerdtutorials.com/wp-content/uploads/2017/10/esp8266-sb-img.jpg?resize=300%2C169&amp;quality=100&amp;strip=all&amp;ssl=1 300w" sizes="(max-width: 400px) 100vw, 400px" loading="lazy">								</a>
														</div>
						</div>
				</div>
				<div class="elementor-element elementor-element-7bc712f elementor-widget elementor-widget-text-editor" data-id="7bc712f" data-element_type="widget" data-widget_type="text-editor.default">
				<div class="elementor-widget-container">
								<div class="elementor-text-editor elementor-clearfix">
					<p><strong><a href="https://randomnerdtutorials.com/home-automation-using-esp8266/">Home Automation using ESP8266 eBook and video course »</a> </strong>Build IoT and home automation projects.</p>					</div>
						</div>
				</div>
						</div>
					</div>
		</div>
				<div class="elementor-column elementor-col-33 elementor-top-column elementor-element elementor-element-9487535" data-id="9487535" data-element_type="column">
			<div class="elementor-column-wrap elementor-element-populated">
							<div class="elementor-widget-wrap">
						<div class="elementor-element elementor-element-330785f elementor-widget elementor-widget-image" data-id="330785f" data-element_type="widget" data-widget_type="image.default">
				<div class="elementor-widget-container">
								<div class="elementor-image">
													<a href="https://randomnerdtutorials.com/arduino-step-by-step-projects/">
							<img width="400" height="225" src="https://i1.wp.com/randomnerdtutorials.com/wp-content/uploads/2017/10/arduino-sb-img.jpg?fit=400%2C225&amp;quality=100&amp;strip=all&amp;ssl=1" class="attachment-full size-full" alt="" srcset="https://i1.wp.com/randomnerdtutorials.com/wp-content/uploads/2017/10/arduino-sb-img.jpg?w=400&amp;quality=100&amp;strip=all&amp;ssl=1 400w, https://i1.wp.com/randomnerdtutorials.com/wp-content/uploads/2017/10/arduino-sb-img.jpg?resize=300%2C169&amp;quality=100&amp;strip=all&amp;ssl=1 300w" sizes="(max-width: 400px) 100vw, 400px" loading="lazy">								</a>
														</div>
						</div>
				</div>
				<div class="elementor-element elementor-element-e9540a9 elementor-widget elementor-widget-text-editor" data-id="e9540a9" data-element_type="widget" data-widget_type="text-editor.default">
				<div class="elementor-widget-container">
								<div class="elementor-text-editor elementor-clearfix">
					<p><strong><a href="https://randomnerdtutorials.com/arduino-step-by-step-projects/">Arduino Step-by-Step Projects »</a> </strong>Build 25 Arduino projects with our course, even with no prior experience!</p>					</div>
						</div>
				</div>
						</div>
					</div>
		</div>
								</div>
					</div>
		</section>
				<section class="elementor-section elementor-top-section elementor-element elementor-element-a9e9c13 elementor-section-boxed elementor-section-height-default elementor-section-height-default" data-id="a9e9c13" data-element_type="section">
						<div class="elementor-container elementor-column-gap-default">
							<div class="elementor-row">
					<div class="elementor-column elementor-col-100 elementor-top-column elementor-element elementor-element-25cf7ca" data-id="25cf7ca" data-element_type="column">
			<div class="elementor-column-wrap elementor-element-populated">
							<div class="elementor-widget-wrap">
						<div class="elementor-element elementor-element-88fc6c0 elementor-widget elementor-widget-text-editor" data-id="88fc6c0" data-element_type="widget" data-widget_type="text-editor.default">
				<div class="elementor-widget-container">
								<div class="elementor-text-editor elementor-clearfix">
					<h3>What to Read Next…</h3>					</div>
						</div>
				</div>
						</div>
					</div>
		</div>
								</div>
					</div>
		</section>
				<section class="elementor-section elementor-top-section elementor-element elementor-element-d68ef93 elementor-section-height-min-height elementor-section-boxed elementor-section-height-default elementor-section-items-middle" data-id="d68ef93" data-element_type="section">
						<div class="elementor-container elementor-column-gap-no">
							<div class="elementor-row">
					<div class="elementor-column elementor-col-100 elementor-top-column elementor-element elementor-element-4ab337a" data-id="4ab337a" data-element_type="column">
			<div class="elementor-column-wrap elementor-element-populated">
							<div class="elementor-widget-wrap">
						<div class="elementor-element elementor-element-efac60e elementor-grid-3 elementor-grid-tablet-2 elementor-grid-mobile-1 elementor-posts--thumbnail-top elementor-card-shadow-yes elementor-posts__hover-gradient elementor-widget elementor-widget-posts" data-id="efac60e" data-element_type="widget" data-settings='{"cards_row_gap":{"unit":"px","size":16,"sizes":[]},"cards_columns":"3","cards_columns_tablet":"2","cards_columns_mobile":"1"}' data-widget_type="posts.cards">
				<div class="elementor-widget-container">
					<div class="elementor-posts-container elementor-posts elementor-posts--skin-cards elementor-grid">
				<article class="elementor-post elementor-grid-item post-103853 post type-post status-publish format-standard has-post-thumbnail hentry category-esp32 category-esp32-project category-esp32-arduino-ide category-0-esp32 category-project mv-content-wrapper">
			<div class="elementor-post__card">
				<a class="elementor-post__thumbnail__link" href="https://randomnerdtutorials.com/esp32-bmp388-arduino/">
			<div class="elementor-post__thumbnail"><img width="1280" height="720" src="https://i0.wp.com/randomnerdtutorials.com/wp-content/uploads/2021/06/ESP32-with-BMP388-Barometric-Altimeter-Sensor.jpg?fit=1280%2C720&amp;quality=100&amp;strip=all&amp;ssl=1" class="attachment-full size-full" alt="ESP32 with BMP388 Barometric Altimeter Sensor Arduino IDE" srcset="https://i0.wp.com/randomnerdtutorials.com/wp-content/uploads/2021/06/ESP32-with-BMP388-Barometric-Altimeter-Sensor.jpg?w=1280&amp;quality=100&amp;strip=all&amp;ssl=1 1280w, https://i0.wp.com/randomnerdtutorials.com/wp-content/uploads/2021/06/ESP32-with-BMP388-Barometric-Altimeter-Sensor.jpg?resize=300%2C169&amp;quality=100&amp;strip=all&amp;ssl=1 300w, https://i0.wp.com/randomnerdtutorials.com/wp-content/uploads/2021/06/ESP32-with-BMP388-Barometric-Altimeter-Sensor.jpg?resize=1024%2C576&amp;quality=100&amp;strip=all&amp;ssl=1 1024w, https://i0.wp.com/randomnerdtutorials.com/wp-content/uploads/2021/06/ESP32-with-BMP388-Barometric-Altimeter-Sensor.jpg?resize=768%2C432&amp;quality=100&amp;strip=all&amp;ssl=1 768w" sizes="(max-width: 1280px) 100vw, 1280px" loading="lazy"></div>
		</a>
				<div class="elementor-post__text">
				<h3 class="elementor-post__title">
			<a href="https://randomnerdtutorials.com/esp32-bmp388-arduino/">
				ESP32 with BMP388 Barometric/Altimeter Sensor (Arduino IDE)			</a>
		</h3>
				</div>
					</div>
		</article>
				<article class="elementor-post elementor-grid-item post-96830 post type-post status-publish format-standard has-post-thumbnail hentry category-esp32 category-esp32-project category-esp32-arduino-ide category-0-esp32 category-project mv-content-wrapper">
			<div class="elementor-post__card">
				<a class="elementor-post__thumbnail__link" href="https://randomnerdtutorials.com/esp32-http-post-ifttt-thingspeak-arduino/">
			<div class="elementor-post__thumbnail"><img width="1280" height="720" src="https://i2.wp.com/randomnerdtutorials.com/wp-content/uploads/2020/05/ESP32-HTTP-POST-with-Arduino-IDE-IFTTT-ThingSpeak.jpg?fit=1280%2C720&amp;quality=100&amp;strip=all&amp;ssl=1" class="attachment-full size-full" alt="ESP32 HTTP POST with Arduino IDE IFTTT ThingSpeak" srcset="https://i2.wp.com/randomnerdtutorials.com/wp-content/uploads/2020/05/ESP32-HTTP-POST-with-Arduino-IDE-IFTTT-ThingSpeak.jpg?w=1280&amp;quality=100&amp;strip=all&amp;ssl=1 1280w, https://i2.wp.com/randomnerdtutorials.com/wp-content/uploads/2020/05/ESP32-HTTP-POST-with-Arduino-IDE-IFTTT-ThingSpeak.jpg?resize=300%2C169&amp;quality=100&amp;strip=all&amp;ssl=1 300w, https://i2.wp.com/randomnerdtutorials.com/wp-content/uploads/2020/05/ESP32-HTTP-POST-with-Arduino-IDE-IFTTT-ThingSpeak.jpg?resize=1024%2C576&amp;quality=100&amp;strip=all&amp;ssl=1 1024w, https://i2.wp.com/randomnerdtutorials.com/wp-content/uploads/2020/05/ESP32-HTTP-POST-with-Arduino-IDE-IFTTT-ThingSpeak.jpg?resize=768%2C432&amp;quality=100&amp;strip=all&amp;ssl=1 768w" sizes="(max-width: 1280px) 100vw, 1280px" loading="lazy"></div>
		</a>
				<div class="elementor-post__text">
				<h3 class="elementor-post__title">
			<a href="https://randomnerdtutorials.com/esp32-http-post-ifttt-thingspeak-arduino/">
				ESP32 HTTP POST with Arduino IDE (ThingSpeak and IFTTT.com)			</a>
		</h3>
				</div>
					</div>
		</article>
				<article class="elementor-post elementor-grid-item post-96491 post type-post status-publish format-standard has-post-thumbnail hentry category-micropython category-0-esp32-micropython category-project mv-content-wrapper">
			<div class="elementor-post__card">
				<a class="elementor-post__thumbnail__link" href="https://randomnerdtutorials.com/micropython-relay-web-server-esp32-esp8266/">
			<div class="elementor-post__thumbnail"><img width="1280" height="720" src="https://i0.wp.com/randomnerdtutorials.com/wp-content/uploads/2020/04/MicroPython-firmware-ESP32-ESP8266-control-relay-web-server-ac-voltage-project.jpg?fit=1280%2C720&amp;quality=100&amp;strip=all&amp;ssl=1" class="attachment-full size-full" alt="MicroPython ESP32 ESP8266 NodeMCU Relay Module Web Server AC Appliances" srcset="https://i0.wp.com/randomnerdtutorials.com/wp-content/uploads/2020/04/MicroPython-firmware-ESP32-ESP8266-control-relay-web-server-ac-voltage-project.jpg?w=1280&amp;quality=100&amp;strip=all&amp;ssl=1 1280w, https://i0.wp.com/randomnerdtutorials.com/wp-content/uploads/2020/04/MicroPython-firmware-ESP32-ESP8266-control-relay-web-server-ac-voltage-project.jpg?resize=300%2C169&amp;quality=100&amp;strip=all&amp;ssl=1 300w, https://i0.wp.com/randomnerdtutorials.com/wp-content/uploads/2020/04/MicroPython-firmware-ESP32-ESP8266-control-relay-web-server-ac-voltage-project.jpg?resize=1024%2C576&amp;quality=100&amp;strip=all&amp;ssl=1 1024w, https://i0.wp.com/randomnerdtutorials.com/wp-content/uploads/2020/04/MicroPython-firmware-ESP32-ESP8266-control-relay-web-server-ac-voltage-project.jpg?resize=768%2C432&amp;quality=100&amp;strip=all&amp;ssl=1 768w" sizes="(max-width: 1280px) 100vw, 1280px" loading="lazy"></div>
		</a>
				<div class="elementor-post__text">
				<h3 class="elementor-post__title">
			<a href="https://randomnerdtutorials.com/micropython-relay-web-server-esp32-esp8266/">
				MicroPython: ESP32/ESP8266 Relay Module Web Server (AC Appliances)			</a>
		</h3>
				</div>
					</div>
		</article>
				</div>
				</div>
				</div>
						</div>
					</div>
		</div>
								</div>
					</div>
		</section>
				</div>
		</div>
		
<br>
		<div data-elementor-type="section" data-elementor-id="82829" class="elementor elementor-82829" data-elementor-settings="[]">
		<div class="elementor-section-wrap">
					<section class="elementor-section elementor-top-section elementor-element elementor-element-1e028b5e elementor-section-boxed elementor-section-height-default elementor-section-height-default" data-id="1e028b5e" data-element_type="section">
						<div class="elementor-container elementor-column-gap-default">
							<div class="elementor-row">
					<div class="elementor-column elementor-col-100 elementor-top-column elementor-element elementor-element-69628243" data-id="69628243" data-element_type="column">
			<div class="elementor-column-wrap elementor-element-populated">
							<div class="elementor-widget-wrap">
						<section class="elementor-section elementor-inner-section elementor-element elementor-element-4a02bbce elementor-section-boxed elementor-section-height-default elementor-section-height-default" data-id="4a02bbce" data-element_type="section">
						<div class="elementor-container elementor-column-gap-default">
							<div class="elementor-row">
					<div class="elementor-column elementor-col-100 elementor-inner-column elementor-element elementor-element-3a76ce22" data-id="3a76ce22" data-element_type="column">
			<div class="elementor-column-wrap elementor-element-populated">
							<div class="elementor-widget-wrap">
						<div class="elementor-element elementor-element-d86fe9d elementor-widget elementor-widget-heading" data-id="d86fe9d" data-element_type="widget" data-widget_type="heading.default">
				<div class="elementor-widget-container">
			<h3 class="elementor-heading-title elementor-size-default">Enjoyed this project? Stay updated by subscribing our newsletter!</h3>		</div>
				</div>
				<div class="elementor-element elementor-element-93ef837 elementor-button-align-stretch elementor-widget elementor-widget-form" data-id="93ef837" data-element_type="widget" data-settings='{"button_width":"33","step_next_label":"Next","step_previous_label":"Previous","step_type":"number_text","step_icon_shape":"circle"}' data-widget_type="form.default">
				<div class="elementor-widget-container">
					<form class="elementor-form" method="post" name="New Form">
			<input type="hidden" name="post_id" value="82829">
			<input type="hidden" name="form_id" value="93ef837">
			<input type="hidden" name="referer_title" value="ESP8266 NodeMCU Stepper Motor (28BYJ-48 and ULN2003 Driver) | Random Nerd Tutorials">

							<input type="hidden" name="queried_id" value="106084">
			
			<div class="elementor-form-fields-wrapper elementor-labels-">
								<div class="elementor-field-type-email elementor-field-group elementor-column elementor-field-group-email elementor-col-66 elementor-field-required">
					<label for="form-field-email" class="elementor-field-label elementor-screen-only">Email</label><input size="1" type="email" name="form_fields[email]" id="form-field-email" class="elementor-field elementor-size-sm  elementor-field-textual" placeholder="Your Email Address" required="required" aria-required="true">				</div>
								<div class="elementor-field-group elementor-column elementor-field-type-submit elementor-col-33 e-form__buttons">
					<button type="submit" class="elementor-button elementor-size-sm">
						<span>
															<span class=" elementor-button-icon">
																										</span>
																						<span class="elementor-button-text">SUBSCRIBE</span>
													</span>
					</button>
				</div>
			</div>
		</form>
				</div>
				</div>
						</div>
					</div>
		</div>
								</div>
					</div>
		</section>
						</div>
					</div>
		</div>
								</div>
					</div>
		</section>
				</div>
		</div>
			</div>
</article>

			<div class="comments-area">
				<div id="comments" style="content-visibility:auto;contain-intrinsic-size:1px 1000px;">

		<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Comment <small><a rel="nofollow" id="cancel-comment-reply-link" href="/esp8266-nodemcu-stepper-motor-28byj-48-uln2003/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://randomnerdtutorials.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><p class="comment-form-comment"><label for="comment" class="screen-reader-text">Comment</label><textarea id="comment" name="comment" cols="45" rows="8" aria-required="true" required></textarea></p><label for="author" class="screen-reader-text">Name</label><input placeholder="Name *" id="author" name="author" type="text" value="" size="30">
<label for="email" class="screen-reader-text">Email</label><input placeholder="Email *" id="email" name="email" type="email" value="" size="30">
<label for="url" class="screen-reader-text">Website</label><input placeholder="Website" id="url" name="url" type="url" value="" size="30">
<p class="comment-subscription-form"><input type="checkbox" name="subscribe_comments" id="subscribe_comments" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;"> <label class="subscribe-label" id="subscribe-label" for="subscribe_comments">Notify me of follow-up comments by email.</label></p><p class="comment-subscription-form"><input type="checkbox" name="subscribe_blog" id="subscribe_blog" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;"> <label class="subscribe-label" id="subscribe-blog-label" for="subscribe_blog">Notify me of new posts by email.</label></p><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment"> <input type="hidden" name="comment_post_ID" value="106084" id="comment_post_ID">
<input type="hidden" name="comment_parent" id="comment_parent" value="0">
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="64e739f063"></p><input type="hidden" id="ak_js" name="ak_js" value="50"><textarea name="ak_hp_textarea" cols="45" rows="8" maxlength="100" style="display: none !important;"></textarea></form>	</div><!-- #respond -->
	
</div><!-- #comments -->
			</div>

					</main>
	</div>

	<div id="left-sidebar" class="widget-area sidebar is-left-sidebar grid-15 tablet-grid-15 mobile-grid-100 grid-parent pull-60 tablet-pull-60" itemtype="https://schema.org/WPSideBar" itemscope>
	<div class="inside-left-sidebar">
		<aside id="text-57" class="widget inner-padding widget_text">			<div class="textwidget"><div class="rnt-sb-m">
<p><span class="rnt-shl">Learn ESP8266</span></p>
<p><a href="https://randomnerdtutorials.com/getting-started-with-esp8266-wifi-transceiver-review/">ESP8266 Introduction</a></p>
<p><a href="https://randomnerdtutorials.com/how-to-install-esp8266-board-arduino-ide/">ESP8266 Arduino IDE</a></p>
<p><a href="https://randomnerdtutorials.com/installing-esp8266-nodemcu-arduino-ide-2-0/">ESP8266 Arduino IDE 2.0</a></p>
<p><a href="https://randomnerdtutorials.com/vs-code-platformio-ide-esp32-esp8266-arduino/">VS Code and PlatformIO</a></p>
<p><a href="https://randomnerdtutorials.com/esp8266-pinout-reference-gpios/">ESP8266 Pinout</a></p>
<p><a href="https://randomnerdtutorials.com/esp8266-nodemcu-digital-inputs-outputs-arduino/">ESP8266 Inputs Outputs</a></p>
<p><a href="https://randomnerdtutorials.com/esp8266-pwm-arduino-ide/">ESP8266 PWM</a></p>
<p><a href="https://randomnerdtutorials.com/esp8266-adc-reading-analog-values-with-nodemcu/">ESP8266 Analog Inputs</a></p>
<p><a href="https://randomnerdtutorials.com/interrupts-timers-esp8266-arduino-ide-nodemcu/">ESP8266 Interrupts Timers</a></p>
<p><a href="https://randomnerdtutorials.com/esp8266-deep-sleep-with-arduino-ide/">ESP8266 Deep Sleep</a></p>
<p><span class="rnt-shl">Protocols</span></p>
<p><a href="https://randomnerdtutorials.com/esp8266-web-server/">ESP8266 Web Server</a></p>
<p><a href="https://randomnerdtutorials.com/esp8266-and-node-red-with-mqtt/">ESP8266 MQTT</a></p>
<p><a href="https://randomnerdtutorials.com/esp-now-esp8266-nodemcu-arduino-ide/">ESP8266 ESP-NOW</a></p>
<p><a href="https://randomnerdtutorials.com/esp8266-nodemcu-client-server-wi-fi/">ESP8266 Wi-Fi</a></p>
<p><a href="https://randomnerdtutorials.com/esp8266-nodemcu-websocket-server-arduino/">ESP8266 WebSocket</a></p>
<p><a href="https://randomnerdtutorials.com/esp-mesh-esp32-esp8266-painlessmesh/">ESP8266 ESP-MESH</a></p>
<p><a href="https://randomnerdtutorials.com/esp8266-nodemcu-send-email-smtp-server-arduino/">ESP8266 Email</a></p>
<p><a href="https://randomnerdtutorials.com/esp8266-nodemcu-http-get-post-arduino/">ESP8266 HTTP GET POST</a></p>
<p><a href="https://randomnerdtutorials.com/esp8266-nodemcu-http-get-open-weather-map-thingspeak-arduino/">HTTP GET Web APIs</a></p>
<p><a href="https://randomnerdtutorials.com/esp8266-nodemcu-http-post-ifttt-thingspeak-arduino/">HTTP POST Web APIs</a></p>
<p><a href="https://randomnerdtutorials.com/esp-now-one-to-many-esp8266-nodemcu/">ESP-NOW One-to-Many</a></p>
<p><a href="https://randomnerdtutorials.com/esp-now-many-to-one-esp8266-nodemcu/">ESP-NOW Many-to-One</a></p>
<p><a href="https://randomnerdtutorials.com/esp-now-two-way-communication-esp8266-nodemcu/">ESP-NOW Two-Way</a></p>
<p><a href="https://randomnerdtutorials.com/esp-now-one-to-many-esp32-esp8266/">ESP-NOW ESP8266 + ESP32</a></p>
<p><a href="https://randomnerdtutorials.com/esp8266-esp-now-wi-fi-web-server/">ESP-NOW + Wi-Fi Web Server</a></p>
<p><a href="https://randomnerdtutorials.com/esp8266-nodemcu-web-server-sent-events-sse/">Server-Sent Events</a></p>
<p><span class="rnt-shl">Web Servers</span></p>
<p><a href="https://randomnerdtutorials.com/esp8266-web-server/">Output Web Server</a></p>
<p><a href="https://randomnerdtutorials.com/esp8266-nodemcu-web-server-slider-pwm/">PWM Slider Web Server</a></p>
<p><a href="https://randomnerdtutorials.com/esp8266-nodemcu-web-server-websocket-sliders/">PWM Multiple Sliders Web Server</a></p>
<p><a href="https://randomnerdtutorials.com/esp8266-nodemcu-async-web-server-espasyncwebserver-library/">Async Web Server</a></p>
<p><a href="https://randomnerdtutorials.com/esp8266-relay-module-ac-web-server/">Relay Web Server</a></p>
<p><a href="https://randomnerdtutorials.com/esp8266-dht11dht22-temperature-and-humidity-web-server-with-arduino-ide/">DHT Web Server</a></p>
<p><a href="https://randomnerdtutorials.com/esp8266-bme280-arduino-ide/">BME280 Web Server</a></p>
<p><a href="https://randomnerdtutorials.com/esp8266-nodemcu-bme680-web-server-arduino/">BME680 Web Server</a></p>
<p><a href="https://randomnerdtutorials.com/esp8266-ds18b20-temperature-sensor-web-server-with-arduino-ide/">DS18B20 Web Server</a></p>
<p><a href="https://randomnerdtutorials.com/esp32-esp8266-plot-chart-web-server/">Plot/Chart Web Server</a></p>
<p><a href="https://randomnerdtutorials.com/esp8266-nodemcu-plot-readings-charts-multiple/">Chart Multiple Series Web Server</a></p>
<p><a href="https://randomnerdtutorials.com/esp8266-web-server-spiffs-nodemcu/">SPIFFS Web Server</a></p>
<p><a href="https://randomnerdtutorials.com/esp32-esp8266-thermostat-web-server/">Thermostat Web Server</a></p>
<p><a href="https://randomnerdtutorials.com/esp32-esp8266-input-data-html-form/">Input Fields Web Server</a></p>
<p><a href="https://randomnerdtutorials.com/display-images-esp32-esp8266-web-server/">Images Web Server</a></p>
<p><a href="https://randomnerdtutorials.com/esp32-esp8266-rgb-led-strip-web-server/">RGB LED Web Server</a></p>
<p><a href="https://randomnerdtutorials.com/esp32-esp8266-web-server-outputs-momentary-switch/">Momentary Switch Web Server</a></p>
<p><a href="https://randomnerdtutorials.com/esp32-esp8266-web-server-physical-button/">Physical Button Web Server</a></p>
<p><a href="https://randomnerdtutorials.com/esp32-esp8266-web-server-timer-pulse/">Timer/Pulse Web Server</a></p>
<p><a href="https://randomnerdtutorials.com/esp32-esp8266-web-server-http-authentication/">HTTP Auth Web Server</a></p>
<p><a href="https://randomnerdtutorials.com/wifimanager-with-esp8266-autoconnect-custom-parameter-and-manage-your-ssid-and-password/">ESP8266 WiFiManager</a></p>
<p><span class="rnt-shl">DIY Cloud</span></p>
<p><a href="https://randomnerdtutorials.com/cloud-weather-station-esp32-esp8266/">ESP8266 Weather Station</a></p>
<p><a href="https://randomnerdtutorials.com/control-esp32-esp8266-gpios-from-anywhere/">Control GPIOs</a></p>
<p><a href="https://randomnerdtutorials.com/visualize-esp32-esp8266-sensor-readings-from-anywhere/">View Sensor Readings</a></p>
<p><a href="https://randomnerdtutorials.com/esp32-esp8266-mysql-database-php/">ESP8266 MySQL</a></p>
<p><a href="https://randomnerdtutorials.com/esp32-esp8266-send-email-notification/">ESP8266 PHP Email</a></p>
<p><a href="https://randomnerdtutorials.com/access-node-red-dashboard-anywhere-digital-ocean/">Cloud Node-RED Dashboard</a></p>
<p><a href="https://randomnerdtutorials.com/cloud-mqtt-mosquitto-broker-access-anywhere-digital-ocean/">Cloud MQTT Broker</a></p>
<p><span class="rnt-shl">Modules and Sensors</span></p>
<p><a href="https://randomnerdtutorials.com/esp8266-relay-module-ac-web-server/">ESP8266 Relay Module</a></p>
<p><a href="https://randomnerdtutorials.com/interrupts-timers-esp8266-arduino-ide-nodemcu/">ESP8266 PIR</a></p>
<p><a href="https://randomnerdtutorials.com/esp8266-nodemcu-hc-sr04-ultrasonic-arduino/">ESP8266 HC-SR04</a></p>
<p><a href="https://randomnerdtutorials.com/hack-pir-motion-sensor-esp8266-hlk-pm03/">ESP8266 AC PIR</a></p>
<p><a href="https://randomnerdtutorials.com/door-status-monitor-using-the-esp8266/">ESP8266 Reed Switch</a></p>
<p><a href="https://randomnerdtutorials.com/esp8266-dht11dht22-temperature-and-humidity-web-server-with-arduino-ide/">ESP8266 DHT11/DHT22</a></p>
<p><a href="https://randomnerdtutorials.com/esp8266-bme280-arduino-ide/">ESP8266 BME280</a></p>
<p><a href="https://randomnerdtutorials.com/esp8266-nodemcu-bme680-sensor-arduino/">ESP8266 BME680</a></p>
<p><a href="https://randomnerdtutorials.com/esp8266-ds18b20-temperature-sensor-web-server-with-arduino-ide/">ESP8266 DS18B20</a></p>
<p><a href="https://randomnerdtutorials.com/esp8266-nodemcu-bmp388-arduino/">ESP8266 BMP388</a></p>
<p><a href="https://randomnerdtutorials.com/esp8266-hi-link-hlk-pm03/">ESP8266 Mains Voltage</a></p>
<p><span class="rnt-shl">Displays</span></p>
<p><a href="https://randomnerdtutorials.com/esp8266-0-96-inch-oled-display-with-arduino-ide/">ESP8266 OLED</a></p>
<p><a href="https://randomnerdtutorials.com/esp32-esp8266-i2c-lcd-arduino-ide/">ESP8266 LCD</a></p>
<p><a href="https://randomnerdtutorials.com/nextion-display-with-esp8266-touchscreen-user-interface-for-node-red/">ESP8266 Nextion</a></p>
<p><a href="https://randomnerdtutorials.com/esp32-esp8266-dht-temperature-and-humidity-oled-display/">OLED Temperature</a></p>
<p><span class="rnt-shl">MQTT</span></p>
<p><a href="https://randomnerdtutorials.com/esp8266-and-node-red-with-mqtt/">ESP8266 MQTT</a></p>
<p><a href="https://randomnerdtutorials.com/raspberry-pi-publishing-mqtt-messages-to-esp8266/">MQTT Output RPi</a></p>
<p><a href="https://randomnerdtutorials.com/esp8266-publishing-dht22-readings-with-mqtt-to-raspberry-pi/">MQTT DHT RPi</a></p>
<p><a href="https://randomnerdtutorials.com/esp8266-publishing-dht22-readings-to-sqlite-database/">MQTT SQLite RPi</a></p>
<p><a href="https://randomnerdtutorials.com/esp8266-nodemcu-mqtt-publish-dht11-dht22-arduino/">MQTT DHT11/DHT22</a></p>
<p><a href="https://randomnerdtutorials.com/esp8266-nodemcu-mqtt-publish-bme280-arduino/">MQTT BME280</a></p>
<p><a href="https://randomnerdtutorials.com/esp8266-nodemcu-mqtt-publish-bme680-arduino/">MQTT BME680</a></p>
<p><a href="https://randomnerdtutorials.com/esp8266-nodemcu-mqtt-publish-ds18b20-arduino/">MQTT DS18B20</a></p>
<p><a href="https://randomnerdtutorials.com/esp8266-nodemcu-mpu-6050-accelerometer-gyroscope-arduino/">ESP8266 MPU-6050</a></p>
<p><span class="rnt-shl">Other Projects</span></p>
<p><a href="https://randomnerdtutorials.com/alexa-echo-with-esp32-and-esp8266/">ESP8266 Alexa</a></p>
<p><a href="https://randomnerdtutorials.com/esp32-esp8266-publish-sensor-readings-to-google-sheets/">ESP8266 Google Sheets</a></p>
<p><a href="https://randomnerdtutorials.com/esp8266-multisensor-shield/">Multisensor Shield</a></p>
<p><a href="https://randomnerdtutorials.com/esp8266-multisensor-shield-with-node-red/">Multisensor Shield Node-RED</a></p>
<p><a href="https://randomnerdtutorials.com/esp8266-daily-task-publish-temperature-readings-to-thingspeak/">ESP8266 Daily Task</a></p>
<p><a href="https://randomnerdtutorials.com/esp8266-wi-fi-button-diy-amazon-dash-button-clone/">ESP8266 Wi-Fi Button</a></p>
<p><a href="https://randomnerdtutorials.com/latching-power-switch-circuit-auto-power-off-circuit-esp32-esp8266-arduino/">Latching Power Circuit</a></p>
<p><a href="https://randomnerdtutorials.com/telegram-control-esp32-esp8266-nodemcu-outputs/">Telegram Control Outputs</a></p>
<p><a href="https://randomnerdtutorials.com/telegram-request-esp32-esp8266-nodemcu-sensor-readings/">Telegram Sensor Readings</a></p>
<p><a href="https://randomnerdtutorials.com/telegram-esp8266-nodemcu-motion-detection-arduino/">Telegram Detect Motion</a></p>
<p><a href="https://randomnerdtutorials.com/telegram-group-esp32-esp8266/">Telegram Group</a></p>
<p><span class="rnt-shl">Useful Guides</span></p>
<p><a href="https://randomnerdtutorials.com/esp8266-troubleshooting-guide/">ESP8266 Troubleshooting</a></p>
<p><a href="https://randomnerdtutorials.com/esp8266-nodemcu-access-point-ap-web-server/">ESP8266 Access Point</a></p>
<p><a href="https://randomnerdtutorials.com/esp8266-nodemcu-static-fixed-ip-address-arduino/">ESP8266 Fixed IP Address</a></p>
<p><a href="https://randomnerdtutorials.com/get-change-esp32-esp8266-mac-address-arduino/">ESP8266 MAC Address</a></p>
<p><a href="https://randomnerdtutorials.com/solved-reconnect-esp8266-nodemcu-to-wifi/">ESP8266 Reconnect Wi-Fi</a></p>
<p><a href="https://randomnerdtutorials.com/esp8266-nodemcu-set-custom-hostname-arduino/">ESP8266 Hostname</a></p>
<p><a href="https://randomnerdtutorials.com/esp8266-ota-updates-with-arduino-ide-over-the-air/">ESP8266 OTA</a></p>
<p><a href="https://randomnerdtutorials.com/esp8266-nodemcu-ota-over-the-air-arduino/">ESP8266 OTA Arduino</a></p>
<p><a href="https://randomnerdtutorials.com/esp8266-nodemcu-ota-over-the-air-vs-code/">ESP8266 OTA VS Code</a></p>
<p><a href="https://randomnerdtutorials.com/power-esp32-esp8266-solar-panels-battery-level-monitoring/">ESP8266 Solar Panels</a></p>
<p><a href="https://randomnerdtutorials.com/esp8266-voltage-regulator-lipo-and-li-ion-batteries/">ESP8266 Voltage Regulator</a></p>
<p><a href="https://randomnerdtutorials.com/esp8266-nodemcu-thingspeak-publish-arduino/">ESP8266 ThingSpeak</a></p>
<p><a href="https://randomnerdtutorials.com/install-esp8266-filesystem-uploader-arduino-ide/">ESP8266 Install SPIFFS</a></p>
<p><a href="https://randomnerdtutorials.com/install-esp8266-nodemcu-littlefs-arduino/">ESP8266 Install LittleFS</a></p>
<p><a href="https://randomnerdtutorials.com/esp8266-nodemcu-date-time-ntp-client-server-arduino/">ESP8266 Time and Date</a></p>
<p><a href="https://randomnerdtutorials.com/epoch-unix-time-esp8266-nodemcu-arduino/">ESP8266 Epoch Time</a></p>
<p><a href="https://randomnerdtutorials.com/decoding-and-encoding-json-with-arduino-or-esp8266/">ESP8266 JSON</a></p>
<p><a href="https://randomnerdtutorials.com/vs-code-platformio-ide-esp32-esp8266-arduino/">VS Code and PlatformIO</a></p>
<p><a href="https://randomnerdtutorials.com/esp8266-nodemcu-vs-code-platformio-littlefs/">VS Code LittleFS</a></p>
<p><a href="https://randomnerdtutorials.com/vs-code-workspaces-esp32-esp8266/">VS Code Workspaces</a></p>
<p><span class="rnt-shl">Learn More</span></p>
<p><a href="https://randomnerdtutorials.com/projects-esp32/">Learn ESP32</a></p>
<p><a href="https://randomnerdtutorials.com/projects-esp8266/">Learn ESP8266</a></p>
<p><a href="https://randomnerdtutorials.com/projects-esp32-cam/">Learn ESP32-CAM</a></p>
<p><a href="https://randomnerdtutorials.com/projects-esp32-esp8266-micropython/">Learn MicroPython</a></p>
<p><a href="https://randomnerdtutorials.com/projects-arduino/">Learn Arduino</a></p>
<p><a href="https://randomnerdtutorials.com/build-web-servers-esp32-esp8266-ebook/"><strong>Build Web Servers eBook</strong></a></p>
<p><a href="https://randomnerdtutorials.com/home-automation-using-esp8266/"><strong>ESP8266 eBook »</strong></a></p>
</div>
</div>
		</aside><aside id="search-4" class="widget inner-padding widget_search"><form method="get" class="search-form" action="https://randomnerdtutorials.com/">
	<label>
		<span class="screen-reader-text">Search for:</span>
		<input type="search" class="search-field" placeholder="Search …" value="" name="s" title="Search for:">
	</label>
	<input type="submit" class="search-submit" value="Search"></form>
</aside>	</div>
</div>
<div id="right-sidebar" class="widget-area sidebar is-right-sidebar grid-25 tablet-grid-25 grid-parent" itemtype="https://schema.org/WPSideBar" itemscope>
	<div class="inside-right-sidebar">
		<aside id="text-49" class="widget inner-padding widget_text">			<div class="textwidget"><p><a href="https://makeradvisor.com/?utm_source=rnt&amp;utm_medium=sb&amp;utm_campaign=sb" target="_blank" rel="noopener"><img class="aligncenter" src="https://i2.wp.com/randomnerdtutorials.com/wp-content/uploads/2017/10/lab-sb-img.jpg?w=828&amp;quality=100&amp;strip=all" data-recalc-dims="1" loading="lazy"></a><br>
<strong><a href="https://makeradvisor.com/?utm_source=rnt&amp;utm_medium=sb&amp;utm_campaign=sb" target="_blank" rel="noopener">Visit Maker Advisor – Tools and Gear for makers, hobbyists and DIYers »</a></strong></p>
</div>
		</aside><aside id="text-47" class="widget inner-padding widget_text">			<div class="textwidget"><p><a href="https://randomnerdtutorials.com/home-automation-using-esp8266/"><img class="aligncenter" src="https://i1.wp.com/randomnerdtutorials.com/wp-content/uploads/2017/10/esp8266-sb-img.jpg?w=828&amp;quality=100&amp;strip=all" data-recalc-dims="1" loading="lazy"></a><br>
<strong><a href="https://randomnerdtutorials.com/home-automation-using-esp8266/">Home Automation using ESP8266 eBook and video course »</a> </strong>Build IoT and home automation projects.</p>
</div>
		</aside><aside id="text-46" class="widget inner-padding widget_text">			<div class="textwidget"><p><a href="https://randomnerdtutorials.com/build-a-home-automation-system-for-100/"><img class="aligncenter" src="https://i1.wp.com/randomnerdtutorials.com/wp-content/uploads/2017/10/home-automation-sb-img.jpg?w=828&amp;quality=100&amp;strip=all" data-recalc-dims="1" loading="lazy"></a><br>
<strong><a href="https://randomnerdtutorials.com/build-a-home-automation-system-for-100/">Build a Home Automation System from Scratch »</a> </strong>With Raspberry Pi, ESP8266, Arduino, and Node-RED.</p>
</div>
		</aside>	</div>
</div>

	</div>
</div>


<div class="site-footer footer-bar-active footer-bar-align-center">
			<footer class="site-info" itemtype="https://schema.org/WPFooter" itemscope style="content-visibility:auto;contain-intrinsic-size:1px 1000px;">
			<div class="inside-site-info grid-container grid-parent">
						<div class="footer-bar">
			<aside id="nav_menu-10" class="widget inner-padding widget_nav_menu"><div class="menu-footer-disclaimer-container"><ul id="menu-footer-disclaimer" class="menu"><li id="menu-item-82503" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-82503"><a href="https://randomnerdtutorials.com/about/">About</a></li>
<li id="menu-item-20492" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-20492"><a href="https://randomnerdtutorials.com/support">Support</a></li>
<li id="menu-item-20493" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-20493"><a href="https://randomnerdtutorials.com/terms">Terms and Conditions</a></li>
<li id="menu-item-20495" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-20495"><a href="https://randomnerdtutorials.com/privacy-policy/">Privacy Policy</a></li>
<li id="menu-item-20494" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-20494"><a href="https://randomnerdtutorials.com/returns-and-refunds/">Refunds</a></li>
<li id="menu-item-103055" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-103055"><a target="_blank" rel="noreferrer noopener nofollow" href="https://www.livroreclamacoes.pt/inicio/">Complaints’ Book</a></li>
<li id="menu-item-43625" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-43625"><a target="_blank" rel="noopener" href="https://makeradvisor.com/">MakerAdvisor.com</a></li>
<li id="menu-item-20496" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-20496"><a target="_blank" rel="noopener" href="https://rntlab.com/">Join the Lab</a></li>
</ul></div></aside>		</div>
						<div class="copyright-bar">
					Copyright © 2013-2021 · RandomNerdTutorials.com · All Rights Reserved				</div>
			</div>
		</footer>
		</div>

		<div data-elementor-type="popup" data-elementor-id="83058" class="elementor elementor-83058 elementor-location-popup" data-elementor-settings='{"entrance_animation":"zoomIn","close_button_position":"outside","entrance_animation_duration":{"unit":"px","size":1.2,"sizes":[]},"triggers":{"scrolling":"yes","scrolling_offset":35,"scrolling_direction":"down"},"timing":{"times":"yes","times_times":3}}'>
		<div class="elementor-section-wrap">
					<section class="elementor-section elementor-top-section elementor-element elementor-element-544e0740 elementor-section-content-bottom elementor-reverse-mobile elementor-section-boxed elementor-section-height-default elementor-section-height-default" data-id="544e0740" data-element_type="section" data-settings='{"background_background":"classic"}'>
						<div class="elementor-container elementor-column-gap-default">
							<div class="elementor-row">
					<div class="elementor-column elementor-col-100 elementor-top-column elementor-element elementor-element-676b082e" data-id="676b082e" data-element_type="column">
			<div class="elementor-column-wrap elementor-element-populated">
							<div class="elementor-widget-wrap">
						<div class="elementor-element elementor-element-5eee063c elementor-widget elementor-widget-heading" data-id="5eee063c" data-element_type="widget" data-widget_type="heading.default">
				<div class="elementor-widget-container">
			<h2 class="elementor-heading-title elementor-size-default">Download our Free eBooks and Resources</h2>		</div>
				</div>
				<div class="elementor-element elementor-element-9bd904c elementor-hidden-phone elementor-widget elementor-widget-text-editor" data-id="9bd904c" data-element_type="widget" data-widget_type="text-editor.default">
				<div class="elementor-widget-container">
								<div class="elementor-text-editor elementor-clearfix">
					<p>Get instant access to our FREE eBooks, Resources, and Exclusive Electronics Projects by entering your email address below.</p>					</div>
						</div>
				</div>
				<div class="elementor-element elementor-element-2a77907 elementor-button-align-stretch elementor-widget elementor-widget-form" data-id="2a77907" data-element_type="widget" data-settings='{"step_next_label":"Next","step_previous_label":"Previous","button_width":"100","step_type":"number_text","step_icon_shape":"circle"}' data-widget_type="form.default">
				<div class="elementor-widget-container">
					<form class="elementor-form" method="post" name="New Form">
			<input type="hidden" name="post_id" value="83058">
			<input type="hidden" name="form_id" value="2a77907">
			<input type="hidden" name="referer_title" value="ESP8266 NodeMCU Stepper Motor (28BYJ-48 and ULN2003 Driver) | Random Nerd Tutorials">

							<input type="hidden" name="queried_id" value="106084">
			
			<div class="elementor-form-fields-wrapper elementor-labels-">
								<div class="elementor-field-type-email elementor-field-group elementor-column elementor-field-group-email elementor-col-100 elementor-field-required">
					<label for="form-field-email" class="elementor-field-label elementor-screen-only">Email</label><input size="1" type="email" name="form_fields[email]" id="form-field-email" class="elementor-field elementor-size-sm  elementor-field-textual" placeholder="Your Email Address" required="required" aria-required="true">				</div>
								<div class="elementor-field-group elementor-column elementor-field-type-submit elementor-col-100 e-form__buttons">
					<button type="submit" class="elementor-button elementor-size-md">
						<span>
															<span class=" elementor-button-icon">
																										</span>
																						<span class="elementor-button-text">FREE DOWNLOAD</span>
													</span>
					</button>
				</div>
			</div>
		</form>
				</div>
				</div>
						</div>
					</div>
		</div>
								</div>
					</div>
		</section>
				</div>
		</div>
		<link rel="stylesheet" data-lazy-method="interaction" data-lazy-attributes="href" data-lazy-href="https://cdnjs.cloudflare.com/ajax/libs/prism/1.23.0/themes/prism.min.css">
<script src="https://cdnjs.cloudflare.com/ajax/libs/prism/1.23.0/prism.min.js" defer></script>
<script src="https://cdnjs.cloudflare.com/ajax/libs/prism/1.23.0/components/prism-c.min.js" defer></script>
<script src="https://cdnjs.cloudflare.com/ajax/libs/prism/1.23.0/components/prism-python.min.js" defer></script>
<link rel="stylesheet" id="elementor-post-83032-css" media="all" data-lazy-method="interaction" data-lazy-attributes="href" data-lazy-href="https://randomnerdtutorials.com/wp-content/cache/flying-press/randomnerdtutorials.com/0374b13add6b.post-83032.css">
<link rel="stylesheet" id="elementor-post-82533-css" media="all" data-lazy-method="interaction" data-lazy-attributes="href" data-lazy-href="https://randomnerdtutorials.com/wp-content/cache/flying-press/randomnerdtutorials.com/32493e4e071e.post-82533.css">
<link rel="stylesheet" id="elementor-post-82829-css" media="all" data-lazy-method="interaction" data-lazy-attributes="href" data-lazy-href="https://randomnerdtutorials.com/wp-content/cache/flying-press/randomnerdtutorials.com/34c8bc3901e5.post-82829.css">
<link rel="stylesheet" id="e-animations-css" media="all" data-lazy-method="interaction" data-lazy-attributes="href" data-lazy-href="https://randomnerdtutorials.com/wp-content/cache/flying-press/randomnerdtutorials.com/4601ba550444.animations.min.css">
<script src="https://randomnerdtutorials.com/wp-content/plugins/gp-premium/menu-plus/functions/js/sticky.min.js?ver=8529d83b54e8" id="generate-sticky-js" defer></script>
<script src="https://randomnerdtutorials.com/wp-content/plugins/jetpack/_inc/build/photon/photon.min.js?ver=c29857eeb45d" id="jetpack-photon-js" defer></script>
<script src="https://randomnerdtutorials.com/wp-content/plugins/flying-press/assets/preload.min.js?ver=4dcfe7c54278" id="flying_press_preload-js" defer></script>
<!--[if lte IE 11]>
<script src='https://randomnerdtutorials.com/wp-content/themes/generatepress/assets/js/classList.min.js?ver=3.0.4' id='generate-classlist-js'></script>
<![endif]-->
<script id="generate-main-js-extra">
var generatepressMenu = {"toggleOpenedSubMenus":"1","openSubMenuLabel":"Open Sub-Menu","closeSubMenuLabel":"Close Sub-Menu"};
</script>
<script src="https://randomnerdtutorials.com/wp-content/themes/generatepress/assets/js/main.min.js?ver=9a78d8d0a506" id="generate-main-js" defer></script>
<script id="generate-navigation-search-js-extra">
var generatepressNavSearch = {"open":"Open Search Bar","close":"Close Search Bar"};
</script>
<script src="https://randomnerdtutorials.com/wp-content/themes/generatepress/assets/js/navigation-search.min.js?ver=454ed58c0f6c" id="generate-navigation-search-js" defer></script>
<script src="https://randomnerdtutorials.com/wp-includes/js/comment-reply.min.js?ver=3b59c3b33879" id="comment-reply-js"></script>
<script src="https://randomnerdtutorials.com/wp-includes/js/wp-embed.min.js?ver=905225d5711b" id="wp-embed-js"></script>
<script src="https://randomnerdtutorials.com/wp-includes/js/imagesloaded.min.js?ver=3a56752b7366" id="imagesloaded-js"></script>
<script defer src="https://randomnerdtutorials.com/wp-content/cache/flying-press/randomnerdtutorials.com/270f0cd7341b.form.js" id="akismet-form-js"></script>
<script src="https://randomnerdtutorials.com/wp-content/plugins/elementor-pro/assets/js/webpack-pro.runtime.min.js?ver=18ca0b7d2f9e" id="elementor-pro-webpack-runtime-js" defer></script>
<script src="https://randomnerdtutorials.com/wp-content/plugins/elementor/assets/js/webpack.runtime.min.js?ver=e0efe313362b" id="elementor-webpack-runtime-js" defer></script>
<script src="https://randomnerdtutorials.com/wp-content/plugins/elementor/assets/js/frontend-modules.min.js?ver=0ebc90177e75" id="elementor-frontend-modules-js" defer></script>
<script id="elementor-pro-frontend-js-before">
var ElementorProFrontendConfig = {"ajaxurl":"https:\/\/randomnerdtutorials.com\/wp-admin\/admin-ajax.php","nonce":"dce7ee3aa6","urls":{"assets":"https:\/\/randomnerdtutorials.com\/wp-content\/plugins\/elementor-pro\/assets\/"},"i18n":{"toc_no_headings_found":"No headings were found on this page."},"shareButtonsNetworks":{"facebook":{"title":"Facebook","has_counter":true},"twitter":{"title":"Twitter"},"google":{"title":"Google+","has_counter":true},"linkedin":{"title":"LinkedIn","has_counter":true},"pinterest":{"title":"Pinterest","has_counter":true},"reddit":{"title":"Reddit","has_counter":true},"vk":{"title":"VK","has_counter":true},"odnoklassniki":{"title":"OK","has_counter":true},"tumblr":{"title":"Tumblr"},"digg":{"title":"Digg"},"skype":{"title":"Skype"},"stumbleupon":{"title":"StumbleUpon","has_counter":true},"mix":{"title":"Mix"},"telegram":{"title":"Telegram"},"pocket":{"title":"Pocket","has_counter":true},"xing":{"title":"XING","has_counter":true},"whatsapp":{"title":"WhatsApp"},"email":{"title":"Email"},"print":{"title":"Print"}},"facebook_sdk":{"lang":"en_US","app_id":""},"lottie":{"defaultAnimationUrl":"https:\/\/randomnerdtutorials.com\/wp-content\/plugins\/elementor-pro\/modules\/lottie\/assets\/animations\/default.json"}};
</script>
<script src="https://randomnerdtutorials.com/wp-content/plugins/elementor-pro/assets/js/frontend.min.js?ver=c7005637f766" id="elementor-pro-frontend-js" defer></script>
<script src="https://randomnerdtutorials.com/wp-content/plugins/elementor/assets/lib/waypoints/waypoints.min.js?ver=3819c3569da7" id="elementor-waypoints-js" defer></script>
<script src="https://randomnerdtutorials.com/wp-includes/js/jquery/ui/core.min.js?ver=49fa677b9cd7" id="jquery-ui-core-js"></script>
<script src="https://randomnerdtutorials.com/wp-content/plugins/elementor/assets/lib/swiper/swiper.min.js?ver=15bb2b8491fc" id="swiper-js" defer></script>
<script src="https://randomnerdtutorials.com/wp-content/plugins/elementor/assets/lib/share-link/share-link.min.js?ver=9bb8540493a7" id="share-link-js" defer></script>
<script src="https://randomnerdtutorials.com/wp-content/plugins/elementor/assets/lib/dialog/dialog.min.js?ver=58baf0f238d7" id="elementor-dialog-js" defer></script>
<script id="elementor-frontend-js-before">
var elementorFrontendConfig = {"environmentMode":{"edit":false,"wpPreview":false,"isScriptDebug":false},"i18n":{"shareOnFacebook":"Share on Facebook","shareOnTwitter":"Share on Twitter","pinIt":"Pin it","download":"Download","downloadImage":"Download image","fullscreen":"Fullscreen","zoom":"Zoom","share":"Share","playVideo":"Play Video","previous":"Previous","next":"Next","close":"Close"},"is_rtl":false,"breakpoints":{"xs":0,"sm":480,"md":768,"lg":1025,"xl":1440,"xxl":1600},"responsive":{"breakpoints":{"mobile":{"label":"Mobile","value":767,"direction":"max","is_enabled":true,"default_value":767},"mobile_extra":{"label":"Mobile Extra","value":880,"direction":"max","is_enabled":false,"default_value":880},"tablet":{"label":"Tablet","value":1024,"direction":"max","is_enabled":true,"default_value":1024},"tablet_extra":{"label":"Tablet Extra","value":1365,"direction":"max","is_enabled":false,"default_value":1365},"laptop":{"label":"Laptop","value":1620,"direction":"max","is_enabled":false,"default_value":1620},"widescreen":{"label":"Widescreen","value":2400,"direction":"min","is_enabled":false,"default_value":2400}}},"version":"3.3.1","is_static":false,"experimentalFeatures":{"e_import_export":true,"landing-pages":true,"elements-color-picker":true,"admin-top-bar":true,"form-submissions":true,"video-playlist":true},"urls":{"assets":"https:\/\/randomnerdtutorials.com\/wp-content\/plugins\/elementor\/assets\/"},"settings":{"page":[],"editorPreferences":[]},"kit":{"active_breakpoints":["viewport_mobile","viewport_tablet"],"lightbox_enable_counter":"yes","lightbox_enable_fullscreen":"yes","lightbox_enable_zoom":"yes","lightbox_enable_share":"yes","lightbox_title_src":"title","lightbox_description_src":"description"},"post":{"id":106084,"title":"ESP8266%20NodeMCU%20Stepper%20Motor%20%2828BYJ-48%20and%20ULN2003%20Driver%29%20%7C%20Random%20Nerd%20Tutorials%20","excerpt":"","featuredImage":"https:\/\/i2.wp.com\/randomnerdtutorials.com\/wp-content\/uploads\/2021\/08\/ESP8266-Stepper-Motor-Tutorial-Arduino-IDE.jpg?fit=828%2C466&quality=100&strip=all&ssl=1"}};
</script>
<script src="https://randomnerdtutorials.com/wp-content/plugins/elementor/assets/js/frontend.min.js?ver=a57515d96bc0" id="elementor-frontend-js" defer></script>
<script src="https://randomnerdtutorials.com/wp-content/plugins/elementor-pro/assets/js/preloaded-elements-handlers.min.js?ver=d0376d181ece" id="pro-preloaded-elements-handlers-js" defer></script>
<script src="https://randomnerdtutorials.com/wp-content/plugins/elementor/assets/js/preloaded-modules.min.js?ver=7cf762f9c52e" id="preloaded-modules-js" defer></script>
<script src="https://randomnerdtutorials.com/wp-content/plugins/elementor-pro/assets/lib/sticky/jquery.sticky.min.js?ver=e16a8821e5f0" id="e-sticky-js" defer></script>

<script>const loadElemsOnUserInteraction=function(){const t=["mouseover","keydown","touchstart","touchmove","wheel"],e=function e(){n(),clearTimeout(o),t.forEach(function(t){window.removeEventListener(t,e,{passive:!0})})};var n=function(){document.querySelectorAll("[data-lazy-method='interaction']").forEach(function(t){t.getAttribute("data-lazy-attributes").split(",").forEach(function(e){const n=t.getAttribute("data-lazy-".concat(e));t.setAttribute(e,n)})})},o=setTimeout(e,10e3);t.forEach(function(t){window.addEventListener(t,e,{passive:!0})})};loadElemsOnUserInteraction();const loadElemsOnViewPort=function(){var t=new IntersectionObserver(function(e){e.forEach(function(e){if(e.isIntersecting){t.unobserve(e.target),e.target.getAttribute("data-lazy-attributes").split(",").forEach(function(t){const n=e.target.getAttribute("data-lazy-".concat(t));e.target.setAttribute(t,n)})}})},{rootMargin:"300px"});document.querySelectorAll("[data-lazy-method='viewport']").forEach(function(e){t.observe(e)})};loadElemsOnViewPort();</script></body>
</html>