﻿<!DOCTYPE html>
<html lang="en-US" prefix="og: https://ogp.me/ns#">
<head>
	<meta charset="UTF-8">
	<link rel="profile" href="https://gmpg.org/xfn/11">
	<title>ESP32/ESP8266: Firebase Authentication (Email and Password) | Random Nerd Tutorials</title><link rel="preload" href="https://i1.wp.com/randomnerdtutorials.com/wp-content/uploads/2021/08/2-Set-Up-Firebase-Project-ESP32-ESP8266.png?resize=750%2C691&amp;quality=100&amp;strip=all&amp;ssl=1" as="image" srcset="https://i1.wp.com/randomnerdtutorials.com/wp-content/uploads/2021/08/2-Set-Up-Firebase-Project-ESP32-ESP8266.png?w=750&amp;quality=100&amp;strip=all&amp;ssl=1 750w, https://i1.wp.com/randomnerdtutorials.com/wp-content/uploads/2021/08/2-Set-Up-Firebase-Project-ESP32-ESP8266.png?resize=300%2C276&amp;quality=100&amp;strip=all&amp;ssl=1 300w" sizes="(max-width: 750px) 100vw, 750px"><link rel="preload" href="https://i0.wp.com/randomnerdtutorials.com/wp-content/uploads/2021/09/Create-firebase-project-1.png?resize=750%2C687&amp;quality=100&amp;strip=all&amp;ssl=1" as="image" srcset="https://i0.wp.com/randomnerdtutorials.com/wp-content/uploads/2021/09/Create-firebase-project-1.png?w=750&amp;quality=100&amp;strip=all&amp;ssl=1 750w, https://i0.wp.com/randomnerdtutorials.com/wp-content/uploads/2021/09/Create-firebase-project-1.png?resize=300%2C275&amp;quality=100&amp;strip=all&amp;ssl=1 300w" sizes="(max-width: 750px) 100vw, 750px"><link rel="preload" href="https://i2.wp.com/randomnerdtutorials.com/wp-content/uploads/2021/08/Firebase-logo.png?resize=375%2C106&amp;quality=100&amp;strip=all&amp;ssl=1" as="image" srcset="https://i2.wp.com/randomnerdtutorials.com/wp-content/uploads/2021/08/Firebase-logo.png?w=750&amp;quality=100&amp;strip=all&amp;ssl=1 750w, https://i2.wp.com/randomnerdtutorials.com/wp-content/uploads/2021/08/Firebase-logo.png?resize=300%2C84&amp;quality=100&amp;strip=all&amp;ssl=1 300w" sizes="(max-width: 375px) 100vw, 375px"><link rel="preload" href="https://i1.wp.com/randomnerdtutorials.com/wp-content/uploads/2021/10/ESP32-ESP8266-Firebase-Authentication-Email-Password.jpg?resize=828%2C466&amp;quality=100&amp;strip=all&amp;ssl=1" as="image" srcset="https://i1.wp.com/randomnerdtutorials.com/wp-content/uploads/2021/10/ESP32-ESP8266-Firebase-Authentication-Email-Password.jpg?w=1280&amp;quality=100&amp;strip=all&amp;ssl=1 1280w, https://i1.wp.com/randomnerdtutorials.com/wp-content/uploads/2021/10/ESP32-ESP8266-Firebase-Authentication-Email-Password.jpg?resize=300%2C169&amp;quality=100&amp;strip=all&amp;ssl=1 300w, https://i1.wp.com/randomnerdtutorials.com/wp-content/uploads/2021/10/ESP32-ESP8266-Firebase-Authentication-Email-Password.jpg?resize=1024%2C576&amp;quality=100&amp;strip=all&amp;ssl=1 1024w, https://i1.wp.com/randomnerdtutorials.com/wp-content/uploads/2021/10/ESP32-ESP8266-Firebase-Authentication-Email-Password.jpg?resize=768%2C432&amp;quality=100&amp;strip=all&amp;ssl=1 768w" sizes="(max-width: 828px) 100vw, 828px"><link rel="preload" href="https://randomnerdtutorials.com/wp-content/uploads/2016/04/logornt.png" as="image" srcset="" sizes=""><style id="flying-press-css">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</style><link rel="stylesheet" media="print" onload="this.media='all'" href="https://randomnerdtutorials.com/wp-content/cache/flying-press/randomnerdtutorials.com/3d1bea95f8f0.post.used.css"><link rel="preload" href="https://randomnerdtutorials.com/wp-content/themes/generatepress/assets/fonts/generatepress.woff2" as="font" type="font/woff2" crossorigin="">

		<!-- All in One SEO 4.1.4.1 -->
		<meta name="description" content="In this guide, you’ll learn how to authenticate to Firebase using your ESP32 or ESP8266 board with an email and password. This is useful for restricting or allowing access to ... CONTINUE READING »">
		<meta name="robots" content="max-image-preview:large">
		<link rel="canonical" href="https://randomnerdtutorials.com/esp32-esp8266-firebase-authentication/">
		<meta property="og:locale" content="en_US">
		<meta property="og:site_name" content="Random Nerd Tutorials">
		<meta property="og:type" content="article">
		<meta property="og:title" content="ESP32/ESP8266: Firebase Authentication (Email and Password) | Random Nerd Tutorials">
		<meta property="og:description" content="In this guide, you’ll learn how to authenticate to Firebase using your ESP32 or ESP8266 board with an email and password. This is useful for restricting or allowing access to ... CONTINUE READING »">
		<meta property="og:url" content="https://randomnerdtutorials.com/esp32-esp8266-firebase-authentication/">
		<meta property="og:image" content="https://randomnerdtutorials.com/wp-content/uploads/2021/10/ESP32-ESP8266-Firebase-Authentication-Email-Password.jpg">
		<meta property="og:image:secure_url" content="https://randomnerdtutorials.com/wp-content/uploads/2021/10/ESP32-ESP8266-Firebase-Authentication-Email-Password.jpg">
		<meta property="og:image:width" content="1280">
		<meta property="og:image:height" content="720">
		<meta property="article:published_time" content="2021-11-01T14:48:32+00:00">
		<meta property="article:modified_time" content="2021-11-01T15:09:28+00:00">
		<meta name="twitter:card" content="summary">
		<meta name="twitter:domain" content="randomnerdtutorials.com">
		<meta name="twitter:title" content="ESP32/ESP8266: Firebase Authentication (Email and Password) | Random Nerd Tutorials">
		<meta name="twitter:description" content="In this guide, you’ll learn how to authenticate to Firebase using your ESP32 or ESP8266 board with an email and password. This is useful for restricting or allowing access to ... CONTINUE READING »">
		<meta name="twitter:image" content="https://randomnerdtutorials.com/wp-content/uploads/2021/10/ESP32-ESP8266-Firebase-Authentication-Email-Password.jpg">
		<meta name="google" content="nositelinkssearchbox">
		<script type="application/ld+json" class="aioseo-schema">
			{"@context":"https:\/\/schema.org","@graph":[{"@type":"WebSite","@id":"https:\/\/randomnerdtutorials.com\/#website","url":"https:\/\/randomnerdtutorials.com\/","name":"Random Nerd Tutorials","description":"Learn ESP8266, ESP32, Arduino, and Raspberry Pi","inLanguage":"en-US","publisher":{"@id":"https:\/\/randomnerdtutorials.com\/#organization"}},{"@type":"Organization","@id":"https:\/\/randomnerdtutorials.com\/#organization","name":"Random Nerd Tutorials","url":"https:\/\/randomnerdtutorials.com\/"},{"@type":"BreadcrumbList","@id":"https:\/\/randomnerdtutorials.com\/esp32-esp8266-firebase-authentication\/#breadcrumblist","itemListElement":[{"@type":"ListItem","@id":"https:\/\/randomnerdtutorials.com\/#listItem","position":1,"item":{"@type":"WebPage","@id":"https:\/\/randomnerdtutorials.com\/","name":"Home","description":"Random Nerd Tutorials helps makers, hobbyists and engineers build electronics projects. We make projects with: ESP32, ESP8266, Arduino, Raspberry Pi, Home Automation and Internet of Things. If you want to learn electronics and programming, you're in the right place.","url":"https:\/\/randomnerdtutorials.com\/"},"nextItem":"https:\/\/randomnerdtutorials.com\/esp32-esp8266-firebase-authentication\/#listItem"},{"@type":"ListItem","@id":"https:\/\/randomnerdtutorials.com\/esp32-esp8266-firebase-authentication\/#listItem","position":2,"item":{"@type":"WebPage","@id":"https:\/\/randomnerdtutorials.com\/esp32-esp8266-firebase-authentication\/","name":"ESP32\/ESP8266: Firebase Authentication (Email and Password)","description":"In this guide, you\u2019ll learn how to authenticate to Firebase using your ESP32 or ESP8266 board with an email and password. This is useful for restricting or allowing access to ... CONTINUE READING \u00bb","url":"https:\/\/randomnerdtutorials.com\/esp32-esp8266-firebase-authentication\/"},"previousItem":"https:\/\/randomnerdtutorials.com\/#listItem"}]},{"@type":"Person","@id":"https:\/\/randomnerdtutorials.com\/author\/sara-santos\/#author","url":"https:\/\/randomnerdtutorials.com\/author\/sara-santos\/","name":"Sara Santos","image":{"@type":"ImageObject","@id":"https:\/\/randomnerdtutorials.com\/esp32-esp8266-firebase-authentication\/#authorImage","url":"https:\/\/secure.gravatar.com\/avatar\/25e3da92f25bc3fde695d9c0d92207b0?s=96&d=mm&r=g","width":96,"height":96,"caption":"Sara Santos"}}]}
		</script>
		<!-- All in One SEO -->

<link rel="dns-prefetch" href="//scripts.mediavine.com">
<link rel="dns-prefetch" href="//s.w.org">
<link rel="dns-prefetch" href="//v0.wordpress.com">
<link rel="dns-prefetch" href="//i0.wp.com">
<link rel="dns-prefetch" href="//i1.wp.com">
<link rel="dns-prefetch" href="//i2.wp.com">
<link rel="alternate" type="application/rss+xml" title="Random Nerd Tutorials » Feed" href="https://randomnerdtutorials.com/feed/">
<link rel="alternate" type="application/rss+xml" title="Random Nerd Tutorials » Comments Feed" href="https://randomnerdtutorials.com/comments/feed/">
<link rel="alternate" type="application/rss+xml" title="Random Nerd Tutorials » ESP32/ESP8266: Firebase Authentication (Email and Password) Comments Feed" href="https://randomnerdtutorials.com/esp32-esp8266-firebase-authentication/feed/">
		<script>
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/randomnerdtutorials.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.8.1"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([10084,65039,8205,55357,56613],[10084,65039,8203,55357,56613])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style>
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel="stylesheet" id="wp-block-library-css" media="all" data-lazy-method="interaction" data-lazy-attributes="href" data-lazy-href="https://randomnerdtutorials.com/wp-content/cache/flying-press/randomnerdtutorials.com/43c4bc05b5e3.style.min.css">
<style id="wp-block-library-inline-css">
.has-text-align-justify{text-align:justify;}
</style>
<link rel="stylesheet" id="mediaelement-css" media="all" data-lazy-method="interaction" data-lazy-attributes="href" data-lazy-href="https://randomnerdtutorials.com/wp-content/cache/flying-press/randomnerdtutorials.com/2b0dd7eecea0.mediaelementplayer-legacy.min.css">
<link rel="stylesheet" id="wp-mediaelement-css" media="all" data-lazy-method="interaction" data-lazy-attributes="href" data-lazy-href="https://randomnerdtutorials.com/wp-content/cache/flying-press/randomnerdtutorials.com/ea958276b7de.wp-mediaelement.min.css">
<link rel="stylesheet" id="generate-style-css" media="all" data-lazy-method="interaction" data-lazy-attributes="href" data-lazy-href="https://randomnerdtutorials.com/wp-content/cache/flying-press/randomnerdtutorials.com/76081276afd9.all.min.css">
<style id="generate-style-inline-css">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</style>
<link rel="stylesheet" id="generate-font-icons-css" media="all" data-lazy-method="interaction" data-lazy-attributes="href" data-lazy-href="https://randomnerdtutorials.com/wp-content/cache/flying-press/randomnerdtutorials.com/78ce964ac72d.font-icons.min.css">
<link rel="stylesheet" id="generate-child-css" media="all" data-lazy-method="interaction" data-lazy-attributes="href" data-lazy-href="https://randomnerdtutorials.com/wp-content/cache/flying-press/randomnerdtutorials.com/273667da91ad.style.css">
<link rel="stylesheet" id="elementor-icons-css" media="all" data-lazy-method="interaction" data-lazy-attributes="href" data-lazy-href="https://randomnerdtutorials.com/wp-content/cache/flying-press/randomnerdtutorials.com/def44311f099.elementor-icons.min.css">
<link rel="stylesheet" id="elementor-frontend-legacy-css" media="all" data-lazy-method="interaction" data-lazy-attributes="href" data-lazy-href="https://randomnerdtutorials.com/wp-content/cache/flying-press/randomnerdtutorials.com/5f521e717558.frontend-legacy.min.css">
<link rel="stylesheet" id="elementor-frontend-css" media="all" data-lazy-method="interaction" data-lazy-attributes="href" data-lazy-href="https://randomnerdtutorials.com/wp-content/cache/flying-press/randomnerdtutorials.com/1698f85b9c63.frontend.min.css">
<style id="elementor-frontend-inline-css">
@font-face{font-family:eicons;src:url(https://randomnerdtutorials.com/wp-content/plugins/elementor/assets/lib/eicons/fonts/eicons.eot?5.10.0);src:url(https://randomnerdtutorials.com/wp-content/plugins/elementor/assets/lib/eicons/fonts/eicons.eot?5.10.0#iefix) format("embedded-opentype"),url(https://randomnerdtutorials.com/wp-content/plugins/elementor/assets/lib/eicons/fonts/eicons.woff2?5.10.0) format("woff2"),url(https://randomnerdtutorials.com/wp-content/plugins/elementor/assets/lib/eicons/fonts/eicons.woff?5.10.0) format("woff"),url(https://randomnerdtutorials.com/wp-content/plugins/elementor/assets/lib/eicons/fonts/eicons.ttf?5.10.0) format("truetype"),url(https://randomnerdtutorials.com/wp-content/plugins/elementor/assets/lib/eicons/fonts/eicons.svg?5.10.0#eicon) format("svg");font-weight:400;font-style:normal}
</style>
<link rel="stylesheet" id="elementor-post-94299-css" media="all" data-lazy-method="interaction" data-lazy-attributes="href" data-lazy-href="https://randomnerdtutorials.com/wp-content/cache/flying-press/randomnerdtutorials.com/281b612b521e.post-94299.css">
<link rel="stylesheet" id="elementor-pro-css" media="all" data-lazy-method="interaction" data-lazy-attributes="href" data-lazy-href="https://randomnerdtutorials.com/wp-content/cache/flying-press/randomnerdtutorials.com/88b33b70281e.frontend.min.css">
<link rel="stylesheet" id="font-awesome-5-all-css" media="all" data-lazy-method="interaction" data-lazy-attributes="href" data-lazy-href="https://randomnerdtutorials.com/wp-content/cache/flying-press/randomnerdtutorials.com/74bab4578692.all.min.css">
<link rel="stylesheet" id="font-awesome-4-shim-css" media="all" data-lazy-method="interaction" data-lazy-attributes="href" data-lazy-href="https://randomnerdtutorials.com/wp-content/cache/flying-press/randomnerdtutorials.com/c55205bce667.v4-shims.min.css">
<link rel="stylesheet" id="elementor-post-83058-css" media="all" data-lazy-method="interaction" data-lazy-attributes="href" data-lazy-href="https://randomnerdtutorials.com/wp-content/cache/flying-press/randomnerdtutorials.com/1796a31f3f3e.post-83058.css">
<link rel="stylesheet" id="generate-sticky-css" media="all" data-lazy-method="interaction" data-lazy-attributes="href" data-lazy-href="https://randomnerdtutorials.com/wp-content/cache/flying-press/randomnerdtutorials.com/858f6e0503fe.sticky.min.css">
<link rel="stylesheet" id="generate-menu-logo-css" media="all" data-lazy-method="interaction" data-lazy-attributes="href" data-lazy-href="https://randomnerdtutorials.com/wp-content/cache/flying-press/randomnerdtutorials.com/c1185c7ce5bc.menu-logo.min.css">
<style id="generate-menu-logo-inline-css">
@media (max-width: 768px){.sticky-menu-logo .navigation-stick:not(.mobile-header-navigation) .menu-toggle,.menu-logo .main-navigation:not(.mobile-header-navigation) .menu-toggle{display:inline-block;clear:none;width:auto;float:right;}.sticky-menu-logo .navigation-stick:not(.mobile-header-navigation) .mobile-bar-items,.menu-logo .main-navigation:not(.mobile-header-navigation) .mobile-bar-items{position:relative;float:right;}.regular-menu-logo .main-navigation:not(.navigation-stick):not(.mobile-header-navigation) .menu-toggle{display:inline-block;clear:none;width:auto;float:right;}.regular-menu-logo .main-navigation:not(.navigation-stick):not(.mobile-header-navigation) .mobile-bar-items{position:relative;float:right;}body[class*="nav-float-"].menu-logo-enabled:not(.sticky-menu-logo) .main-navigation .main-nav{display:block;}.sticky-menu-logo.nav-float-left .navigation-stick:not(.mobile-header-navigation) .menu-toggle,.menu-logo.nav-float-left .main-navigation:not(.mobile-header-navigation) .menu-toggle,.regular-menu-logo.nav-float-left .main-navigation:not(.navigation-stick):not(.mobile-header-navigation) .menu-toggle{float:left;}}
</style>
<link rel="stylesheet" id="google-fonts-1-css" media="all" data-lazy-method="interaction" data-lazy-attributes="href" data-lazy-href="https://randomnerdtutorials.com/wp-content/cache/flying-press/randomnerdtutorials.com/3160f4c8d110.af39441ca0fd.google-font.css">
<link rel="stylesheet" id="jetpack_css-css" media="all" data-lazy-method="interaction" data-lazy-attributes="href" data-lazy-href="https://randomnerdtutorials.com/wp-content/cache/flying-press/randomnerdtutorials.com/e4f0b7415be4.jetpack.css">
<script src="https://randomnerdtutorials.com/wp-includes/js/jquery/jquery.min.js?ver=02dd5d04add4" id="jquery-core-js"></script>
<script src="https://randomnerdtutorials.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=79b4956b7ec4" id="jquery-migrate-js"></script>
<script async="async" data-noptimize="1" data-cfasync="false" src="https://scripts.mediavine.com/tags/random-nerd-tutorials.js?ver=5.8.1" id="mv-script-wrapper-js" defer></script>
<script src="https://randomnerdtutorials.com/wp-content/plugins/elementor/assets/lib/font-awesome/js/v4-shims.min.js?ver=7a5dea0a705c" id="font-awesome-4-shim-js" defer></script>
<link rel="https://api.w.org/" href="https://randomnerdtutorials.com/wp-json/"><link rel="alternate" type="application/json" href="https://randomnerdtutorials.com/wp-json/wp/v2/posts/107356"><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://randomnerdtutorials.com/xmlrpc.php?rsd">
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://randomnerdtutorials.com/wp-includes/wlwmanifest.xml"> 
<meta name="generator" content="WordPress 5.8.1">
<link rel="shortlink" href="https://randomnerdtutorials.com/?p=107356">
<link rel="alternate" type="application/json+oembed" href="https://randomnerdtutorials.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Frandomnerdtutorials.com%2Fesp32-esp8266-firebase-authentication%2F">
<link rel="alternate" type="text/xml+oembed" href="https://randomnerdtutorials.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Frandomnerdtutorials.com%2Fesp32-esp8266-firebase-authentication%2F&amp;format=xml">
<style>img{height:auto}</style><meta name="viewport" content="width=device-width, initial-scale=1"><!-- Global site tag (gtag.js) - Google Analytics -->
<script async data-lazy-src="https://www.googletagmanager.com/gtag/js?id=UA-41273278-2" data-lazy-method="interaction" data-lazy-attributes="src"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-41273278-2');
</script>
<style>
@media ( min-width: 782px ) {
  .skip-link {
    display:none;
  }
}
.is-logo-image {
width: 145px;
height: 60px;
}
.rntn-top-menu {
background: #edeff3;
border-radius: 4px;
padding: 4px 8px;
margin: 4px;
}
.rnt-menu-top-links a {
text-decoration: none;
color: #3a3a3a ;
}
.rnt-menu-top-links a:hover { text-decoration: underline; color: #3a3a3a; }
</style><link rel="icon" href="https://i2.wp.com/randomnerdtutorials.com/wp-content/uploads/2018/03/n-favicon-2018.png?fit=16%2C16&amp;quality=100&amp;strip=all&amp;ssl=1" sizes="32x32">
<link rel="icon" href="https://i2.wp.com/randomnerdtutorials.com/wp-content/uploads/2018/03/n-favicon-2018.png?fit=16%2C16&amp;quality=100&amp;strip=all&amp;ssl=1" sizes="192x192">
<link rel="apple-touch-icon" href="https://i2.wp.com/randomnerdtutorials.com/wp-content/uploads/2018/03/n-favicon-2018.png?fit=16%2C16&amp;quality=100&amp;strip=all&amp;ssl=1">
<meta name="msapplication-TileImage" content="https://i2.wp.com/randomnerdtutorials.com/wp-content/uploads/2018/03/n-favicon-2018.png?fit=16%2C16&amp;quality=100&amp;strip=all&amp;ssl=1">
<meta http-equiv="Content-Type" content="text/html; charset=utf-8"></head>

<body data-rsssl="1" class="post-template-default single single-post postid-107356 single-format-standard wp-embed-responsive post-image-above-header post-image-aligned-center sticky-menu-no-transition sticky-enabled menu-logo menu-logo-enabled both-sticky-menu both-sidebars nav-above-header separate-containers fluid-header active-footer-widgets-0 nav-search-enabled nav-aligned-center header-aligned-center dropdown-hover featured-image-active elementor-default elementor-kit-94299 elementor-page-82536" itemtype="https://schema.org/Blog" itemscope>
	<a class="screen-reader-text skip-link" href="#content" title="Skip to content">Skip to content</a>		<nav id="site-navigation" class="auto-hide-sticky main-navigation sub-menu-right" itemtype="https://schema.org/SiteNavigationElement" itemscope>
			<div class="inside-navigation grid-container grid-parent">
				<div class="site-logo sticky-logo navigation-logo">
					<a href="https://randomnerdtutorials.com/" title="Random Nerd Tutorials" rel="home">
						<img src="https://randomnerdtutorials.com/wp-content/uploads/2016/04/logornt.png" alt="Random Nerd Tutorials" class="is-logo-image" loading="eager" width="250" height="80">
					</a>
				</div><form method="get" class="search-form navigation-search" action="https://randomnerdtutorials.com/">
					<input type="search" class="search-field" value="" name="s" title="Search">
				</form>		<div class="mobile-bar-items">
						<span class="search-item">
				<a aria-label="Open Search Bar" href="#">
									</a>
			</span>
		</div>
						<button class="menu-toggle" aria-controls="primary-menu" aria-expanded="false">
					<span class="mobile-menu">Menu</span>				</button>
				<div id="primary-menu" class="main-nav"><ul id="menu-newtop" class=" menu sf-menu"><li id="menu-item-20487" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-20487"><a href="https://randomnerdtutorials.com/download">Free eBooks</a></li>
<li id="menu-item-20484" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-20484"><a href="https://randomnerdtutorials.com/about">About</a></li>
<li id="menu-item-20485" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-20485"><a href="https://randomnerdtutorials.com/contact">Contact</a></li>
<li id="menu-item-68854" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-68854"><a target="_blank" rel="noopener" href="https://rntlab.com/login">Courses Login</a></li>
<li id="menu-item-20483" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-20483"><a href="https://randomnerdtutorials.com/courses/"><strong>Get Courses</strong><span role="presentation" class="dropdown-menu-toggle"></span></a>
<ul class="sub-menu">
	<li id="menu-item-40154" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-40154"><a href="https://randomnerdtutorials.com/courses/"><strong>All eBooks &amp; Courses</strong></a></li>
	<li id="menu-item-100940" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-100940"><a href="https://randomnerdtutorials.com/build-web-servers-esp32-esp8266-ebook/"><strong>Build Web Servers with ESP32 and ESP8266</strong></a></li>
	<li id="menu-item-69105" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-69105"><a href="https://randomnerdtutorials.com/learn-esp32-with-arduino-ide/">Learn ESP32 with Arduino IDE</a></li>
	<li id="menu-item-96038" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-96038"><a href="https://randomnerdtutorials.com/esp32-cam-projects-ebook/">Build ESP32-CAM Projects</a></li>
	<li id="menu-item-83302" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-83302"><a href="https://randomnerdtutorials.com/micropython-programming-with-esp32-and-esp8266/">MicroPython Programming with ESP32 and ESP8266</a></li>
	<li id="menu-item-40149" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-40149"><a href="https://randomnerdtutorials.com/home-automation-using-esp8266/">Home Automation Using ESP8266</a></li>
	<li id="menu-item-40150" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-40150"><a href="https://randomnerdtutorials.com/build-a-home-automation-system-for-100/">Build a Home Automation System for $100</a></li>
	<li id="menu-item-40151" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-40151"><a href="https://randomnerdtutorials.com/arduino-step-by-step-projects/">Arduino Step-by-step Projects</a></li>
	<li id="menu-item-40153" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-40153"><a href="https://randomnerdtutorials.com/android-apps-for-arduino-with-mit-app-inventor-2/">Android Apps For Arduino</a></li>
	<li id="menu-item-40152" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-40152"><a href="https://randomnerdtutorials.com/electronics-for-beginners/">Electronics For Beginners</a></li>
</ul>
</li>
<li class="search-item menu-item-align-right"><a aria-label="Open Search Bar" href="#"></a></li></ul></div>			</div>
		</nav>
				<header id="masthead" class="site-header" itemtype="https://schema.org/WPHeader" itemscope>
			<div class="inside-header">
							</div>
		</header>
		
	<div id="page" class="site grid-container container hfeed grid-parent">
		<div style="margin-top:10px; padding:10px;" class="rnt-menu-top-links">
	<a class="rntn-top-menu" href="https://randomnerdtutorials.com/">HOME</a>
  <a class="rntn-top-menu" href="https://randomnerdtutorials.com/projects-esp32/">ESP32</a>
  <a class="rntn-top-menu" href="https://randomnerdtutorials.com/projects-esp8266/">ESP8266</a>
  <a class="rntn-top-menu" href="https://randomnerdtutorials.com/projects-esp32-cam/">ESP32-CAM</a>
  <a class="rntn-top-menu" href="https://randomnerdtutorials.com/projects-esp32-esp8266-micropython/">MICROPYTHON</a>
  <a class="rntn-top-menu" href="https://randomnerdtutorials.com/projects-arduino/">ARDUINO</a>
  <a class="rntn-top-menu" href="https://makeradvisor.com/" target="_blank" rel="noopener">REVIEWS</a>
  <a class="rntn-top-menu" href="https://randomnerdtutorials.com/projects/">PROJECTS</a>
</div>		<div id="content" class="site-content">
			
	<div id="primary" class="content-area grid-parent mobile-grid-100 push-15 grid-60 tablet-push-15 tablet-grid-60">
		<main id="main" class="site-main">
			
<article id="post-107356" class="post-107356 post type-post status-publish format-standard has-post-thumbnail hentry category-esp32 category-esp32-project category-esp32-arduino-ide category-0-esp32 category-project mv-content-wrapper" itemtype="https://schema.org/CreativeWork" itemscope>
	<div class="inside-article">
					<header class="entry-header">
				<h1 class="entry-title" itemprop="headline">ESP32/ESP8266: Firebase Authentication (Email and Password)</h1>			</header>
			
		<div class="entry-content" itemprop="text">
			
<p>In this guide, you’ll learn how to authenticate to Firebase using your ESP32 or ESP8266 board with an email and password. This is useful for restricting or allowing access to certain users or creating multiple users that can access the same Firebase project. Additionally, this is helpful to set up database rules to protect your project’s data.</p>



<div class="wp-block-image"><figure class="aligncenter size-full"><img width="828" height="466" src="https://i1.wp.com/randomnerdtutorials.com/wp-content/uploads/2021/10/ESP32-ESP8266-Firebase-Authentication-Email-Password.jpg?resize=828%2C466&amp;quality=100&amp;strip=all&amp;ssl=1" alt="ESP32 ESP8266 Firebase Authentication Email Password" class="wp-image-107388" srcset="https://i1.wp.com/randomnerdtutorials.com/wp-content/uploads/2021/10/ESP32-ESP8266-Firebase-Authentication-Email-Password.jpg?w=1280&amp;quality=100&amp;strip=all&amp;ssl=1 1280w, https://i1.wp.com/randomnerdtutorials.com/wp-content/uploads/2021/10/ESP32-ESP8266-Firebase-Authentication-Email-Password.jpg?resize=300%2C169&amp;quality=100&amp;strip=all&amp;ssl=1 300w, https://i1.wp.com/randomnerdtutorials.com/wp-content/uploads/2021/10/ESP32-ESP8266-Firebase-Authentication-Email-Password.jpg?resize=1024%2C576&amp;quality=100&amp;strip=all&amp;ssl=1 1024w, https://i1.wp.com/randomnerdtutorials.com/wp-content/uploads/2021/10/ESP32-ESP8266-Firebase-Authentication-Email-Password.jpg?resize=768%2C432&amp;quality=100&amp;strip=all&amp;ssl=1 768w" sizes="(max-width: 828px) 100vw, 828px" data-recalc-dims="1" loading="eager"></figure></div>



<p>Other Firebase Tutorials with the ESP32 that you might be interested in:</p>



<ul><li><a href="https://randomnerdtutorials.com/esp32-firebase-realtime-database/">ESP32: Getting Started with Firebase (Realtime Database)</a></li><li><a href="https://randomnerdtutorials.com/esp32-firebase-web-app/">ESP32 with Firebase – Creating a Web App</a></li></ul>



<h2><strong>What is Firebase?</strong></h2>



<div class="wp-block-image"><figure class="aligncenter size-full is-resized"><img src="https://i2.wp.com/randomnerdtutorials.com/wp-content/uploads/2021/08/Firebase-logo.png?resize=375%2C106&amp;quality=100&amp;strip=all&amp;ssl=1" alt="Firebase logo" class="wp-image-105820" width="375" height="106" srcset="https://i2.wp.com/randomnerdtutorials.com/wp-content/uploads/2021/08/Firebase-logo.png?w=750&amp;quality=100&amp;strip=all&amp;ssl=1 750w, https://i2.wp.com/randomnerdtutorials.com/wp-content/uploads/2021/08/Firebase-logo.png?resize=300%2C84&amp;quality=100&amp;strip=all&amp;ssl=1 300w" sizes="(max-width: 375px) 100vw, 375px" data-recalc-dims="1" loading="eager"></figure></div>



<p>Firebase is Google’s mobile application development platform that helps you build, improve, and grow your app. It has many services used to manage data from any android, IOS, or web application like authentication, <a href="https://randomnerdtutorials.com/esp32-firebase-realtime-database/">realtime database</a>, <a href="https://randomnerdtutorials.com/esp32-firebase-web-app/">hosting</a>, etc. In this tutorial, we’ll focus on the authentication part.</p>



<h2>Project Overview</h2>



<ol><li><a href="#create-firebase-project">Create Firebase Project</a></li><li><a href="#Set-Authentication-Methods">Set Authentication Methods</a></li><li><a href="#firebase-project-api-key">Get Project API Key</a></li><li><a href="#Firebase-Authentication-ESP32-ESP8266">Authentication with ESP32/ESP8266</a></li></ol>



<h2 id="create-firebase-project">1) <span style="font-size: inherit;">Create Firebase Project</span></h2>



<p><strong>1)</strong> <span style="font-size: inherit;">Go to </span><a style="font-size: inherit;" href="https://firebase.google.com/" target="_blank" rel="noreferrer noopener">Firebase </a><span style="font-size: inherit;">and sign in using a Google Account.</span></p>



<p><strong>2)</strong> <span style="font-size: inherit;">Click </span><em style="font-size: inherit;">Get Started</em><span style="font-size: inherit;"> and then </span><em style="font-size: inherit;">Add project</em><span style="font-size: inherit;"> to create a new project.</span></p>



<p><strong>3)</strong> <span style="font-size: inherit;">Give a name to your project, for example: </span><em style="font-size: inherit;">ESP Firebase Demo</em><span style="font-size: inherit;">.</span></p>



<div class="wp-block-image"><figure class="aligncenter size-full"><img width="750" height="687" src="https://i0.wp.com/randomnerdtutorials.com/wp-content/uploads/2021/09/Create-firebase-project-1.png?resize=750%2C687&amp;quality=100&amp;strip=all&amp;ssl=1" alt="Set Up Firebase Project for ESP32 and ESP8266 Step 1" class="wp-image-106637" srcset="https://i0.wp.com/randomnerdtutorials.com/wp-content/uploads/2021/09/Create-firebase-project-1.png?w=750&amp;quality=100&amp;strip=all&amp;ssl=1 750w, https://i0.wp.com/randomnerdtutorials.com/wp-content/uploads/2021/09/Create-firebase-project-1.png?resize=300%2C275&amp;quality=100&amp;strip=all&amp;ssl=1 300w" sizes="(max-width: 750px) 100vw, 750px" data-recalc-dims="1" loading="eager"></figure></div>



<p> <strong>4)</strong> <span style="font-size: inherit;">Disable the option </span><em style="font-size: inherit;">Enable Google Analytics</em><span style="font-size: inherit;"> for this project as it is not needed and click </span><em style="font-size: inherit;">Create project</em><span style="font-size: inherit;">.</span> </p>



<div class="wp-block-image"><figure class="aligncenter size-full"><img width="750" height="691" src="https://i1.wp.com/randomnerdtutorials.com/wp-content/uploads/2021/08/2-Set-Up-Firebase-Project-ESP32-ESP8266.png?resize=750%2C691&amp;quality=100&amp;strip=all&amp;ssl=1" alt="Set Up Firebase Project for ESP32 and ESP8266 Step 2" class="wp-image-105730" srcset="https://i1.wp.com/randomnerdtutorials.com/wp-content/uploads/2021/08/2-Set-Up-Firebase-Project-ESP32-ESP8266.png?w=750&amp;quality=100&amp;strip=all&amp;ssl=1 750w, https://i1.wp.com/randomnerdtutorials.com/wp-content/uploads/2021/08/2-Set-Up-Firebase-Project-ESP32-ESP8266.png?resize=300%2C276&amp;quality=100&amp;strip=all&amp;ssl=1 300w" sizes="(max-width: 750px) 100vw, 750px" data-recalc-dims="1" loading="eager"></figure></div>



<p> <strong>5)</strong> <span style="font-size: inherit;">It will take a few seconds to set up your project. Then, click </span><em style="font-size: inherit;">Continue </em><span style="font-size: inherit;">when it’s ready.</span> </p>



<p> <strong>6)</strong> <span style="font-size: inherit;">You’ll be redirected to your Project console page.</span> </p>



<h2 id="Set-Authentication-Methods">2) Set Authentication Methods</h2>



<p>To allow authentication with email and password, first, you need to set authentication methods for your app. </p>



<p>“Most apps need to know the identity of a user. In other words, it takes care of logging in and identifying the users (in this case, the ESP32 or ESP8266). Knowing a user’s identity allows an app to securely save user data in the cloud and provide the same personalized experience across all of the user’s devices.” To learn more about the authentication methods, you can <a href="https://firebase.google.com/docs/auth" target="_blank" rel="noreferrer noopener">read the documentation</a>.</p>



<p><strong>1)</strong> On the left sidebar, click on <em>Authentication </em>and then on <em>Get started</em>. </p>



<div class="wp-block-image"><figure class="aligncenter size-full"><img width="750" height="359" src="https://i1.wp.com/randomnerdtutorials.com/wp-content/uploads/2021/09/Firebase-Project-Authentication.png?resize=750%2C359&amp;quality=100&amp;strip=all&amp;ssl=1" alt="Firebase Project Authentication" class="wp-image-106639" srcset="https://i1.wp.com/randomnerdtutorials.com/wp-content/uploads/2021/09/Firebase-Project-Authentication.png?w=750&amp;quality=100&amp;strip=all&amp;ssl=1 750w, https://i1.wp.com/randomnerdtutorials.com/wp-content/uploads/2021/09/Firebase-Project-Authentication.png?resize=300%2C144&amp;quality=100&amp;strip=all&amp;ssl=1 300w" sizes="(max-width: 750px) 100vw, 750px" data-recalc-dims="1" loading="lazy"></figure></div>



<p><strong>2)</strong> Select the Option <strong>Email/Password</strong>.</p>



<div class="wp-block-image"><figure class="aligncenter size-full"><img width="750" height="394" src="https://i0.wp.com/randomnerdtutorials.com/wp-content/uploads/2021/10/Authentication-methods.png?resize=750%2C394&amp;quality=100&amp;strip=all&amp;ssl=1" alt="Selecting Firebase Authentication with Email/Password" class="wp-image-107373" srcset="https://i0.wp.com/randomnerdtutorials.com/wp-content/uploads/2021/10/Authentication-methods.png?w=750&amp;quality=100&amp;strip=all&amp;ssl=1 750w, https://i0.wp.com/randomnerdtutorials.com/wp-content/uploads/2021/10/Authentication-methods.png?resize=300%2C158&amp;quality=100&amp;strip=all&amp;ssl=1 300w" sizes="(max-width: 750px) 100vw, 750px" data-recalc-dims="1" loading="lazy"></figure></div>



<p><strong>3)</strong> Enable that authentication method and click <strong>Save</strong>.</p>



<div class="wp-block-image"><figure class="aligncenter size-full"><img width="750" height="323" src="https://i2.wp.com/randomnerdtutorials.com/wp-content/uploads/2021/10/Firebase-email-password-sign-in-provider.png?resize=750%2C323&amp;quality=100&amp;strip=all&amp;ssl=1" alt="Enable Email/password authentication Firebase" class="wp-image-107375" srcset="https://i2.wp.com/randomnerdtutorials.com/wp-content/uploads/2021/10/Firebase-email-password-sign-in-provider.png?w=750&amp;quality=100&amp;strip=all&amp;ssl=1 750w, https://i2.wp.com/randomnerdtutorials.com/wp-content/uploads/2021/10/Firebase-email-password-sign-in-provider.png?resize=300%2C129&amp;quality=100&amp;strip=all&amp;ssl=1 300w" sizes="(max-width: 750px) 100vw, 750px" data-recalc-dims="1" loading="lazy"></figure></div>



<p><strong>4)</strong> The authentication with email and password should now be enabled.</p>



<div class="wp-block-image"><figure class="aligncenter size-full"><img width="668" height="208" src="https://i2.wp.com/randomnerdtutorials.com/wp-content/uploads/2021/10/email-password-enabled.png?resize=668%2C208&amp;quality=100&amp;strip=all&amp;ssl=1" alt="Firebase Authentication with Email/Password enabled" class="wp-image-107376" srcset="https://i2.wp.com/randomnerdtutorials.com/wp-content/uploads/2021/10/email-password-enabled.png?w=668&amp;quality=100&amp;strip=all&amp;ssl=1 668w, https://i2.wp.com/randomnerdtutorials.com/wp-content/uploads/2021/10/email-password-enabled.png?resize=300%2C93&amp;quality=100&amp;strip=all&amp;ssl=1 300w" sizes="(max-width: 668px) 100vw, 668px" data-recalc-dims="1" loading="lazy"></figure></div>



<p id="firebase-add-user"><strong>5)</strong> Now, you need to add a user. Still on the <strong>Authentication </strong>tab, select the <strong>Users </strong>tab at the top. Then, click on <strong>Add User</strong>.</p>



<div class="wp-block-image"><figure class="aligncenter size-full"><img width="750" height="335" src="https://i2.wp.com/randomnerdtutorials.com/wp-content/uploads/2021/10/Firebase-Add-New-User.png?resize=750%2C335&amp;quality=100&amp;strip=all&amp;ssl=1" alt="Firebase Authentication Add New User" class="wp-image-107377" srcset="https://i2.wp.com/randomnerdtutorials.com/wp-content/uploads/2021/10/Firebase-Add-New-User.png?w=750&amp;quality=100&amp;strip=all&amp;ssl=1 750w, https://i2.wp.com/randomnerdtutorials.com/wp-content/uploads/2021/10/Firebase-Add-New-User.png?resize=300%2C134&amp;quality=100&amp;strip=all&amp;ssl=1 300w" sizes="(max-width: 750px) 100vw, 750px" data-recalc-dims="1" loading="lazy"></figure></div>



<p><strong>6)</strong> Add an email address for the authorized user. It can be your google account email or any other email. You can also create an email for this specific project. Add a password that will allow you to sign in to your app and access the database. Don’t forget to save the password in a safe place because you’ll need it later. When you’re done, click <strong>Add user</strong>.</p>



<div class="wp-block-image"><figure class="aligncenter size-full"><img width="750" height="494" src="https://i0.wp.com/randomnerdtutorials.com/wp-content/uploads/2021/10/Firebase-Add-User-Email-Password.png?resize=750%2C494&amp;quality=100&amp;strip=all&amp;ssl=1" alt="Firebase Authentication Add User with Email and Password" class="wp-image-107378" srcset="https://i0.wp.com/randomnerdtutorials.com/wp-content/uploads/2021/10/Firebase-Add-User-Email-Password.png?w=750&amp;quality=100&amp;strip=all&amp;ssl=1 750w, https://i0.wp.com/randomnerdtutorials.com/wp-content/uploads/2021/10/Firebase-Add-User-Email-Password.png?resize=300%2C198&amp;quality=100&amp;strip=all&amp;ssl=1 300w" sizes="(max-width: 750px) 100vw, 750px" data-recalc-dims="1" loading="lazy"></figure></div>



<p><strong>7)</strong> A new user was successfully created and added to the <strong>Users</strong> table.</p>



<div class="wp-block-image"><figure class="aligncenter size-full"><img width="750" height="188" src="https://i1.wp.com/randomnerdtutorials.com/wp-content/uploads/2021/10/Users-Table-Firebase.png?resize=750%2C188&amp;quality=100&amp;strip=all&amp;ssl=1" alt="Firebase Users Table" class="wp-image-107379" srcset="https://i1.wp.com/randomnerdtutorials.com/wp-content/uploads/2021/10/Users-Table-Firebase.png?w=750&amp;quality=100&amp;strip=all&amp;ssl=1 750w, https://i1.wp.com/randomnerdtutorials.com/wp-content/uploads/2021/10/Users-Table-Firebase.png?resize=300%2C75&amp;quality=100&amp;strip=all&amp;ssl=1 300w" sizes="(max-width: 750px) 100vw, 750px" data-recalc-dims="1" loading="lazy"></figure></div>



<p>Notice that Firebase creates a unique UID for each registered user. The user UID allows us to identify the user and keep track of the user to provide or deny access to the project or the database. There’s also a column that registers the date of the last sign-in. At the moment, it is empty because we haven’t signed in with that user yet.</p>



<h2 id="firebase-project-api-key">3) Get Project API Key</h2>



<p>To interface with your Firebase project using the ESP32 or ESP8266 boards, you need to get your project API key. Follow the next steps to get your project API key.</p>



<p><strong>1)</strong> On the left sidebar, click on <strong>Project Settings</strong>.</p>



<div class="wp-block-image"><figure class="aligncenter size-full"><img width="750" height="350" src="https://i2.wp.com/randomnerdtutorials.com/wp-content/uploads/2021/09/Firebase-project-settings.png?resize=750%2C350&amp;quality=100&amp;strip=all&amp;ssl=1" alt="Firebase Project Settings" class="wp-image-106642" srcset="https://i2.wp.com/randomnerdtutorials.com/wp-content/uploads/2021/09/Firebase-project-settings.png?w=750&amp;quality=100&amp;strip=all&amp;ssl=1 750w, https://i2.wp.com/randomnerdtutorials.com/wp-content/uploads/2021/09/Firebase-project-settings.png?resize=300%2C140&amp;quality=100&amp;strip=all&amp;ssl=1 300w" sizes="(max-width: 750px) 100vw, 750px" data-recalc-dims="1" loading="lazy"></figure></div>



<p><strong>2)</strong> Copy the Web API Key to a safe place because you’ll need it later.</p>



<div class="wp-block-image"><figure class="aligncenter size-full"><img width="750" height="393" src="https://i2.wp.com/randomnerdtutorials.com/wp-content/uploads/2021/09/Firebase-Project-Settings-Web-API-Key.png?resize=750%2C393&amp;quality=100&amp;strip=all&amp;ssl=1" alt="Firebase Project Settings Web API Key" class="wp-image-106643" srcset="https://i2.wp.com/randomnerdtutorials.com/wp-content/uploads/2021/09/Firebase-Project-Settings-Web-API-Key.png?w=750&amp;quality=100&amp;strip=all&amp;ssl=1 750w, https://i2.wp.com/randomnerdtutorials.com/wp-content/uploads/2021/09/Firebase-Project-Settings-Web-API-Key.png?resize=300%2C157&amp;quality=100&amp;strip=all&amp;ssl=1 300w" sizes="(max-width: 750px) 100vw, 750px" data-recalc-dims="1" loading="lazy"></figure></div>



<h2 id="Firebase-Authentication-ESP32-ESP8266">4) <span style="font-size: inherit;">Authentication with ESP32</span>/ESP8266 </h2>



<p>Now that your Firebase Project is created and you’ve set up the authentication method, you’ll learn to log in with the ESP32 using the authorized user email and password.</p>



<p>To program the ESP32, you can use <a href="https://randomnerdtutorials.com/installing-the-esp32-board-in-arduino-ide-windows-instructions/">Arduino IDE</a>, <a href="https://randomnerdtutorials.com/vs-code-platformio-ide-esp32-esp8266-arduino/">VS Code with the PlatformIO extension</a>, or other suitable software.</p>



<p><strong>Note: </strong> for firebase projects, we recommend using VS Code with the PlatformIO extension because if you want to develop a web application to make the bridge between the ESP32 and Firebase, VS Code provides all the tools to do that. However, we won’t build the web application in this tutorial, so you can use Arduino IDE.</p>



<h3>Install the Firebase-ESP-Client Library</h3>



<p>There is a library with lots of examples to use Firebase with the ESP32: the <a href="https://github.com/mobizt/Firebase-ESP-Client" target="_blank" rel="noreferrer noopener">Firebase-ESP-Client library</a>. This library is compatible with both the ESP32 and ESP8266 boards. </p>



<p>If you like this library and you’ll use it in your projects, consider supporting the developer’s work.</p>



<p>In this tutorial, we’ll look at a simple example to authenticate the ESP32. <a href="https://github.com/mobizt/Firebase-ESP-Client/tree/main/examples" title="https://github.com/mobizt/Firebase-ESP-Client/tree/main/examples" target="_blank" rel="noreferrer noopener">The library provides many other examples that you can check here</a>. It also offers detailed documentation explaining how to use the library.</p>



<h4>Installation – VS Code + PlatformIO</h4>



<p>If you’re using VS Code with the PlatformIO extension, click on the <strong>PIO Home</strong> icon and select the <strong>Libraries tab</strong>. Search for “<strong>Firebase ESP Client</strong>“. Select the <strong>Firebase Arduino Client Library for ESP8266 and ESP32</strong>.</p>



<div class="wp-block-image"><figure class="aligncenter size-full"><img width="828" height="745" src="https://i1.wp.com/randomnerdtutorials.com/wp-content/uploads/2021/09/Install-Firebase-Library-VS-Code-1.png?resize=828%2C745&amp;quality=100&amp;strip=all&amp;ssl=1" alt="Install Firebase ESP Client Library VS Code" class="wp-image-106720" srcset="https://i1.wp.com/randomnerdtutorials.com/wp-content/uploads/2021/09/Install-Firebase-Library-VS-Code-1.png?w=954&amp;quality=100&amp;strip=all&amp;ssl=1 954w, https://i1.wp.com/randomnerdtutorials.com/wp-content/uploads/2021/09/Install-Firebase-Library-VS-Code-1.png?resize=300%2C270&amp;quality=100&amp;strip=all&amp;ssl=1 300w, https://i1.wp.com/randomnerdtutorials.com/wp-content/uploads/2021/09/Install-Firebase-Library-VS-Code-1.png?resize=768%2C691&amp;quality=100&amp;strip=all&amp;ssl=1 768w" sizes="(max-width: 828px) 100vw, 828px" data-recalc-dims="1" loading="lazy"></figure></div>



<p>Then, click <strong>Add to Project</strong> and select the project you’re working on.</p>



<div class="wp-block-image"><figure class="aligncenter size-full"><img width="828" height="411" src="https://i1.wp.com/randomnerdtutorials.com/wp-content/uploads/2021/09/Install-Firebase-Library-VS-Code-2.png?resize=828%2C411&amp;quality=100&amp;strip=all&amp;ssl=1" alt="Add Firebase ESP Client Library to Project VS Code" class="wp-image-106721" srcset="https://i1.wp.com/randomnerdtutorials.com/wp-content/uploads/2021/09/Install-Firebase-Library-VS-Code-2.png?w=954&amp;quality=100&amp;strip=all&amp;ssl=1 954w, https://i1.wp.com/randomnerdtutorials.com/wp-content/uploads/2021/09/Install-Firebase-Library-VS-Code-2.png?resize=300%2C149&amp;quality=100&amp;strip=all&amp;ssl=1 300w, https://i1.wp.com/randomnerdtutorials.com/wp-content/uploads/2021/09/Install-Firebase-Library-VS-Code-2.png?resize=768%2C381&amp;quality=100&amp;strip=all&amp;ssl=1 768w" sizes="(max-width: 828px) 100vw, 828px" data-recalc-dims="1" loading="lazy"></figure></div>



<p>Also, change the monitor speed to 115200 by adding the following line to the <span class="rnthl rntliteral">platformio.ini</span> file of your project:</p>



<pre class="wp-block-code language-c"><code>monitor_speed = 115200</code></pre>



<h4>Installation – Arduino IDE</h4>



<p>If you’re using Arduino IDE, follow the next steps to install the library.</p>



<ol><li>Go to <strong>Sketch </strong>&gt; <strong>Include Library</strong> &gt; <strong>Manage Libraries</strong></li><li>Search for <em>Firebase ESP Client</em> and install the <em>Firebase Arduino Client Library for ESP8266 and ESP32</em> by Mobitz.</li></ol>



<div class="wp-block-image"><figure class="aligncenter size-full"><img width="786" height="443" src="https://i2.wp.com/randomnerdtutorials.com/wp-content/uploads/2021/09/Install-Firebase-ESP-Client-Library-Arduino-IDE-f.png?resize=786%2C443&amp;quality=100&amp;strip=all&amp;ssl=1" alt="Install Firebase Arduino Client Library for ESP8266 and ESP32 by Mobitz" class="wp-image-106596" srcset="https://i2.wp.com/randomnerdtutorials.com/wp-content/uploads/2021/09/Install-Firebase-ESP-Client-Library-Arduino-IDE-f.png?w=786&amp;quality=100&amp;strip=all&amp;ssl=1 786w, https://i2.wp.com/randomnerdtutorials.com/wp-content/uploads/2021/09/Install-Firebase-ESP-Client-Library-Arduino-IDE-f.png?resize=300%2C169&amp;quality=100&amp;strip=all&amp;ssl=1 300w, https://i2.wp.com/randomnerdtutorials.com/wp-content/uploads/2021/09/Install-Firebase-ESP-Client-Library-Arduino-IDE-f.png?resize=768%2C433&amp;quality=100&amp;strip=all&amp;ssl=1 768w" sizes="(max-width: 786px) 100vw, 786px" data-recalc-dims="1" loading="lazy"></figure></div>



<p>Now, you’re all set to start programming the ESP32 or ESP8266 board to interact with the database.</p>



<h3><span style="font-size: inherit;">ESP32</span>/ESP8266 Firebase Authentication Email/Password</h3>



<p>Copy the following code to the Arduino IDE or to the <span class="rnthl rntliteral">main.cpp</span> file if you’re using VS Code.</p>


<pre style="max-height: 40em; margin-bottom: 20px;"><code class="language-c">/*
  Rui Santos
  Complete project details at our blog: https://RandomNerdTutorials.com/esp32-esp8266-firebase-authentication/
  Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated documentation files.
  The above copyright notice and this permission notice shall be included in all copies or substantial portions of the Software.
  Based in the Authenticatiions Examples by Firebase-ESP-Client library by mobizt: https://github.com/mobizt/Firebase-ESP-Client/tree/main/examples/Authentications
*/

#include &lt;Arduino.h&gt;
#if defined(ESP32)
  #include &lt;WiFi.h&gt;
#elif defined(ESP8266)
  #include &lt;ESP8266WiFi.h&gt;
#endif
#include &lt;Firebase_ESP_Client.h&gt;

// Provide the token generation process info.
#include "addons/TokenHelper.h"
// Provide the RTDB payload printing info and other helper functions.
#include "addons/RTDBHelper.h"

// Insert your network credentials
#define WIFI_SSID "REPLACE_WITH_YOUR_SSID"
#define WIFI_PASSWORD "REPLACE_WITH_YOUR_PASSWORD"

// Insert Firebase project API Key
#define API_KEY "REPLACE_WITH_YOUR_FIREBASE_PROJECT_API_KEY"

// Insert Authorized Email and Corresponding Password
#define USER_EMAIL "<a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="abcec6cac2c7ebced3cac6dbc7ce85c8c4c6">[email&#160;protected]</a>"
#define USER_PASSWORD "your_user_password"

// Define Firebase objects
FirebaseData fbdo;
FirebaseAuth auth;
FirebaseConfig config;

// Variable to save USER UID
String uid;

// Initialize WiFi
void initWiFi() {
  WiFi.begin(WIFI_SSID, WIFI_PASSWORD);
  Serial.print("Connecting to WiFi ..");
  while (WiFi.status() != WL_CONNECTED) {
    Serial.print('.');
    delay(1000);
  }
  Serial.println(WiFi.localIP());
  Serial.println();
}

void setup(){
  Serial.begin(115200);
  
  // Initialize WiFi
  initWiFi();

  // Assign the api key (required)
  config.api_key = API_KEY;

  // Assign the user sign in credentials
  auth.user.email = USER_EMAIL;
  auth.user.password = USER_PASSWORD;

  Firebase.reconnectWiFi(true);
  fbdo.setResponseSize(4096);

  // Assign the callback function for the long running token generation task
  config.token_status_callback = tokenStatusCallback; //see addons/TokenHelper.h

  // Assign the maximum retry of token generation
  config.max_token_generation_retry = 5;

  // Initialize the library with the Firebase authen and config
  Firebase.begin(&amp;config, &amp;auth);

  // Getting the user UID might take a few seconds
  Serial.println("Getting User UID");
  while ((auth.token.uid) == "") {
    Serial.print('.');
    delay(1000);
  }
  // Print user UID
  uid = auth.token.uid.c_str();
  Serial.print("User UID: ");
  Serial.print(uid);
}

void loop(){

}
</code></pre>
	<p style="text-align:center"><a class="rntwhite" href="https://github.com/RuiSantosdotme/Firebase-ESP/raw/main/ESP-Firebase-Authentication/ESP-Firebase-Authentication.ino" target="_blank">View raw code</a></p>



<p>You need to insert your network credentials, URL database, and project API key for the project to work.</p>



<p>This sketch was based on the <a href="https://github.com/mobizt/Firebase-ESP-Client/blob/main/examples/Authentications/SignInAsUser/EmailPassword/EmailPassword.ino" target="_blank" rel="noreferrer noopener">authentication basic example provided by the library</a>. You can find more examples <a href="https://github.com/mobizt/Firebase-ESP-Client/tree/main/examples" target="_blank" rel="noreferrer noopener">here</a>.</p>



<h3>How the Code Works</h3>



<p>Continue reading to learn how the code works, or skip to the <a href="#demonstration">demonstration section</a>.</p>



<h4>Include Libraries</h4>



<p>First, include the required libraries. The <span class="rnthl rntliteral">WiFi.h</span> library to connect the ESP32 to the internet (or the <span class="rnthl rntliteral">ESP8266WiFi.h</span> library for the ESP8266 board) and the <span class="rnthl rntliteral">Firebase_ESP_Client.h</span> library to interface the boards with Firebase.</p>



<pre class="wp-block-code language-c"><code>#include &lt;Arduino.h&gt;
#if defined(ESP32)
  #include &lt;WiFi.h&gt;
#elif defined(ESP8266)
  #include &lt;ESP8266WiFi.h&gt;
#endif
#include &lt;Firebase_ESP_Client.h&gt;</code></pre>



<p>You also need to include the following for the Firebase library to work.</p>



<pre class="wp-block-code language-c"><code>// Provide the token generation process info.
#include "addons/TokenHelper.h"
// Provide the RTDB payload printing info and other helper functions.
#include "addons/RTDBHelper.h"</code></pre>



<h4>Network Credentials</h4>



<p>Include your network credentials in the following lines so that your boards can connect to the internet using your local network.</p>



<pre class="wp-block-code language-c"><code>// Insert your network credentials
#define WIFI_SSID "REPLACE_WITH_YOUR_SSID"
#define WIFI_PASSWORD "REPLACE_WITH_YOUR_PASSWORD"</code></pre>



<h4>Firebase Project API Key and Firebase User</h4>



<p>Insert your <a href="#firebase-project-api-key">Firebase project API key</a>—the one you’ve gotten<a href="#firebase-project-api-key"> in this section</a>.</p>



<pre class="wp-block-code language-c"><code>#define API_KEY "REPLACE_WITH_YOUR_PROJECT_API_KEY"</code></pre>



<p>Insert the <a href="#firebase-add-user">authorized email and the corresponding password</a>—these are the details of the user you’ve added <a href="#firebase-add-user">in this section</a>.</p>



<pre class="wp-block-code language-c"><code>// Insert Authorized Email and Corresponding Password
#define USER_EMAIL "REPLACE_WITH_THE_USER_EMAIL"
#define USER_PASSWORD "REPLACE_WITH_THE_USER_PASSWORD"</code></pre>



<h4>Firebase Objects and Other Variables</h4>



<p>The following line defines a <span class="rnthl rntliteral">FirebaseData</span> object.</p>



<pre class="wp-block-code language-c"><code>FirebaseData fbdo;</code></pre>



<p>The next line defines a <span class="rnthl rntliteral">FirebaseAuth</span> object needed for authentication.</p>



<pre class="wp-block-code language-c"><code>FirebaseAuth auth;</code></pre>



<p>Finally, the following line defines <span class="rnthl rntliteral">FirebaseConfig</span> object needed for configuration data.</p>



<pre class="wp-block-code language-c"><code>FirebaseConfig config;</code></pre>



<p>The <span class="rnthl rntliteral">uid</span> variable will be used to save the user’s UID. We can get the user’s UID after the authentication.</p>



<pre class="wp-block-code language-c"><code>String uid;</code></pre>



<h4>initWiFi()</h4>



<p>The <span class="rnthl rntliteral">initWiFi()</span> function connects your ESP to the internet using the network credentials provided. You must call this function later in the <span class="rnthl rntliteral">setup()</span> to initialize WiFi.</p>



<pre class="wp-block-code language-c"><code>// Initialize WiFi
void initWiFi() {
  WiFi.begin(WIFI_SSID, WIFI_PASSWORD);
  Serial.print("Connecting to WiFi ..");
  while (WiFi.status() != WL_CONNECTED) {
    Serial.print('.');
    delay(1000);
  }
  Serial.println(WiFi.localIP());
  Serial.println();
}</code></pre>



<h4>setup()</h4>



<p>In <span class="rnthl rntliteral">setup()</span>, initialize the Serial Monitor for debugging purposes at a baud rate of 115200.</p>



<pre class="wp-block-code language-c"><code>Serial.begin(115200);</code></pre>



<p>Call the <span class="rnthl rntliteral">initWiFi()</span> function to initialize WiFi.</p>



<h4>initWiFi();</h4>



<p>Assign the API key to the Firebase configuration.</p>



<pre class="wp-block-code language-c"><code>config.api_key = API_KEY;</code></pre>



<p>The following lines assign the email and password to the Firebase authentication object.</p>



<pre class="wp-block-code language-c"><code>auth.user.email = USER_EMAIL;
auth.user.password = USER_PASSWORD;</code></pre>



<p>Add the following to the configuration object.</p>



<pre class="wp-block-code language-c"><code>// Assign the callback function for the long running token generation task
config.token_status_callback = tokenStatusCallback; //see addons/TokenHelper.h

// Assign the maximum retry of token generation
config.max_token_generation_retry = 5;</code></pre>



<p>Finally, initialize the Firebase library (authenticate) with the configuration and authentication settings we defined earlier.</p>



<pre class="wp-block-code language-c"><code>// Initialize the library with the Firebase authen and config
Firebase.begin(&amp;config, &amp;auth);</code></pre>



<p>After initializing the library, we can get the user UID by calling <span class="rnthl rntliteral">auth.token.uid</span>. Getting the user’s UID might take some time, so we add a while loop that waits until we get it.</p>



<pre class="wp-block-code language-c"><code>// Getting the user UID might take a few seconds
Serial.println("Getting User UID");
while ((auth.token.uid) == "") {
  Serial.print('.');
  delay(1000);
}</code></pre>



<p>Finally, we save the user’s UID in the <span class="rnthl rntliteral">uid</span> variable and print it in the Serial Monitor.</p>



<pre class="wp-block-code language-c"><code>uid = auth.token.uid.c_str();
Serial.print("User UID: ");
Serial.print(uid);</code></pre>



<h1 id="demonstration">Demonstration</h1>



<p>After uploading the code, open the Serial Monitor at a baud rate of 115200.</p>



<p><strong>Note</strong>: if you’re using VS Code, you need to add the following line to your <span class="rnthl rntliteral">platformio.ini</span> file to change the baud rate. Then, save your file.</p>



<pre class="wp-block-code language-c"><code>monitor_speed = 115200</code></pre>



<p>Reset your board by pressing the on-board EN/RST button.</p>



<p>The ESP32/ESP8266 authenticates the user successfully and gets its UID.</p>



<div class="wp-block-image"><figure class="aligncenter size-full"><img width="601" height="445" src="https://i1.wp.com/randomnerdtutorials.com/wp-content/uploads/2021/10/ESP32-ESP8266-Firebase-Successful-Arduino-IDE-Serial-Monitor.png?resize=601%2C445&amp;quality=100&amp;strip=all&amp;ssl=1" alt="ESP32 ESP8266 Firebase Successful Arduino IDE Serial Monitor" class="wp-image-107384" srcset="https://i1.wp.com/randomnerdtutorials.com/wp-content/uploads/2021/10/ESP32-ESP8266-Firebase-Successful-Arduino-IDE-Serial-Monitor.png?w=601&amp;quality=100&amp;strip=all&amp;ssl=1 601w, https://i1.wp.com/randomnerdtutorials.com/wp-content/uploads/2021/10/ESP32-ESP8266-Firebase-Successful-Arduino-IDE-Serial-Monitor.png?resize=300%2C222&amp;quality=100&amp;strip=all&amp;ssl=1 300w" sizes="(max-width: 601px) 100vw, 601px" data-recalc-dims="1" loading="lazy"></figure></div>



<p>Then, go to your Firebase project console to check if it signed in as a user. Go to <strong>Authentication</strong> &gt; <strong>Users</strong>. Now you should have the current date in the <strong>Signed</strong> <strong>In</strong> field. Additionally, you’ll see that the User UID matches the UID printed by your ESP board in the Serial Monitor.</p>



<div class="wp-block-image"><figure class="aligncenter size-full"><img width="750" height="166" src="https://i1.wp.com/randomnerdtutorials.com/wp-content/uploads/2021/10/Firebase-Users-Last-Sign-in.png?resize=750%2C166&amp;quality=100&amp;strip=all&amp;ssl=1" alt="Firebase Users Last Sign-in" class="wp-image-107385" srcset="https://i1.wp.com/randomnerdtutorials.com/wp-content/uploads/2021/10/Firebase-Users-Last-Sign-in.png?w=750&amp;quality=100&amp;strip=all&amp;ssl=1 750w, https://i1.wp.com/randomnerdtutorials.com/wp-content/uploads/2021/10/Firebase-Users-Last-Sign-in.png?resize=300%2C66&amp;quality=100&amp;strip=all&amp;ssl=1 300w" sizes="(max-width: 750px) 100vw, 750px" data-recalc-dims="1" loading="lazy"></figure></div>



<p>Congratulations! You successfully signed in your ESP32/ESP8266 board as a user. You can combine this example with one of our previous tutorials to send sensor readings to the database as an authorized user: <a href="https://randomnerdtutorials.com/esp32-firebase-realtime-database/">ESP32: Getting Started with Firebase (Realtime Database)</a></p>



<h2>Wrapping Up</h2>



<p>In this tutorial, you learned how to set up the ESP32/ESP8266 board as a user that can access your Firebase project with email and password. This was just a simple example that you can apply to more advanced projects. </p>



<p>Setting up the ESP as a user allows you to identify the user to enable or restrict access to the Firebase Project or to the database or to specific database nodes—allows you to set up database rules.</p>



<p>In a future tutorial, we’ll show you how to use this feature to apply database rules and create a web app with login/logout features to authorize and restrict access to the data. Stay tuned.</p>



<p>If you want to learn more about building a fully-featured Firebase Web App to control and monitor your ESP32 and ESP8266 boards from anywhere, take a look at our newest eBook (registrations only available during the next few days):</p>



<ul><li><a href="https://randomnerdtutorials.com/firebase-esp32-esp8266-ebook/"><strong>Firebase Web App with ESP32 and ESP8266</strong></a></li></ul>



<p>Other resources that you might find helpful:</p>



<ul><li><a href="https://randomnerdtutorials.com/build-web-servers-esp32-esp8266-ebook/">Build Web Servers with the ESP32/ESP8266</a></li><li><a href="https://randomnerdtutorials.com/learn-esp32-with-arduino-ide/">Learn ESP32 with Arduino IDE</a></li><li><a href="https://randomnerdtutorials.com/home-automation-using-esp8266/">Home Automation using ESP8266</a></li></ul>
		</div>

		<br>
<center><a href="https://randomnerdtutorials.com/pcbway" target="_blank"><img src="https://randomnerdtutorials.com/wp-content/uploads/2020/10/750x170-updated-f.png" loading="lazy" width="750" height="148"></a></center>
<br>
		<div data-elementor-type="section" data-elementor-id="83032" class="elementor elementor-83032" data-elementor-settings="[]">
		<div class="elementor-section-wrap">
					<section class="elementor-section elementor-top-section elementor-element elementor-element-2d8a9105 elementor-section-boxed elementor-section-height-default elementor-section-height-default" data-id="2d8a9105" data-element_type="section">
						<div class="elementor-container elementor-column-gap-default">
							<div class="elementor-row">
					<div class="elementor-column elementor-col-100 elementor-top-column elementor-element elementor-element-2280806f" data-id="2280806f" data-element_type="column">
			<div class="elementor-column-wrap elementor-element-populated">
							<div class="elementor-widget-wrap">
						<section class="elementor-section elementor-inner-section elementor-element elementor-element-4a840dd4 elementor-section-boxed elementor-section-height-default elementor-section-height-default" data-id="4a840dd4" data-element_type="section">
						<div class="elementor-container elementor-column-gap-default">
							<div class="elementor-row">
					<div class="elementor-column elementor-col-50 elementor-inner-column elementor-element elementor-element-3497580" data-id="3497580" data-element_type="column">
			<div class="elementor-column-wrap elementor-element-populated">
							<div class="elementor-widget-wrap">
						<div class="elementor-element elementor-element-7b0162e9 elementor-widget elementor-widget-image" data-id="7b0162e9" data-element_type="widget" data-widget_type="image.default">
				<div class="elementor-widget-container">
								<div class="elementor-image">
													<a href="https://randomnerdtutorials.com/build-web-servers-esp32-esp8266-ebook/">
							<img src="https://randomnerdtutorials.com/wp-content/uploads/elementor/thumbs/Build-Web-Servers-with-ESP32-and-ESP8266-eBook-2nd-Edition-500px-h-p2lw6wwnkk9ystvwe9iof8zx6yt4x7uma3cqfup534.jpg" title="Build-Web-Servers-with-ESP32-and-ESP8266-eBook-2nd-Edition-500px-h" alt="Build-Web-Servers-with-ESP32-and-ESP8266-eBook-2nd-Edition-500px-h" loading="lazy" width="129" height="180">								</a>
														</div>
						</div>
				</div>
						</div>
					</div>
		</div>
				<div class="elementor-column elementor-col-50 elementor-inner-column elementor-element elementor-element-45a69540" data-id="45a69540" data-element_type="column">
			<div class="elementor-column-wrap elementor-element-populated">
							<div class="elementor-widget-wrap">
						<div class="elementor-element elementor-element-d7f411a elementor-widget elementor-widget-heading" data-id="d7f411a" data-element_type="widget" data-widget_type="heading.default">
				<div class="elementor-widget-container">
			<h4 class="elementor-heading-title elementor-size-default"><a href="https://randomnerdtutorials.com/build-web-servers-esp32-esp8266-ebook/">[eBook] Build Web Servers with ESP32 and ESP8266 (2nd Edition)</a></h4>		</div>
				</div>
				<div class="elementor-element elementor-element-5dc4402f elementor-hidden-phone elementor-widget elementor-widget-text-editor" data-id="5dc4402f" data-element_type="widget" data-widget_type="text-editor.default">
				<div class="elementor-widget-container">
								<div class="elementor-text-editor elementor-clearfix">
				Build Web Server projects with the ESP32 and ESP8266 boards to control outputs and monitor sensors remotely. Learn HTML, CSS, JavaScript and client-server communication protocols <strong><a href="https://randomnerdtutorials.com/build-web-servers-esp32-esp8266-ebook/" rel="noopener">DOWNLOAD »</a></strong>					</div>
						</div>
				</div>
						</div>
					</div>
		</div>
								</div>
					</div>
		</section>
				<div class="elementor-element elementor-element-4de314b8 elementor-hidden-desktop elementor-hidden-tablet elementor-widget elementor-widget-text-editor" data-id="4de314b8" data-element_type="widget" data-widget_type="text-editor.default">
				<div class="elementor-widget-container">
								<div class="elementor-text-editor elementor-clearfix">
				<p>Build Web Server projects with the ESP32 and ESP8266 boards to control outputs and monitor sensors remotely. Learn HTML, CSS, JavaScript and client-server communication protocols <strong><a href="https://randomnerdtutorials.com/build-web-servers-esp32-esp8266-ebook/" rel="noopener">DOWNLOAD »</a></strong></p>					</div>
						</div>
				</div>
						</div>
					</div>
		</div>
								</div>
					</div>
		</section>
				</div>
		</div>
		
		<div data-elementor-type="section" data-elementor-id="82533" class="elementor elementor-82533" data-elementor-settings="[]">
		<div class="elementor-section-wrap">
					<section class="elementor-section elementor-top-section elementor-element elementor-element-31c9920 elementor-section-boxed elementor-section-height-default elementor-section-height-default" data-id="31c9920" data-element_type="section">
						<div class="elementor-container elementor-column-gap-default">
							<div class="elementor-row">
					<div class="elementor-column elementor-col-100 elementor-top-column elementor-element elementor-element-e6bec81" data-id="e6bec81" data-element_type="column">
			<div class="elementor-column-wrap elementor-element-populated">
							<div class="elementor-widget-wrap">
						<div class="elementor-element elementor-element-ae5f36f elementor-widget elementor-widget-text-editor" data-id="ae5f36f" data-element_type="widget" data-widget_type="text-editor.default">
				<div class="elementor-widget-container">
								<div class="elementor-text-editor elementor-clearfix">
				<h3>Recommended Resources</h3>					</div>
						</div>
				</div>
						</div>
					</div>
		</div>
								</div>
					</div>
		</section>
				<section class="elementor-section elementor-top-section elementor-element elementor-element-df31b19 elementor-section-boxed elementor-section-height-default elementor-section-height-default" data-id="df31b19" data-element_type="section">
						<div class="elementor-container elementor-column-gap-default">
							<div class="elementor-row">
					<div class="elementor-column elementor-col-33 elementor-top-column elementor-element elementor-element-f988f78" data-id="f988f78" data-element_type="column">
			<div class="elementor-column-wrap elementor-element-populated">
							<div class="elementor-widget-wrap">
						<div class="elementor-element elementor-element-ea4ffd5 elementor-widget elementor-widget-image" data-id="ea4ffd5" data-element_type="widget" data-widget_type="image.default">
				<div class="elementor-widget-container">
								<div class="elementor-image">
													<a href="https://randomnerdtutorials.com/build-a-home-automation-system-for-100/">
							<img width="400" height="225" src="https://i1.wp.com/randomnerdtutorials.com/wp-content/uploads/2017/10/home-automation-sb-img.jpg?fit=400%2C225&amp;quality=100&amp;strip=all&amp;ssl=1" class="attachment-full size-full" alt="" srcset="https://i1.wp.com/randomnerdtutorials.com/wp-content/uploads/2017/10/home-automation-sb-img.jpg?w=400&amp;quality=100&amp;strip=all&amp;ssl=1 400w, https://i1.wp.com/randomnerdtutorials.com/wp-content/uploads/2017/10/home-automation-sb-img.jpg?resize=300%2C169&amp;quality=100&amp;strip=all&amp;ssl=1 300w" sizes="(max-width: 400px) 100vw, 400px" loading="lazy">								</a>
														</div>
						</div>
				</div>
				<div class="elementor-element elementor-element-1d03956 elementor-widget elementor-widget-text-editor" data-id="1d03956" data-element_type="widget" data-widget_type="text-editor.default">
				<div class="elementor-widget-container">
								<div class="elementor-text-editor elementor-clearfix">
				<p><strong><a href="https://randomnerdtutorials.com/build-a-home-automation-system-for-100/">Build a Home Automation System from Scratch »</a> </strong>With Raspberry Pi, ESP8266, Arduino, and Node-RED.</p>					</div>
						</div>
				</div>
						</div>
					</div>
		</div>
				<div class="elementor-column elementor-col-33 elementor-top-column elementor-element elementor-element-c804b9b" data-id="c804b9b" data-element_type="column">
			<div class="elementor-column-wrap elementor-element-populated">
							<div class="elementor-widget-wrap">
						<div class="elementor-element elementor-element-caff517 elementor-widget elementor-widget-image" data-id="caff517" data-element_type="widget" data-widget_type="image.default">
				<div class="elementor-widget-container">
								<div class="elementor-image">
													<a href="https://randomnerdtutorials.com/home-automation-using-esp8266/">
							<img width="400" height="225" src="https://i1.wp.com/randomnerdtutorials.com/wp-content/uploads/2017/10/esp8266-sb-img.jpg?fit=400%2C225&amp;quality=100&amp;strip=all&amp;ssl=1" class="attachment-full size-full" alt="" srcset="https://i1.wp.com/randomnerdtutorials.com/wp-content/uploads/2017/10/esp8266-sb-img.jpg?w=400&amp;quality=100&amp;strip=all&amp;ssl=1 400w, https://i1.wp.com/randomnerdtutorials.com/wp-content/uploads/2017/10/esp8266-sb-img.jpg?resize=300%2C169&amp;quality=100&amp;strip=all&amp;ssl=1 300w" sizes="(max-width: 400px) 100vw, 400px" loading="lazy">								</a>
														</div>
						</div>
				</div>
				<div class="elementor-element elementor-element-7bc712f elementor-widget elementor-widget-text-editor" data-id="7bc712f" data-element_type="widget" data-widget_type="text-editor.default">
				<div class="elementor-widget-container">
								<div class="elementor-text-editor elementor-clearfix">
				<p><strong><a href="https://randomnerdtutorials.com/home-automation-using-esp8266/">Home Automation using ESP8266 eBook and video course »</a> </strong>Build IoT and home automation projects.</p>					</div>
						</div>
				</div>
						</div>
					</div>
		</div>
				<div class="elementor-column elementor-col-33 elementor-top-column elementor-element elementor-element-9487535" data-id="9487535" data-element_type="column">
			<div class="elementor-column-wrap elementor-element-populated">
							<div class="elementor-widget-wrap">
						<div class="elementor-element elementor-element-330785f elementor-widget elementor-widget-image" data-id="330785f" data-element_type="widget" data-widget_type="image.default">
				<div class="elementor-widget-container">
								<div class="elementor-image">
													<a href="https://randomnerdtutorials.com/arduino-step-by-step-projects/">
							<img width="400" height="225" src="https://i1.wp.com/randomnerdtutorials.com/wp-content/uploads/2017/10/arduino-sb-img.jpg?fit=400%2C225&amp;quality=100&amp;strip=all&amp;ssl=1" class="attachment-full size-full" alt="" srcset="https://i1.wp.com/randomnerdtutorials.com/wp-content/uploads/2017/10/arduino-sb-img.jpg?w=400&amp;quality=100&amp;strip=all&amp;ssl=1 400w, https://i1.wp.com/randomnerdtutorials.com/wp-content/uploads/2017/10/arduino-sb-img.jpg?resize=300%2C169&amp;quality=100&amp;strip=all&amp;ssl=1 300w" sizes="(max-width: 400px) 100vw, 400px" loading="lazy">								</a>
														</div>
						</div>
				</div>
				<div class="elementor-element elementor-element-e9540a9 elementor-widget elementor-widget-text-editor" data-id="e9540a9" data-element_type="widget" data-widget_type="text-editor.default">
				<div class="elementor-widget-container">
								<div class="elementor-text-editor elementor-clearfix">
				<p><strong><a href="https://randomnerdtutorials.com/arduino-step-by-step-projects/">Arduino Step-by-Step Projects »</a> </strong>Build 25 Arduino projects with our course, even with no prior experience!</p>					</div>
						</div>
				</div>
						</div>
					</div>
		</div>
								</div>
					</div>
		</section>
				<section class="elementor-section elementor-top-section elementor-element elementor-element-a9e9c13 elementor-section-boxed elementor-section-height-default elementor-section-height-default" data-id="a9e9c13" data-element_type="section">
						<div class="elementor-container elementor-column-gap-default">
							<div class="elementor-row">
					<div class="elementor-column elementor-col-100 elementor-top-column elementor-element elementor-element-25cf7ca" data-id="25cf7ca" data-element_type="column">
			<div class="elementor-column-wrap elementor-element-populated">
							<div class="elementor-widget-wrap">
						<div class="elementor-element elementor-element-88fc6c0 elementor-widget elementor-widget-text-editor" data-id="88fc6c0" data-element_type="widget" data-widget_type="text-editor.default">
				<div class="elementor-widget-container">
								<div class="elementor-text-editor elementor-clearfix">
				<h3>What to Read Next…</h3>					</div>
						</div>
				</div>
						</div>
					</div>
		</div>
								</div>
					</div>
		</section>
				<section class="elementor-section elementor-top-section elementor-element elementor-element-d68ef93 elementor-section-height-min-height elementor-section-boxed elementor-section-height-default elementor-section-items-middle" data-id="d68ef93" data-element_type="section">
						<div class="elementor-container elementor-column-gap-no">
							<div class="elementor-row">
					<div class="elementor-column elementor-col-100 elementor-top-column elementor-element elementor-element-4ab337a" data-id="4ab337a" data-element_type="column">
			<div class="elementor-column-wrap elementor-element-populated">
							<div class="elementor-widget-wrap">
						<div class="elementor-element elementor-element-efac60e elementor-grid-3 elementor-grid-tablet-2 elementor-grid-mobile-1 elementor-posts--thumbnail-top elementor-card-shadow-yes elementor-posts__hover-gradient elementor-widget elementor-widget-posts" data-id="efac60e" data-element_type="widget" data-settings='{"cards_row_gap":{"unit":"px","size":16,"sizes":[]},"cards_columns":"3","cards_columns_tablet":"2","cards_columns_mobile":"1"}' data-widget_type="posts.cards">
				<div class="elementor-widget-container">
					<div class="elementor-posts-container elementor-posts elementor-posts--skin-cards elementor-grid">
				<article class="elementor-post elementor-grid-item post-106878 post type-post status-publish format-standard has-post-thumbnail hentry category-esp8266 category-esp8266-project category-esp8266-arduino-ide category-esp8266-projects category-0-esp8266 category-project mv-content-wrapper">
			<div class="elementor-post__card">
				<a class="elementor-post__thumbnail__link" href="https://randomnerdtutorials.com/esp8266-nodemcu-firebase-web-app/">
			<div class="elementor-post__thumbnail"><img width="1280" height="720" src="https://i2.wp.com/randomnerdtutorials.com/wp-content/uploads/2021/09/ESP8266-Firebase-web-app-tutorial.jpg?fit=1280%2C720&amp;quality=100&amp;strip=all&amp;ssl=1" class="attachment-full size-full" alt="ESP8266 NodeMCU with Firebase Creating a Web App Arduino IDE" srcset="https://i2.wp.com/randomnerdtutorials.com/wp-content/uploads/2021/09/ESP8266-Firebase-web-app-tutorial.jpg?w=1280&amp;quality=100&amp;strip=all&amp;ssl=1 1280w, https://i2.wp.com/randomnerdtutorials.com/wp-content/uploads/2021/09/ESP8266-Firebase-web-app-tutorial.jpg?resize=300%2C169&amp;quality=100&amp;strip=all&amp;ssl=1 300w, https://i2.wp.com/randomnerdtutorials.com/wp-content/uploads/2021/09/ESP8266-Firebase-web-app-tutorial.jpg?resize=1024%2C576&amp;quality=100&amp;strip=all&amp;ssl=1 1024w, https://i2.wp.com/randomnerdtutorials.com/wp-content/uploads/2021/09/ESP8266-Firebase-web-app-tutorial.jpg?resize=768%2C432&amp;quality=100&amp;strip=all&amp;ssl=1 768w" sizes="(max-width: 1280px) 100vw, 1280px" loading="lazy"></div>
		</a>
				<div class="elementor-post__text">
				<h3 class="elementor-post__title">
			<a href="https://randomnerdtutorials.com/esp8266-nodemcu-firebase-web-app/">
				ESP8266 NodeMCU with Firebase – Creating a Web App			</a>
		</h3>
				</div>
					</div>
		</article>
				<article class="elementor-post elementor-grid-item post-99497 post type-post status-publish format-standard has-post-thumbnail hentry category-esp8266-project category-esp8266-arduino-ide category-0-esp8266 category-project mv-content-wrapper">
			<div class="elementor-post__card">
				<a class="elementor-post__thumbnail__link" href="https://randomnerdtutorials.com/esp8266-nodemcu-mqtt-publish-bme680-arduino/">
			<div class="elementor-post__thumbnail"><img width="1280" height="720" src="https://i2.wp.com/randomnerdtutorials.com/wp-content/uploads/2020/10/ESP8266-NodeMCU-MQTT-Publish-BME680-Temperature-Humidity-Pressure-Gas-Readings-Arduino-IDE.jpg?fit=1280%2C720&amp;quality=100&amp;strip=all&amp;ssl=1" class="attachment-full size-full" alt="ESP8266 NodeMCU MQTT Publish BME680 Temperature Humidity Pressure and Gas Readings Arduino IDE" srcset="https://i2.wp.com/randomnerdtutorials.com/wp-content/uploads/2020/10/ESP8266-NodeMCU-MQTT-Publish-BME680-Temperature-Humidity-Pressure-Gas-Readings-Arduino-IDE.jpg?w=1280&amp;quality=100&amp;strip=all&amp;ssl=1 1280w, https://i2.wp.com/randomnerdtutorials.com/wp-content/uploads/2020/10/ESP8266-NodeMCU-MQTT-Publish-BME680-Temperature-Humidity-Pressure-Gas-Readings-Arduino-IDE.jpg?resize=300%2C169&amp;quality=100&amp;strip=all&amp;ssl=1 300w, https://i2.wp.com/randomnerdtutorials.com/wp-content/uploads/2020/10/ESP8266-NodeMCU-MQTT-Publish-BME680-Temperature-Humidity-Pressure-Gas-Readings-Arduino-IDE.jpg?resize=1024%2C576&amp;quality=100&amp;strip=all&amp;ssl=1 1024w, https://i2.wp.com/randomnerdtutorials.com/wp-content/uploads/2020/10/ESP8266-NodeMCU-MQTT-Publish-BME680-Temperature-Humidity-Pressure-Gas-Readings-Arduino-IDE.jpg?resize=768%2C432&amp;quality=100&amp;strip=all&amp;ssl=1 768w" sizes="(max-width: 1280px) 100vw, 1280px" loading="lazy"></div>
		</a>
				<div class="elementor-post__text">
				<h3 class="elementor-post__title">
			<a href="https://randomnerdtutorials.com/esp8266-nodemcu-mqtt-publish-bme680-arduino/">
				ESP8266 NodeMCU MQTT – Publish BME680 Temperature, Humidity, Pressure, and Gas Readings (Arduino IDE)			</a>
		</h3>
				</div>
					</div>
		</article>
				<article class="elementor-post elementor-grid-item post-96340 post type-post status-publish format-standard has-post-thumbnail hentry category-esp8266 category-esp8266-project category-esp8266-arduino-ide category-esp8266-projects category-0-esp8266 category-project mv-content-wrapper">
			<div class="elementor-post__card">
				<a class="elementor-post__thumbnail__link" href="https://randomnerdtutorials.com/esp8266-nodemcu-mqtt-publish-dht11-dht22-arduino/">
			<div class="elementor-post__thumbnail"><img width="1280" height="720" src="https://i2.wp.com/randomnerdtutorials.com/wp-content/uploads/2020/04/ESP8266-NodeMCU-DHT11-DHT22-Temperature-Humidity-Sensor-MQTT-Publish-Arduino-IDE-Node-RED.jpg?fit=1280%2C720&amp;quality=100&amp;strip=all&amp;ssl=1" class="attachment-full size-full" alt="ESP8266 NodeMCU MQTT Publish DHT22 or DHT11 Sensor Readings Arduino IDE" srcset="https://i2.wp.com/randomnerdtutorials.com/wp-content/uploads/2020/04/ESP8266-NodeMCU-DHT11-DHT22-Temperature-Humidity-Sensor-MQTT-Publish-Arduino-IDE-Node-RED.jpg?w=1280&amp;quality=100&amp;strip=all&amp;ssl=1 1280w, https://i2.wp.com/randomnerdtutorials.com/wp-content/uploads/2020/04/ESP8266-NodeMCU-DHT11-DHT22-Temperature-Humidity-Sensor-MQTT-Publish-Arduino-IDE-Node-RED.jpg?resize=300%2C169&amp;quality=100&amp;strip=all&amp;ssl=1 300w, https://i2.wp.com/randomnerdtutorials.com/wp-content/uploads/2020/04/ESP8266-NodeMCU-DHT11-DHT22-Temperature-Humidity-Sensor-MQTT-Publish-Arduino-IDE-Node-RED.jpg?resize=1024%2C576&amp;quality=100&amp;strip=all&amp;ssl=1 1024w, https://i2.wp.com/randomnerdtutorials.com/wp-content/uploads/2020/04/ESP8266-NodeMCU-DHT11-DHT22-Temperature-Humidity-Sensor-MQTT-Publish-Arduino-IDE-Node-RED.jpg?resize=768%2C432&amp;quality=100&amp;strip=all&amp;ssl=1 768w" sizes="(max-width: 1280px) 100vw, 1280px" loading="lazy"></div>
		</a>
				<div class="elementor-post__text">
				<h3 class="elementor-post__title">
			<a href="https://randomnerdtutorials.com/esp8266-nodemcu-mqtt-publish-dht11-dht22-arduino/">
				ESP8266 NodeMCU MQTT – Publish DHT11/DHT22 Temperature and Humidity Readings (Arduino IDE)			</a>
		</h3>
				</div>
					</div>
		</article>
				</div>


		
				</div>
				</div>
						</div>
					</div>
		</div>
								</div>
					</div>
		</section>
				</div>
		</div>
		
<br>
		<div data-elementor-type="section" data-elementor-id="82829" class="elementor elementor-82829" data-elementor-settings="[]">
		<div class="elementor-section-wrap">
					<section class="elementor-section elementor-top-section elementor-element elementor-element-1e028b5e elementor-section-boxed elementor-section-height-default elementor-section-height-default" data-id="1e028b5e" data-element_type="section">
						<div class="elementor-container elementor-column-gap-default">
							<div class="elementor-row">
					<div class="elementor-column elementor-col-100 elementor-top-column elementor-element elementor-element-69628243" data-id="69628243" data-element_type="column">
			<div class="elementor-column-wrap elementor-element-populated">
							<div class="elementor-widget-wrap">
						<section class="elementor-section elementor-inner-section elementor-element elementor-element-4a02bbce elementor-section-boxed elementor-section-height-default elementor-section-height-default" data-id="4a02bbce" data-element_type="section">
						<div class="elementor-container elementor-column-gap-default">
							<div class="elementor-row">
					<div class="elementor-column elementor-col-100 elementor-inner-column elementor-element elementor-element-3a76ce22" data-id="3a76ce22" data-element_type="column">
			<div class="elementor-column-wrap elementor-element-populated">
							<div class="elementor-widget-wrap">
						<div class="elementor-element elementor-element-d86fe9d elementor-widget elementor-widget-heading" data-id="d86fe9d" data-element_type="widget" data-widget_type="heading.default">
				<div class="elementor-widget-container">
			<h3 class="elementor-heading-title elementor-size-default">Enjoyed this project? Stay updated by subscribing our newsletter!</h3>		</div>
				</div>
				<div class="elementor-element elementor-element-93ef837 elementor-button-align-stretch elementor-widget elementor-widget-form" data-id="93ef837" data-element_type="widget" data-settings='{"button_width":"33","step_next_label":"Next","step_previous_label":"Previous","step_type":"number_text","step_icon_shape":"circle"}' data-widget_type="form.default">
				<div class="elementor-widget-container">
					<form class="elementor-form" method="post" name="New Form">
			<input type="hidden" name="post_id" value="82829">
			<input type="hidden" name="form_id" value="93ef837">
			<input type="hidden" name="referer_title" value="ESP32/ESP8266: Firebase Authentication (Email and Password) | Random Nerd Tutorials">

							<input type="hidden" name="queried_id" value="107356">
			
			<div class="elementor-form-fields-wrapper elementor-labels-">
								<div class="elementor-field-type-email elementor-field-group elementor-column elementor-field-group-email elementor-col-66 elementor-field-required">
					<label for="form-field-email" class="elementor-field-label elementor-screen-only">Email</label><input size="1" type="email" name="form_fields[email]" id="form-field-email" class="elementor-field elementor-size-sm  elementor-field-textual" placeholder="Your Email Address" required="required" aria-required="true">				</div>
								<div class="elementor-field-group elementor-column elementor-field-type-submit elementor-col-33 e-form__buttons">
					<button type="submit" class="elementor-button elementor-size-sm">
						<span>
															<span class=" elementor-button-icon">
																										</span>
																						<span class="elementor-button-text">SUBSCRIBE</span>
													</span>
					</button>
				</div>
			</div>
		</form>
				</div>
				</div>
						</div>
					</div>
		</div>
								</div>
					</div>
		</section>
						</div>
					</div>
		</div>
								</div>
					</div>
		</section>
				</div>
		</div>
			</div>
</article>

			<div class="comments-area">
				<div id="comments" style="content-visibility:auto;contain-intrinsic-size:1px 1000px;">

	<h3 class="comments-title">5 thoughts on “ESP32/ESP8266: Firebase Authentication (Email and Password)”</h3>
		<ol class="comment-list">
			
		<li id="comment-692690" class="comment even thread-even depth-1 parent">
			<article id="div-comment-692690" class="comment-body" itemtype="https://schema.org/Comment" itemscope>
				<footer class="comment-meta" style="content-visibility:auto;contain-intrinsic-size:1px 1000px;">
					<img alt="" src="https://secure.gravatar.com/avatar/7543ec3977906ec3246732d078803c48?s=50&amp;d=mm&amp;r=g" srcset="https://secure.gravatar.com/avatar/7543ec3977906ec3246732d078803c48?s=100&amp;d=mm&amp;r=g 2x" class="avatar avatar-50 photo" height="50" width="50" loading="lazy">					<div class="comment-author-info">
						<div class="comment-author vcard" itemprop="author" itemtype="https://schema.org/Person" itemscope>
							<cite itemprop="name" class="fn">Sagar Kayarkar</cite>						</div>

						<div class="entry-meta comment-metadata">
							<a href="https://randomnerdtutorials.com/esp32-esp8266-firebase-authentication/#comment-692690">
								<time datetime="2021-11-02T04:55:49+00:00" itemprop="datePublished">
									November 2, 2021 at 4:55 am								</time>
							</a>
													</div>
					</div>

									</footer>

				<div class="comment-content" itemprop="text">
					<p>Please create the tutorial for run time wifi credentials addition .it hard to add the wifi password and I’d hard-coded for scalable product</p>
<span class="reply"><a rel="nofollow" class="comment-reply-link" href="https://randomnerdtutorials.com/esp32-esp8266-firebase-authentication/?replytocom=692690#respond" data-commentid="692690" data-postid="107356" data-belowelement="div-comment-692690" data-respondelement="respond" data-replyto="Reply to Sagar Kayarkar" aria-label="Reply to Sagar Kayarkar">Reply</a></span>				</div>
			</article>
			<ul class="children">

		<li id="comment-692974" class="comment byuser comment-author-sara-santos bypostauthor odd alt depth-2">
			<article id="div-comment-692974" class="comment-body" itemtype="https://schema.org/Comment" itemscope>
				<footer class="comment-meta" style="content-visibility:auto;contain-intrinsic-size:1px 1000px;">
					<img alt="" src="https://secure.gravatar.com/avatar/25e3da92f25bc3fde695d9c0d92207b0?s=50&amp;d=mm&amp;r=g" srcset="https://secure.gravatar.com/avatar/25e3da92f25bc3fde695d9c0d92207b0?s=100&amp;d=mm&amp;r=g 2x" class="avatar avatar-50 photo" height="50" width="50" loading="lazy">					<div class="comment-author-info">
						<div class="comment-author vcard" itemprop="author" itemtype="https://schema.org/Person" itemscope>
							<cite itemprop="name" class="fn">Sara Santos</cite>						</div>

						<div class="entry-meta comment-metadata">
							<a href="https://randomnerdtutorials.com/esp32-esp8266-firebase-authentication/#comment-692974">
								<time datetime="2021-11-02T15:25:51+00:00" itemprop="datePublished">
									November 2, 2021 at 3:25 pm								</time>
							</a>
													</div>
					</div>

									</footer>

				<div class="comment-content" itemprop="text">
					<p>Hi.<br>
You can use the WiFi Manager library.<br>
For example: <a href="https://github.com/zhouhan0126/WIFIMANAGER-ESP32" rel="nofollow ugc">https://github.com/zhouhan0126/WIFIMANAGER-ESP32</a><br>
Regards,<br>
Sara</p>
<span class="reply"><a rel="nofollow" class="comment-reply-link" href="https://randomnerdtutorials.com/esp32-esp8266-firebase-authentication/?replytocom=692974#respond" data-commentid="692974" data-postid="107356" data-belowelement="div-comment-692974" data-respondelement="respond" data-replyto="Reply to Sara Santos" aria-label="Reply to Sara Santos">Reply</a></span>				</div>
			</article>
			</li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->

		<li id="comment-693180" class="comment even thread-odd thread-alt depth-1 parent">
			<article id="div-comment-693180" class="comment-body" itemtype="https://schema.org/Comment" itemscope>
				<footer class="comment-meta" style="content-visibility:auto;contain-intrinsic-size:1px 1000px;">
					<img alt="" src="https://secure.gravatar.com/avatar/3f51c44e31f6309e8bc2fcf1d604967c?s=50&amp;d=mm&amp;r=g" srcset="https://secure.gravatar.com/avatar/3f51c44e31f6309e8bc2fcf1d604967c?s=100&amp;d=mm&amp;r=g 2x" class="avatar avatar-50 photo" height="50" width="50" loading="lazy">					<div class="comment-author-info">
						<div class="comment-author vcard" itemprop="author" itemtype="https://schema.org/Person" itemscope>
							<cite itemprop="name" class="fn">Om S Anavekar</cite>						</div>

						<div class="entry-meta comment-metadata">
							<a href="https://randomnerdtutorials.com/esp32-esp8266-firebase-authentication/#comment-693180">
								<time datetime="2021-11-02T23:27:19+00:00" itemprop="datePublished">
									November 2, 2021 at 11:27 pm								</time>
							</a>
													</div>
					</div>

									</footer>

				<div class="comment-content" itemprop="text">
					<p>Excellent tutorial! Would this solution work for multiple users using the same email address/password? For example, if a user has multiple ESP-32 devices in their home and wanted to connect all of them to the database, can each ESP-32 have the same email/password?</p>
<span class="reply"><a rel="nofollow" class="comment-reply-link" href="https://randomnerdtutorials.com/esp32-esp8266-firebase-authentication/?replytocom=693180#respond" data-commentid="693180" data-postid="107356" data-belowelement="div-comment-693180" data-respondelement="respond" data-replyto="Reply to Om S Anavekar" aria-label="Reply to Om S Anavekar">Reply</a></span>				</div>
			</article>
			<ul class="children">

		<li id="comment-693207" class="comment byuser comment-author-sara-santos bypostauthor odd alt depth-2">
			<article id="div-comment-693207" class="comment-body" itemtype="https://schema.org/Comment" itemscope>
				<footer class="comment-meta" style="content-visibility:auto;contain-intrinsic-size:1px 1000px;">
					<img alt="" src="https://secure.gravatar.com/avatar/25e3da92f25bc3fde695d9c0d92207b0?s=50&amp;d=mm&amp;r=g" srcset="https://secure.gravatar.com/avatar/25e3da92f25bc3fde695d9c0d92207b0?s=100&amp;d=mm&amp;r=g 2x" class="avatar avatar-50 photo" height="50" width="50" loading="lazy">					<div class="comment-author-info">
						<div class="comment-author vcard" itemprop="author" itemtype="https://schema.org/Person" itemscope>
							<cite itemprop="name" class="fn">Sara Santos</cite>						</div>

						<div class="entry-meta comment-metadata">
							<a href="https://randomnerdtutorials.com/esp32-esp8266-firebase-authentication/#comment-693207">
								<time datetime="2021-11-03T00:54:19+00:00" itemprop="datePublished">
									November 3, 2021 at 12:54 am								</time>
							</a>
													</div>
					</div>

									</footer>

				<div class="comment-content" itemprop="text">
					<p>Yes.<br>
That is possible.<br>
Regards,<br>
Sara</p>
<span class="reply"><a rel="nofollow" class="comment-reply-link" href="https://randomnerdtutorials.com/esp32-esp8266-firebase-authentication/?replytocom=693207#respond" data-commentid="693207" data-postid="107356" data-belowelement="div-comment-693207" data-respondelement="respond" data-replyto="Reply to Sara Santos" aria-label="Reply to Sara Santos">Reply</a></span>				</div>
			</article>
			</li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->

		<li id="comment-693553" class="comment even thread-even depth-1">
			<article id="div-comment-693553" class="comment-body" itemtype="https://schema.org/Comment" itemscope>
				<footer class="comment-meta" style="content-visibility:auto;contain-intrinsic-size:1px 1000px;">
					<img alt="" src="https://secure.gravatar.com/avatar/17a46b6e120ad7361c57fa5ddbd3e500?s=50&amp;d=mm&amp;r=g" srcset="https://secure.gravatar.com/avatar/17a46b6e120ad7361c57fa5ddbd3e500?s=100&amp;d=mm&amp;r=g 2x" class="avatar avatar-50 photo" height="50" width="50" loading="lazy">					<div class="comment-author-info">
						<div class="comment-author vcard" itemprop="author" itemtype="https://schema.org/Person" itemscope>
							<cite itemprop="name" class="fn">Rodrigo Brasil</cite>						</div>

						<div class="entry-meta comment-metadata">
							<a href="https://randomnerdtutorials.com/esp32-esp8266-firebase-authentication/#comment-693553">
								<time datetime="2021-11-03T17:26:12+00:00" itemprop="datePublished">
									November 3, 2021 at 5:26 pm								</time>
							</a>
													</div>
					</div>

									</footer>

				<div class="comment-content" itemprop="text">
					<p>Hey Sara, great job!</p>
<span class="reply"><a rel="nofollow" class="comment-reply-link" href="https://randomnerdtutorials.com/esp32-esp8266-firebase-authentication/?replytocom=693553#respond" data-commentid="693553" data-postid="107356" data-belowelement="div-comment-693553" data-respondelement="respond" data-replyto="Reply to Rodrigo Brasil" aria-label="Reply to Rodrigo Brasil">Reply</a></span>				</div>
			</article>
			</li><!-- #comment-## -->
		</ol><!-- .comment-list -->

			<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Comment <small><a rel="nofollow" id="cancel-comment-reply-link" href="/esp32-esp8266-firebase-authentication/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://randomnerdtutorials.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><p class="comment-form-comment"><label for="comment" class="screen-reader-text">Comment</label><textarea id="comment" name="comment" cols="45" rows="8" aria-required="true" required></textarea></p><label for="author" class="screen-reader-text">Name</label><input placeholder="Name *" id="author" name="author" type="text" value="" size="30">
<label for="email" class="screen-reader-text">Email</label><input placeholder="Email *" id="email" name="email" type="email" value="" size="30">
<label for="url" class="screen-reader-text">Website</label><input placeholder="Website" id="url" name="url" type="url" value="" size="30">
<p class="comment-subscription-form"><input type="checkbox" name="subscribe_comments" id="subscribe_comments" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;"> <label class="subscribe-label" id="subscribe-label" for="subscribe_comments">Notify me of follow-up comments by email.</label></p><p class="comment-subscription-form"><input type="checkbox" name="subscribe_blog" id="subscribe_blog" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;"> <label class="subscribe-label" id="subscribe-blog-label" for="subscribe_blog">Notify me of new posts by email.</label></p><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment"> <input type="hidden" name="comment_post_ID" value="107356" id="comment_post_ID">
<input type="hidden" name="comment_parent" id="comment_parent" value="0">
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="64cf717c31"></p><input type="hidden" id="ak_js" name="ak_js" value="145"><textarea name="ak_hp_textarea" cols="45" rows="8" maxlength="100" style="display: none !important;"></textarea></form>	</div><!-- #respond -->
	
</div><!-- #comments -->
			</div>

					</main>
	</div>

	<div id="left-sidebar" class="widget-area sidebar is-left-sidebar grid-15 tablet-grid-15 mobile-grid-100 grid-parent pull-60 tablet-pull-60" itemtype="https://schema.org/WPSideBar" itemscope>
	<div class="inside-left-sidebar">
		<aside id="text-54" class="widget inner-padding widget_text">			<div class="textwidget"><div class="rnt-sb-m">
<p><span class="rnt-shl">Learn ESP32</span></p>
<p><a href="https://randomnerdtutorials.com/getting-started-with-esp32/">ESP32 Introduction</a></p>
<p><a href="https://randomnerdtutorials.com/installing-the-esp32-board-in-arduino-ide-windows-instructions/">ESP32 Arduino IDE</a></p>
<p><a href="https://randomnerdtutorials.com/installing-esp32-arduino-ide-2-0/">ESP32 Arduino IDE 2.0</a></p>
<p><a href="https://randomnerdtutorials.com/vs-code-platformio-ide-esp32-esp8266-arduino/">VS Code and PlatformIO</a></p>
<p><a href="https://randomnerdtutorials.com/esp32-pinout-reference-gpios/">ESP32 Pinout</a></p>
<p><a href="https://randomnerdtutorials.com/esp32-digital-inputs-outputs-arduino/">ESP32 Inputs Outputs</a></p>
<p><a href="https://randomnerdtutorials.com/esp32-pwm-arduino-ide/">ESP32 PWM</a></p>
<p><a href="https://randomnerdtutorials.com/esp32-adc-analog-read-arduino-ide/">ESP32 Analog Inputs</a></p>
<p><a href="https://randomnerdtutorials.com/esp32-pir-motion-sensor-interrupts-timers/">ESP32 Interrupts Timers</a></p>
<p><a href="https://randomnerdtutorials.com/esp32-deep-sleep-arduino-ide-wake-up-sources/">ESP32 Deep Sleep</a></p>
<p><span class="rnt-shl">Protocols</span></p>
<p><a href="https://randomnerdtutorials.com/esp32-web-server-arduino-ide/">ESP32 Web Server</a></p>
<p><a href="https://randomnerdtutorials.com/esp32-lora-rfm95-transceiver-arduino-ide/">ESP32 LoRa</a></p>
<p><a href="https://randomnerdtutorials.com/esp32-bluetooth-low-energy-ble-arduino-ide/">ESP32 BLE</a></p>
<p><a href="https://randomnerdtutorials.com/esp32-bluetooth-classic-arduino-ide/">ESP32 Bluetooth</a></p>
<p><a href="https://randomnerdtutorials.com/esp32-mqtt-publish-subscribe-arduino-ide/">ESP32 MQTT</a></p>
<p><a href="https://randomnerdtutorials.com/esp-now-esp32-arduino-ide/">ESP32 ESP-NOW</a></p>
<p><a href="https://randomnerdtutorials.com/esp32-client-server-wi-fi/">ESP32 Wi-Fi</a></p>
<p><a href="https://randomnerdtutorials.com/esp32-websocket-server-arduino/">ESP32 WebSocket</a></p>
<p><a href="https://randomnerdtutorials.com/esp-mesh-esp32-esp8266-painlessmesh/">ESP32 ESP-MESH</a></p>
<p><a href="https://randomnerdtutorials.com/esp32-send-email-smtp-server-arduino-ide/">ESP32 Email</a></p>
<p><a href="https://randomnerdtutorials.com/esp32-sim800l-send-text-messages-sms/">ESP32 Text Messages</a></p>
<p><a href="https://randomnerdtutorials.com/esp32-http-get-post-arduino/">ESP32 HTTP GET POST</a></p>
<p><a href="https://randomnerdtutorials.com/esp32-http-get-open-weather-map-thingspeak-arduino/">HTTP GET Web APIs</a></p>
<p><a href="https://randomnerdtutorials.com/esp32-http-post-ifttt-thingspeak-arduino/">HTTP POST Web APIs</a></p>
<p><a href="https://randomnerdtutorials.com/esp32-web-server-sent-events-sse/">Server-Sent Events</a></p>
<p><span class="rnt-shl">Web Servers</span></p>
<p><a href="https://randomnerdtutorials.com/esp32-web-server-arduino-ide/">Output Web Server</a></p>
<p><a href="https://randomnerdtutorials.com/esp32-web-server-slider-pwm/">PWM Slider Web Server</a></p>
<p><a href="https://randomnerdtutorials.com/esp32-web-server-websocket-sliders/">PWM Multiple Sliders Web Server</a></p>
<p><a href="https://randomnerdtutorials.com/esp32-async-web-server-espasyncwebserver-library/">Async Web Server</a></p>
<p><a href="https://randomnerdtutorials.com/esp32-relay-module-ac-web-server/">Relay Web Server</a></p>
<p><a href="https://randomnerdtutorials.com/esp32-servo-motor-web-server-arduino-ide/">Servo Web Server</a></p>
<p><a href="https://randomnerdtutorials.com/esp32-dht11-dht22-temperature-humidity-web-server-arduino-ide/">DHT Web Server</a></p>
<p><a href="https://randomnerdtutorials.com/esp32-web-server-with-bme280-mini-weather-station/">BME280 Web Server</a></p>
<p><a href="https://randomnerdtutorials.com/esp32-bme680-web-server-arduino/">BME680 Web Server</a></p>
<p><a href="https://randomnerdtutorials.com/esp32-ds18b20-temperature-arduino-ide/">DS18B20 Web Server</a></p>
<p><a href="https://randomnerdtutorials.com/esp32-lora-sensor-web-server/">LoRa Web Server</a></p>
<p><a href="https://randomnerdtutorials.com/esp32-esp8266-plot-chart-web-server/">Plot/Chart Web Server</a></p>
<p><a href="https://randomnerdtutorials.com/esp32-plot-readings-charts-multiple/">Chart Multiple Series Web Server</a></p>
<p><a href="https://randomnerdtutorials.com/esp32-web-server-spiffs-spi-flash-file-system/">SPIFFS Web Server</a></p>
<p><a href="https://randomnerdtutorials.com/esp32-esp8266-thermostat-web-server/">Thermostat Web Server</a></p>
<p><a href="https://randomnerdtutorials.com/esp32-esp8266-web-server-outputs-momentary-switch/">Momentary Switch Web Server</a></p>
<p><a href="https://randomnerdtutorials.com/esp32-esp8266-web-server-physical-button/">Physical Button Web Server</a></p>
<p><a href="https://randomnerdtutorials.com/esp32-esp8266-input-data-html-form/">Input Fields Web Server</a></p>
<p><a href="https://randomnerdtutorials.com/display-images-esp32-esp8266-web-server/">Images Web Server</a></p>
<p><a href="https://randomnerdtutorials.com/esp32-esp8266-rgb-led-strip-web-server/">RGB LED Web Server</a></p>
<p><a href="https://randomnerdtutorials.com/esp32-esp8266-web-server-timer-pulse/">Timer/Pulse Web Server</a></p>
<p><a href="https://randomnerdtutorials.com/esp32-esp8266-web-server-http-authentication/">HTTP Auth Web Server</a></p>
<p><a href="https://randomnerdtutorials.com/esp32-mpu-6050-web-server/">MPU-6050 Web Server</a></p>
<p><a href="https://randomnerdtutorials.com/esp32-web-server-microsd-card/">MicroSD Card Web Server</a></p>
<p><a href="https://randomnerdtutorials.com/stepper-motor-esp32-web-server/">Stepper Motor Web Server</a></p>
<p><span class="rnt-shl">DIY Cloud</span></p>
<p><a href="https://randomnerdtutorials.com/cloud-weather-station-esp32-esp8266/">ESP32 Weather Station</a></p>
<p><a href="https://randomnerdtutorials.com/control-esp32-esp8266-gpios-from-anywhere/">Control GPIOs</a></p>
<p><a href="https://randomnerdtutorials.com/visualize-esp32-esp8266-sensor-readings-from-anywhere/">View Sensor Readings</a></p>
<p><a href="https://randomnerdtutorials.com/esp32-esp8266-mysql-database-php/">ESP32 MySQL</a></p>
<p><a href="https://randomnerdtutorials.com/esp32-esp8266-send-email-notification/">ESP32 PHP Email</a></p>
<p><a href="https://randomnerdtutorials.com/esp32-sim800l-publish-data-to-cloud/">ESP32 SIM800L</a></p>
<p><a href="https://randomnerdtutorials.com/access-node-red-dashboard-anywhere-digital-ocean/">Cloud Node-RED Dashboard</a></p>
<p><a href="https://randomnerdtutorials.com/cloud-mqtt-mosquitto-broker-access-anywhere-digital-ocean/">Cloud MQTT Broker</a></p>
<p><a href="https://randomnerdtutorials.com/esp32-cloud-mqtt-broker-sim800l/">ESP32 Cloud MQTT</a></p>
<p><span class="rnt-shl">ESP-NOW</span></p>
<p><a href="https://randomnerdtutorials.com/esp-now-esp32-arduino-ide/">ESP-NOW Introduction</a></p>
<p><a href="https://randomnerdtutorials.com/esp-now-two-way-communication-esp32/">ESP-NOW Two-Way</a></p>
<p><a href="https://randomnerdtutorials.com/esp-now-one-to-many-esp32-esp8266/">ESP-NOW One-to-Many</a></p>
<p><a href="https://randomnerdtutorials.com/esp-now-many-to-one-esp32/">ESP-NOW Many-to-One</a></p>
<p><a href="https://randomnerdtutorials.com/esp32-esp-now-wi-fi-web-server/">ESP-NOW + Wi-Fi Web Server</a></p>
<p><span class="rnt-shl">Firebase</span></p>
<p><a href="https://randomnerdtutorials.com/esp32-firebase-realtime-database/">Firebase Realtime Database</a></p>
<p><a href="https://randomnerdtutorials.com/esp32-firebase-web-app/">Firebase Web App</a></p>
<p><span class="rnt-shl">Modules</span></p>
<p><a href="https://randomnerdtutorials.com/esp32-relay-module-ac-web-server/">ESP32 Relay Module</a></p>
<p><a href="https://randomnerdtutorials.com/esp32-dc-motor-l298n-motor-driver-control-speed-direction/">ESP32 DC Motors</a></p>
<p><a href="https://randomnerdtutorials.com/esp32-servo-motor-web-server-arduino-ide/">ESP32 Servo</a></p>
<p><a href="https://randomnerdtutorials.com/esp32-stepper-motor-28byj-48-uln2003/">ESP32 Stepper Motor</a></p>
<p><a href="https://randomnerdtutorials.com/esp32-microsd-card-arduino/">ESP32 MicroSD Card</a></p>
<p><a href="https://randomnerdtutorials.com/esp32-data-logging-temperature-to-microsd-card/">ESP32 MicroSD Card Data Logging</a></p>
<p><a href="https://randomnerdtutorials.com/esp32-pir-motion-sensor-interrupts-timers/">ESP32 PIR</a></p>
<p><a href="https://randomnerdtutorials.com/esp32-hc-sr04-ultrasonic-arduino/">ESP32 HC-SR04</a></p>
<p><a href="https://randomnerdtutorials.com/tca9548a-i2c-multiplexer-esp32-esp8266-arduino/">ESP32 I2C Multiplexer</a></p>
<p><span class="rnt-shl">Sensors</span></p>
<p><a href="https://randomnerdtutorials.com/esp32-dht11-dht22-temperature-humidity-sensor-arduino-ide/">ESP32 DHT11/DHT22</a></p>
<p><a href="https://randomnerdtutorials.com/esp32-bme280-arduino-ide-pressure-temperature-humidity/">ESP32 BME280</a></p>
<p><a href="https://randomnerdtutorials.com/esp32-bme680-sensor-arduino/">ESP32 BME680</a></p>
<p><a href="https://randomnerdtutorials.com/esp32-ds18b20-temperature-arduino-ide/">ESP32 DS18B20</a></p>
<p><a href="https://randomnerdtutorials.com/esp32-multiple-ds18b20-temperature-sensors/">ESP32 Multiple DS18B20</a></p>
<p><a href="https://randomnerdtutorials.com/esp32-with-bmp180-barometric-sensor/">ESP32 BMP180</a></p>
<p><a href="https://randomnerdtutorials.com/esp32-bmp388-arduino/">ESP32 BMP388</a></p>
<p><a href="https://randomnerdtutorials.com/esp32-mqtt-publish-dht11-dht22-arduino/">MQTT DHT11/DHT22</a></p>
<p><a href="https://randomnerdtutorials.com/esp32-mqtt-publish-bme280-arduino/">MQTT BME280</a></p>
<p><a href="https://randomnerdtutorials.com/esp32-mqtt-publish-bme680-arduino/">MQTT BME680</a></p>
<p><a href="https://randomnerdtutorials.com/esp32-mqtt-publish-ds18b20-temperature-arduino/">MQTT DS18B20</a></p>
<p><a href="https://randomnerdtutorials.com/esp32-mpu-6050-accelerometer-gyroscope-arduino/">ESP32 MPU-6050</a></p>
<p><span class="rnt-shl">Displays</span></p>
<p><a href="https://randomnerdtutorials.com/esp32-ssd1306-oled-display-arduino-ide/">ESP32 OLED</a></p>
<p><a href="https://randomnerdtutorials.com/esp32-esp8266-i2c-lcd-arduino-ide/">ESP32 LCD</a></p>
<p><a href="https://randomnerdtutorials.com/esp32-esp8266-dht-temperature-and-humidity-oled-display/">OLED Temperature</a></p>
<p><span class="rnt-shl">ESP32 Features</span></p>
<p><a href="https://randomnerdtutorials.com/esp32-hall-effect-sensor/">ESP32 Hall Sensor</a></p>
<p><a href="https://randomnerdtutorials.com/esp32-touch-pins-arduino-ide/">ESP32 Touch Sensor</a></p>
<p><a href="https://randomnerdtutorials.com/esp32-i2c-communication-arduino-ide/">ESP32 I2C</a></p>
<p><a href="https://randomnerdtutorials.com/esp32-flash-memory/">ESP32 Flash Memory</a></p>
<p><a href="https://randomnerdtutorials.com/esp32-dual-core-arduino-ide/">ESP32 Dual Core</a></p>
<p><span class="rnt-shl">Useful Guides</span></p>
<p><a href="https://randomnerdtutorials.com/esp32-troubleshooting-guide/">ESP32 Troubleshooting</a></p>
<p><a href="https://randomnerdtutorials.com/esp32-access-point-ap-web-server/">ESP32 Access Point</a></p>
<p><a href="https://randomnerdtutorials.com/esp32-static-fixed-ip-address-arduino-ide/">ESP32 Fixed IP Address</a></p>
<p><a href="https://randomnerdtutorials.com/get-change-esp32-esp8266-mac-address-arduino/">ESP32 MAC Address</a></p>
<p><a href="https://randomnerdtutorials.com/esp32-set-custom-hostname-arduino/">ESP32 Hostname</a></p>
<p><a href="https://randomnerdtutorials.com/esp32-over-the-air-ota-programming/">ESP32 OTA</a></p>
<p><a href="https://randomnerdtutorials.com/esp32-ota-over-the-air-arduino/">ESP32 OTA Arduino</a></p>
<p><a href="https://randomnerdtutorials.com/esp32-ota-over-the-air-vs-code/">ESP32 OTA VS Code</a></p>
<p><a href="https://randomnerdtutorials.com/power-esp32-esp8266-solar-panels-battery-level-monitoring/">ESP32 Solar Panels</a></p>
<p><a href="https://randomnerdtutorials.com/alexa-echo-with-esp32-and-esp8266/">ESP32 Alexa</a></p>
<p><a href="https://randomnerdtutorials.com/install-esp32-filesystem-uploader-arduino-ide/">ESP32 Install SPIFFS</a></p>
<p><a href="https://randomnerdtutorials.com/esp32-date-time-ntp-client-server-arduino/">ESP32 Time and Date</a></p>
<p><a href="https://randomnerdtutorials.com/epoch-unix-time-esp32-arduino/">ESP32 Epoch Time</a></p>
<p><a href="https://randomnerdtutorials.com/esp32-esp8266-publish-sensor-readings-to-google-sheets/">ESP32 Google Sheets</a></p>
<p><a href="https://randomnerdtutorials.com/esp32-email-alert-temperature-threshold/">ESP32 Email Altert</a></p>
<p><a href="https://randomnerdtutorials.com/esp32-thingspeak-publish-arduino/">ESP32 ThingSpeak</a></p>
<p><a href="https://randomnerdtutorials.com/build-an-all-in-one-esp32-weather-station-shield/">Weather Station Shield</a></p>
<p><a href="https://randomnerdtutorials.com/esp32-iot-shield-pcb-dashboard/">ESP32 IoT Shield</a></p>
<p><a href="https://randomnerdtutorials.com/esp32-weather-station-pcb/">ESP32 Weather Station PCB</a></p>
<p><a href="https://randomnerdtutorials.com/vs-code-platformio-ide-esp32-esp8266-arduino/">VS Code and PlatformIO</a></p>
<p><a href="https://randomnerdtutorials.com/esp32-vs-code-platformio-spiffs/">VS Code SPIFFS</a></p>
<p><a href="https://randomnerdtutorials.com/vs-code-workspaces-esp32-esp8266/">VS Code Workspaces</a></p>
<p><a href="https://randomnerdtutorials.com/esp32-save-data-permanently-preferences/">Save Data Preferences Library</a></p>
<p><a href="https://randomnerdtutorials.com/solved-reconnect-esp32-to-wifi/">Reconnect to Wi-Fi</a></p>
<p><a href="https://randomnerdtutorials.com/esp32-useful-wi-fi-functions-arduino/">Useful Wi-Fi Functions</a></p>
<p><span class="rnt-shl">Other Projects</span></p>
<p><a href="https://randomnerdtutorials.com/telegram-control-esp32-esp8266-nodemcu-outputs/">Telegram Control Outputs</a></p>
<p><a href="https://randomnerdtutorials.com/telegram-request-esp32-esp8266-nodemcu-sensor-readings/">Telegram Sensor Readings</a></p>
<p><a href="https://randomnerdtutorials.com/telegram-esp32-motion-detection-arduino/">Telegram Detect Motion</a></p>
<p><a href="https://randomnerdtutorials.com/telegram-group-esp32-esp8266/">Telegram Group</a></p>
<p><a href="https://randomnerdtutorials.com/esp32-status-indicator-sensor-pcb/">ESP32 Status PCB</a></p>
<p><a href="https://randomnerdtutorials.com/altimeter-datalogger-esp32-bmp388/">ESP32 BMP388 Datalogger</a></p>
<p><a href="https://randomnerdtutorials.com/esp32-webserial-library/">ESP32 Web Serial</a></p>
<p><a href="https://randomnerdtutorials.com/esp32-door-status-monitor-email/">ESP32 Door Monitor</a></p>
<p><span class="rnt-shl">ESP32 Boards</span></p>
<p><a href="https://randomnerdtutorials.com/esp32-cam-video-streaming-face-recognition-arduino-ide/">ESP32 Camera</a></p>
<p><a href="https://randomnerdtutorials.com/ttgo-lora32-sx1276-arduino-ide/">ESP32 LoRa</a></p>
<p><a href="https://randomnerdtutorials.com/esp32-built-in-oled-ssd1306/">ESP32 OLED</a></p>
<p><a href="https://randomnerdtutorials.com/esp32-sim800l-send-text-messages-sms/">ESP32 SIM800L</a></p>
<p><span class="rnt-shl">Learn More</span></p>
<p><a href="https://randomnerdtutorials.com/projects-esp32/">Learn ESP32</a></p>
<p><a href="https://randomnerdtutorials.com/projects-esp8266/">Learn ESP8266</a></p>
<p><a href="https://randomnerdtutorials.com/projects-esp32-cam/">Learn ESP32-CAM</a></p>
<p><a href="https://randomnerdtutorials.com/projects-esp32-esp8266-micropython/">Learn MicroPython</a></p>
<p><a href="https://randomnerdtutorials.com/projects-arduino/">Learn Arduino</a></p>
<p><a href="https://randomnerdtutorials.com/build-web-servers-esp32-esp8266-ebook/"><strong>Build Web Servers eBook</strong></a></p>
<p><a href="https://randomnerdtutorials.com/learn-esp32-with-arduino-ide/"><strong>ESP32 Premium Course »</strong></a></p>
</div>
</div>
		</aside><aside id="search-4" class="widget inner-padding widget_search"><form method="get" class="search-form" action="https://randomnerdtutorials.com/">
	<label>
		<span class="screen-reader-text">Search for:</span>
		<input type="search" class="search-field" placeholder="Search …" value="" name="s" title="Search for:">
	</label>
	<input type="submit" class="search-submit" value="Search"></form>
</aside>	</div>
</div>
<div id="right-sidebar" class="widget-area sidebar is-right-sidebar grid-25 tablet-grid-25 grid-parent" itemtype="https://schema.org/WPSideBar" itemscope>
	<div class="inside-right-sidebar">
		<aside id="text-49" class="widget inner-padding widget_text">			<div class="textwidget"><p><a href="https://makeradvisor.com/?utm_source=rnt&amp;utm_medium=sb&amp;utm_campaign=sb" target="_blank" rel="noopener"><img class="aligncenter" src="https://i2.wp.com/randomnerdtutorials.com/wp-content/uploads/2017/10/lab-sb-img.jpg?w=828&amp;quality=100&amp;strip=all" data-recalc-dims="1" loading="lazy"></a><br>
<strong><a href="https://makeradvisor.com/?utm_source=rnt&amp;utm_medium=sb&amp;utm_campaign=sb" target="_blank" rel="noopener">Visit Maker Advisor – Tools and Gear for makers, hobbyists and DIYers »</a></strong></p>
</div>
		</aside><aside id="text-47" class="widget inner-padding widget_text">			<div class="textwidget"><p><a href="https://randomnerdtutorials.com/home-automation-using-esp8266/"><img class="aligncenter" src="https://i1.wp.com/randomnerdtutorials.com/wp-content/uploads/2017/10/esp8266-sb-img.jpg?w=828&amp;quality=100&amp;strip=all" data-recalc-dims="1" loading="lazy"></a><br>
<strong><a href="https://randomnerdtutorials.com/home-automation-using-esp8266/">Home Automation using ESP8266 eBook and video course »</a> </strong>Build IoT and home automation projects.</p>
</div>
		</aside><aside id="text-46" class="widget inner-padding widget_text">			<div class="textwidget"><p><a href="https://randomnerdtutorials.com/build-a-home-automation-system-for-100/"><img class="aligncenter" src="https://i1.wp.com/randomnerdtutorials.com/wp-content/uploads/2017/10/home-automation-sb-img.jpg?w=828&amp;quality=100&amp;strip=all" data-recalc-dims="1" loading="lazy"></a><br>
<strong><a href="https://randomnerdtutorials.com/build-a-home-automation-system-for-100/">Build a Home Automation System from Scratch »</a> </strong>With Raspberry Pi, ESP8266, Arduino, and Node-RED.</p>
</div>
		</aside>	</div>
</div>

	</div>
</div>


<div class="site-footer footer-bar-active footer-bar-align-center">
			<footer class="site-info" itemtype="https://schema.org/WPFooter" itemscope style="content-visibility:auto;contain-intrinsic-size:1px 1000px;">
			<div class="inside-site-info grid-container grid-parent">
						<div class="footer-bar">
			<aside id="nav_menu-10" class="widget inner-padding widget_nav_menu"><div class="menu-footer-disclaimer-container"><ul id="menu-footer-disclaimer" class="menu"><li id="menu-item-82503" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-82503"><a href="https://randomnerdtutorials.com/about/">About</a></li>
<li id="menu-item-20492" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-20492"><a href="https://randomnerdtutorials.com/support">Support</a></li>
<li id="menu-item-20493" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-20493"><a href="https://randomnerdtutorials.com/terms">Terms and Conditions</a></li>
<li id="menu-item-20495" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-20495"><a href="https://randomnerdtutorials.com/privacy-policy/">Privacy Policy</a></li>
<li id="menu-item-20494" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-20494"><a href="https://randomnerdtutorials.com/returns-and-refunds/">Refunds</a></li>
<li id="menu-item-103055" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-103055"><a target="_blank" rel="noreferrer noopener nofollow" href="https://www.livroreclamacoes.pt/inicio/">Complaints’ Book</a></li>
<li id="menu-item-43625" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-43625"><a target="_blank" rel="noopener" href="https://makeradvisor.com/">MakerAdvisor.com</a></li>
<li id="menu-item-20496" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-20496"><a target="_blank" rel="noopener" href="https://rntlab.com/">Join the Lab</a></li>
</ul></div></aside>		</div>
						<div class="copyright-bar">
					Copyright © 2013-2021 · RandomNerdTutorials.com · All Rights Reserved				</div>
			</div>
		</footer>
		</div>

		<div data-elementor-type="popup" data-elementor-id="83058" class="elementor elementor-83058 elementor-location-popup" data-elementor-settings='{"entrance_animation":"zoomIn","close_button_position":"outside","entrance_animation_duration":{"unit":"px","size":1.2,"sizes":[]},"triggers":{"scrolling":"yes","scrolling_offset":35,"scrolling_direction":"down"},"timing":{"times":"yes","times_times":3}}'>
		<div class="elementor-section-wrap">
					<section class="elementor-section elementor-top-section elementor-element elementor-element-544e0740 elementor-section-content-bottom elementor-reverse-mobile elementor-section-boxed elementor-section-height-default elementor-section-height-default" data-id="544e0740" data-element_type="section" data-settings='{"background_background":"classic"}'>
						<div class="elementor-container elementor-column-gap-default">
							<div class="elementor-row">
					<div class="elementor-column elementor-col-100 elementor-top-column elementor-element elementor-element-676b082e" data-id="676b082e" data-element_type="column">
			<div class="elementor-column-wrap elementor-element-populated">
							<div class="elementor-widget-wrap">
						<div class="elementor-element elementor-element-5eee063c elementor-widget elementor-widget-heading" data-id="5eee063c" data-element_type="widget" data-widget_type="heading.default">
				<div class="elementor-widget-container">
			<h2 class="elementor-heading-title elementor-size-default">Download our Free eBooks and Resources</h2>		</div>
				</div>
				<div class="elementor-element elementor-element-9bd904c elementor-hidden-phone elementor-widget elementor-widget-text-editor" data-id="9bd904c" data-element_type="widget" data-widget_type="text-editor.default">
				<div class="elementor-widget-container">
								<div class="elementor-text-editor elementor-clearfix">
				<p>Get instant access to our FREE eBooks, Resources, and Exclusive Electronics Projects by entering your email address below.</p>					</div>
						</div>
				</div>
				<div class="elementor-element elementor-element-2a77907 elementor-button-align-stretch elementor-widget elementor-widget-form" data-id="2a77907" data-element_type="widget" data-settings='{"step_next_label":"Next","step_previous_label":"Previous","button_width":"100","step_type":"number_text","step_icon_shape":"circle"}' data-widget_type="form.default">
				<div class="elementor-widget-container">
					<form class="elementor-form" method="post" name="New Form">
			<input type="hidden" name="post_id" value="83058">
			<input type="hidden" name="form_id" value="2a77907">
			<input type="hidden" name="referer_title" value="ESP32/ESP8266: Firebase Authentication (Email and Password) | Random Nerd Tutorials">

							<input type="hidden" name="queried_id" value="107356">
			
			<div class="elementor-form-fields-wrapper elementor-labels-">
								<div class="elementor-field-type-email elementor-field-group elementor-column elementor-field-group-email elementor-col-100 elementor-field-required">
					<label for="form-field-email" class="elementor-field-label elementor-screen-only">Email</label><input size="1" type="email" name="form_fields[email]" id="form-field-email" class="elementor-field elementor-size-sm  elementor-field-textual" placeholder="Your Email Address" required="required" aria-required="true">				</div>
								<div class="elementor-field-group elementor-column elementor-field-type-submit elementor-col-100 e-form__buttons">
					<button type="submit" class="elementor-button elementor-size-md">
						<span>
															<span class=" elementor-button-icon">
																										</span>
																						<span class="elementor-button-text">FREE DOWNLOAD</span>
													</span>
					</button>
				</div>
			</div>
		</form>
				</div>
				</div>
						</div>
					</div>
		</div>
								</div>
					</div>
		</section>
				</div>
		</div>
		<link rel="stylesheet" data-lazy-method="interaction" data-lazy-attributes="href" data-lazy-href="https://cdnjs.cloudflare.com/ajax/libs/prism/1.23.0/themes/prism.min.css">
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script src="https://cdnjs.cloudflare.com/ajax/libs/prism/1.23.0/prism.min.js" defer></script>
<script src="https://cdnjs.cloudflare.com/ajax/libs/prism/1.23.0/components/prism-c.min.js" defer></script>
<script src="https://cdnjs.cloudflare.com/ajax/libs/prism/1.23.0/components/prism-python.min.js" defer></script>
<link rel="stylesheet" id="elementor-post-83032-css" media="all" data-lazy-method="interaction" data-lazy-attributes="href" data-lazy-href="https://randomnerdtutorials.com/wp-content/cache/flying-press/randomnerdtutorials.com/0374b13add6b.post-83032.css">
<link rel="stylesheet" id="elementor-post-82533-css" media="all" data-lazy-method="interaction" data-lazy-attributes="href" data-lazy-href="https://randomnerdtutorials.com/wp-content/cache/flying-press/randomnerdtutorials.com/32493e4e071e.post-82533.css">
<link rel="stylesheet" id="elementor-post-82829-css" media="all" data-lazy-method="interaction" data-lazy-attributes="href" data-lazy-href="https://randomnerdtutorials.com/wp-content/cache/flying-press/randomnerdtutorials.com/34c8bc3901e5.post-82829.css">
<link rel="stylesheet" id="e-animations-css" media="all" data-lazy-method="interaction" data-lazy-attributes="href" data-lazy-href="https://randomnerdtutorials.com/wp-content/cache/flying-press/randomnerdtutorials.com/4601ba550444.animations.min.css">
<script src="https://randomnerdtutorials.com/wp-content/plugins/gp-premium/menu-plus/functions/js/sticky.min.js?ver=8529d83b54e8" id="generate-sticky-js" defer></script>
<script src="https://randomnerdtutorials.com/wp-content/plugins/jetpack/_inc/build/photon/photon.min.js?ver=c29857eeb45d" id="jetpack-photon-js" defer></script>
<script src="https://randomnerdtutorials.com/wp-content/plugins/flying-press/assets/preload.min.js?ver=4dcfe7c54278" id="flying_press_preload-js" defer></script>
<!--[if lte IE 11]>
<script src='https://randomnerdtutorials.com/wp-content/themes/generatepress/assets/js/classList.min.js?ver=3.0.4' id='generate-classlist-js'></script>
<![endif]-->
<script id="generate-main-js-extra">
var generatepressMenu = {"toggleOpenedSubMenus":"1","openSubMenuLabel":"Open Sub-Menu","closeSubMenuLabel":"Close Sub-Menu"};
</script>
<script src="https://randomnerdtutorials.com/wp-content/themes/generatepress/assets/js/main.min.js?ver=9a78d8d0a506" id="generate-main-js" defer></script>
<script id="generate-navigation-search-js-extra">
var generatepressNavSearch = {"open":"Open Search Bar","close":"Close Search Bar"};
</script>
<script src="https://randomnerdtutorials.com/wp-content/themes/generatepress/assets/js/navigation-search.min.js?ver=454ed58c0f6c" id="generate-navigation-search-js" defer></script>
<script src="https://randomnerdtutorials.com/wp-includes/js/comment-reply.min.js?ver=3b59c3b33879" id="comment-reply-js"></script>
<script src="https://randomnerdtutorials.com/wp-includes/js/wp-embed.min.js?ver=905225d5711b" id="wp-embed-js"></script>
<script src="https://randomnerdtutorials.com/wp-includes/js/imagesloaded.min.js?ver=3a56752b7366" id="imagesloaded-js"></script>
<script defer src="https://randomnerdtutorials.com/wp-content/cache/flying-press/randomnerdtutorials.com/270f0cd7341b.form.js" id="akismet-form-js"></script>
<script src="https://randomnerdtutorials.com/wp-content/plugins/elementor-pro/assets/js/webpack-pro.runtime.min.js?ver=2ea4590f80f3" id="elementor-pro-webpack-runtime-js" defer></script>
<script src="https://randomnerdtutorials.com/wp-content/plugins/elementor/assets/js/webpack.runtime.min.js?ver=02298369a672" id="elementor-webpack-runtime-js" defer></script>
<script src="https://randomnerdtutorials.com/wp-content/plugins/elementor/assets/js/frontend-modules.min.js?ver=4a4dc12b16a4" id="elementor-frontend-modules-js" defer></script>
<script id="elementor-pro-frontend-js-before">
var ElementorProFrontendConfig = {"ajaxurl":"https:\/\/randomnerdtutorials.com\/wp-admin\/admin-ajax.php","nonce":"f183f1bf1b","urls":{"assets":"https:\/\/randomnerdtutorials.com\/wp-content\/plugins\/elementor-pro\/assets\/","rest":"https:\/\/randomnerdtutorials.com\/wp-json\/"},"i18n":{"toc_no_headings_found":"No headings were found on this page."},"shareButtonsNetworks":{"facebook":{"title":"Facebook","has_counter":true},"twitter":{"title":"Twitter"},"google":{"title":"Google+","has_counter":true},"linkedin":{"title":"LinkedIn","has_counter":true},"pinterest":{"title":"Pinterest","has_counter":true},"reddit":{"title":"Reddit","has_counter":true},"vk":{"title":"VK","has_counter":true},"odnoklassniki":{"title":"OK","has_counter":true},"tumblr":{"title":"Tumblr"},"digg":{"title":"Digg"},"skype":{"title":"Skype"},"stumbleupon":{"title":"StumbleUpon","has_counter":true},"mix":{"title":"Mix"},"telegram":{"title":"Telegram"},"pocket":{"title":"Pocket","has_counter":true},"xing":{"title":"XING","has_counter":true},"whatsapp":{"title":"WhatsApp"},"email":{"title":"Email"},"print":{"title":"Print"}},"facebook_sdk":{"lang":"en_US","app_id":""},"lottie":{"defaultAnimationUrl":"https:\/\/randomnerdtutorials.com\/wp-content\/plugins\/elementor-pro\/modules\/lottie\/assets\/animations\/default.json"}};
</script>
<script src="https://randomnerdtutorials.com/wp-content/plugins/elementor-pro/assets/js/frontend.min.js?ver=92f231b80369" id="elementor-pro-frontend-js" defer></script>
<script src="https://randomnerdtutorials.com/wp-content/plugins/elementor/assets/lib/waypoints/waypoints.min.js?ver=3819c3569da7" id="elementor-waypoints-js" defer></script>
<script src="https://randomnerdtutorials.com/wp-includes/js/jquery/ui/core.min.js?ver=49fa677b9cd7" id="jquery-ui-core-js"></script>
<script src="https://randomnerdtutorials.com/wp-content/plugins/elementor/assets/lib/swiper/swiper.min.js?ver=15bb2b8491fc" id="swiper-js" defer></script>
<script src="https://randomnerdtutorials.com/wp-content/plugins/elementor/assets/lib/share-link/share-link.min.js?ver=9bb8540493a7" id="share-link-js" defer></script>
<script src="https://randomnerdtutorials.com/wp-content/plugins/elementor/assets/lib/dialog/dialog.min.js?ver=58baf0f238d7" id="elementor-dialog-js" defer></script>
<script id="elementor-frontend-js-before">
var elementorFrontendConfig = {"environmentMode":{"edit":false,"wpPreview":false,"isScriptDebug":false},"i18n":{"shareOnFacebook":"Share on Facebook","shareOnTwitter":"Share on Twitter","pinIt":"Pin it","download":"Download","downloadImage":"Download image","fullscreen":"Fullscreen","zoom":"Zoom","share":"Share","playVideo":"Play Video","previous":"Previous","next":"Next","close":"Close"},"is_rtl":false,"breakpoints":{"xs":0,"sm":480,"md":768,"lg":1025,"xl":1440,"xxl":1600},"responsive":{"breakpoints":{"mobile":{"label":"Mobile","value":767,"default_value":767,"direction":"max","is_enabled":true},"mobile_extra":{"label":"Mobile Extra","value":880,"default_value":880,"direction":"max","is_enabled":false},"tablet":{"label":"Tablet","value":1024,"default_value":1024,"direction":"max","is_enabled":true},"tablet_extra":{"label":"Tablet Extra","value":1200,"default_value":1200,"direction":"max","is_enabled":false},"laptop":{"label":"Laptop","value":1366,"default_value":1366,"direction":"max","is_enabled":false},"widescreen":{"label":"Widescreen","value":2400,"default_value":2400,"direction":"min","is_enabled":false}}},"version":"3.4.3","is_static":false,"experimentalFeatures":{"e_import_export":true,"landing-pages":true,"elements-color-picker":true,"admin-top-bar":true,"form-submissions":true},"urls":{"assets":"https:\/\/randomnerdtutorials.com\/wp-content\/plugins\/elementor\/assets\/"},"settings":{"page":[],"editorPreferences":[]},"kit":{"active_breakpoints":["viewport_mobile","viewport_tablet"],"lightbox_enable_counter":"yes","lightbox_enable_fullscreen":"yes","lightbox_enable_zoom":"yes","lightbox_enable_share":"yes","lightbox_title_src":"title","lightbox_description_src":"description"},"post":{"id":107356,"title":"ESP32%2FESP8266%3A%20Firebase%20Authentication%20%28Email%20and%20Password%29%20%7C%20Random%20Nerd%20Tutorials","excerpt":"","featuredImage":"https:\/\/i1.wp.com\/randomnerdtutorials.com\/wp-content\/uploads\/2021\/10\/ESP32-ESP8266-Firebase-Authentication-Email-Password.jpg?fit=828%2C466&quality=100&strip=all&ssl=1"}};
</script>
<script src="https://randomnerdtutorials.com/wp-content/plugins/elementor/assets/js/frontend.min.js?ver=a8d52c4a8a20" id="elementor-frontend-js" defer></script>
<script src="https://randomnerdtutorials.com/wp-content/plugins/elementor-pro/assets/js/preloaded-elements-handlers.min.js?ver=8f79f5d5d4b8" id="pro-preloaded-elements-handlers-js" defer></script>
<script src="https://randomnerdtutorials.com/wp-content/plugins/elementor/assets/js/preloaded-modules.min.js?ver=d1b24c5026b8" id="preloaded-modules-js" defer></script>
<script src="https://randomnerdtutorials.com/wp-content/plugins/elementor-pro/assets/lib/sticky/jquery.sticky.min.js?ver=e16a8821e5f0" id="e-sticky-js" defer></script>

<script>const loadElemsOnUserInteraction=function(){const t=["mouseover","keydown","touchstart","touchmove","wheel"],e=function e(){n(),clearTimeout(o),t.forEach(function(t){window.removeEventListener(t,e,{passive:!0})})};var n=function(){document.querySelectorAll("[data-lazy-method='interaction']").forEach(function(t){t.getAttribute("data-lazy-attributes").split(",").forEach(function(e){const n=t.getAttribute("data-lazy-".concat(e));t.setAttribute(e,n)})})},o=setTimeout(e,10e3);t.forEach(function(t){window.addEventListener(t,e,{passive:!0})})};loadElemsOnUserInteraction();const loadElemsOnViewPort=function(){var t=new IntersectionObserver(function(e){e.forEach(function(e){if(e.isIntersecting){t.unobserve(e.target),e.target.getAttribute("data-lazy-attributes").split(",").forEach(function(t){const n=e.target.getAttribute("data-lazy-".concat(t));e.target.setAttribute(t,n)})}})},{rootMargin:"300px"});document.querySelectorAll("[data-lazy-method='viewport']").forEach(function(e){t.observe(e)})};loadElemsOnViewPort();</script></body>
</html>